9 Replies Latest reply on Aug 16, 2018 3:18 AM by Intel Corporation

    Intel Aero FPGA_VERSION = unknown and unable to read bootloader pin value on 01.00.16 and 1.6.2

    jakeUF

      Hey everyone,

       

      I am trying to get the Initial Setup of my Intel Aero drone done.  I am currently trying to flash the FPGA using the following guides:

      https://github.com/intel-aero/meta-intel-aero/wiki/02-Initial-setup

      https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation

       

      aero-get-version.py yields

       

      BIOS_VERSION = Aero-01.00.16

      OS_VERSION = Pokey Aero (Intel Aero Linux Distro) 1.6.2 (pyro)

      AirMap_Version = 1.8

      FPGA-VERSION = unknown

      AerFC firmware version = 1.6.5

       

      following the guides, I have done

      cd /etc/fpga/

      jam -aprogram aero-rtf.jam

        this yields Exit code = 0 ... success

       

      Although, when moving to the next step of

      cd /etc/aerofc/px4/

      aerofc-update.sh nuttx-aerofc-v1-default.px4

        this gives the error of: Unable to set force bootloader pin value

       

       

      In looking up this problem I found: Install ubuntu and flashing issues.

      As following this I tried:

      uname -a

           Linux intel-aero 4.4.113-yocto-standard #1 SMP PREMPT Tue May 22 11:10:22 IST 2018 x86_64 x86_64 x86_64 GNU/Linux

       

      The above solution says this is fixed in Linux 4.4, but it can be seen that I am running 4.4 and this problem persists.

       

      If anyone could help this would be greatly appreciated.  My end goal is to do get the R200 camera working if that changes anything.