8 Replies Latest reply on Aug 5, 2018 12:52 PM by SMM77

    Ubuntu 18.04 build issue with libgtk-3-dev & libssl-dev

    SMM77

      Hi,

       

      I'm seeing the following problems when building librealsense-2.14.0 on a fresh Ubuntu 18 machine:

       

      ~/Src/RealSense$ uname -r

      4.15.0-29-generic

       

      Errors:

       

      ~/Src/RealSense$ sudo apt install libgtk-3-dev

      Reading package lists... Done

      Building dependency tree      

      Reading state information... Done

      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:

       

      The following packages have unmet dependencies:

      libgtk-3-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.30.0) but it is not going to be installed

                      Depends: libpango1.0-dev (>= 1.40.5) but it is not going to be installed

                      Depends: libcairo2-dev (>= 1.14.0) but it is not going to be installed

                      Depends: libfontconfig1-dev but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

       

       

      And:

       

      ~/Src/RealSense$ sudo apt install libssl-dev

      Reading package lists... Done

      Building dependency tree      

      Reading state information... Done

      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:

       

      The following packages have unmet dependencies:

      libssl-dev : Depends: libssl1.1 (= 1.1.0g-2ubuntu4) but 1.1.0g-2ubuntu4.1 is to be installed

                    Recommends: libssl-doc but it is not going to be installed

       

      Any advice greatly appreciated!! Thanks!