1 2 Previous Next 17 Replies Latest reply on Jan 29, 2014 11:39 AM by sylvia_intel

    Intel Dx58SO Bios issues

    msedek

      Hello, here what I have done so far:

       

      Tried to Upgrade the BIOS to solve some ram problems, the board would not allow me to run the memory at 1333, so that I needed to update it.

       

      Update method: Within Windows (claimed as "THE MOST POPULAR")

       

      Results: Everything was OK. (UPGRADED TO 5020), after the flash finished, I did some stuff on windows and turned the system off, later on when I wanted to do some more work the board does not POST, No beeps, No erros, leds are on, fans are spinning (AT TOP SPEED), and next what test I have done: 

       

      Step A:

      ===========
      Now try to boot the system only with power supply, motherboard, GFX card and cpu connected (no memory)
      Result:
      Does the board issue any beeps? yes 3 beeps, then pause, then 3 beeps again and go on... non stop.

       

      Step B:
      ===========
      Put one memory module on the board on the slot dimm 0
      Result: still black screen, also did in channel A(0,1), B and C with 1, 2 and 3 sticks and tried all the sticks 1 by 1, also tested the sticks 6 of them in another dx58so and they are OK.

       

      Step C:
      ===========
      Switch the bios jumper configuration of the board to the configuration mode
      Switch on the system
      Result: Black screen as well

       

      Last Step D: Note Update the bios using the recovery mode only
      ============
      CMOS Clear again
      Download the latest bios file from the download page website

      Copy the bio file to a fat-formatted usb memory stick

      Remove the bios jumper from the board.
      Connect the usb stick on the target machine.
      Make sure there is no other usb devices connected on the system
      Switch on the system
      Wait for the bios update to complete.
      Put back the bios jumper to its normal position
      Try to boot the machine.

       

      If it does not work, try another graphics card.
      Result:

       

      Tried ALL flashing methods (iFlash, usb stick, and cdrom), the usb ports have power cause the usb stick led turns on, but the board is not reading the data from the stick, tried with the jumper in the 3 possitions, pins(1,2), (2,3) and without jumpers (same result all cases), same with the cdrom, it does turns on, read the cd/dvd then the light turns off and nothing happens, tried 3 graphic cards, 1 nvidia 9800gt 1gb, 1 nvidia 8800 gtx 512mb and also bought(e-bay for 3$ usd) a regular PCI trident 1mb (non pci express) and tried with 3 different monitors and still nothing (all 3 cards are working fine with all 3 monitors tested on another dx58so.

       

      Also the cpu is a D0 step core I7 920 and I switched it with the other dx50so board i have and the cpu its OK, al tested the other cpu on the "DEAD BOARD", still nothing, changed the PSU 3 brands going from 550W to 1000W, and nothing, all the PSU tested with ALL THE DDR 3 STICKS(CORSAIR XMS3) 6 in total, and all this tested also with both CPUs and both board, the non  dead board works good with all the cpus and all the PSUs and all the memory, also is running the 5020 bios version.

       

      Also checked with a magnifier glass the socket pins and are OK, same as the working board.., cannot rma it cause im from Venezuela and intel does not offer that kind of service for latin america, can not go to the store where i bought it cause they got broken and there is no store anymore... is there a way to force the bios to post? or force to read the usb?. I have an acer aspire one and whenever the bios fails, i just put a usb stick on the port, press fn+esc keys then press the power and thats it, it will flash the bios no matter what..

       

      Removed the battery for 5 or more hours, replaced the battery with the Good board battery, and I ve done the WHOLE process with all the variants inclued, created a test sheet on excel and everything.

       

       

      Any help?

       

      Thanks in advance..

        • 1. Re: Intel Dx58SO Bios issues
          RJL190365

          Hello Miguel,

           

          BIOS version 5020 is now two releases old. That BIOS has so many bugs in it:

           

          First off, the default BCLK is now 135MHz instead of 133MHz.

           

          Second, attempting to manually reset the BCLK to the stock 133MHz will result in a POST failure (or more specifically, the system going into an endless cycle of reboots without ever getting past POST). The only way to fix this is to disconnect all power, remove the CMOS battery and let it sit for several minutes before reinstalling the battery and reconnecting the power.

           

          Third, at setup defaults the maximum Turbo multiplier remains at 25x instead of the proper 22x with an i7-920. BIOS versions 4598 and 5112 also have this same bug. However, forcing the memory to use an XMP profile will reset the maximum Turbo multiplier to 22x with this processor.

           

          If you have a "bricked" DX58SO, you may be able to update to a different BIOS version using the Recovery method (remove the BIOS CONFIG jumper completely and then use the recovery version of the latest BIOS saved onto a USB flash drive).

           

          The latest BIOS version for this board is 5200, as linked below:

          http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3018&DwnldID=18938&lang=eng

          • 2. Re: Intel Dx58SO Bios issues
            msedek

            I did the upgrade sometime ago.. I got my other dx58s0 working with the new BIOS released, but as i said, I did removed the battery and power cord for more than 5 hours, and is not reading the usb stick, the mobo is not posting at all, i got no video signal eather..  any suggest?

            • 3. Re: Intel Dx58SO Bios issues
              RJL190365

              How long did you wait before you gave up on the BIOS recovery?

               

              I did my update earlier today, and I had to wait three minutes from power-on before the USB flash memory stick for the BIOS recovery began to be read.

              • 4. Re: Intel Dx58SO Bios issues
                msedek

                Well I have wait several hours.. put the usb stick into the usb port, turns on the system and then I do other stuff, several hours later I go check the computer and everything its the same... any suggestion on wich port should I test?.. I am connecting the usb stick under the lan port..

                 

                Thanks for your repplies ... first person that ever cares =).. Im really exited because I feel that you will help me solve this...

                • 5. Re: Intel Dx58SO Bios issues
                  msedek

                  Do you think that if I am able to get some1 to lend me a higher cpu, lets say a 940/960 I7, they would support the 5020 new values and I would be able to post and reflash?, and by the way.. what its the best value for the BCLK 135 or 133?

                  • 6. Re: Intel Dx58SO Bios issues
                    Nico

                    default is 133, 135 is wrong.

                    • 7. Re: Intel Dx58SO Bios issues
                      msedek

                      Ok, but if my board is locked with the bclk at 135 mhz and the turbo setted at 25x and im not able to get the boar to post or anything, not even read the usb stick to be able reflash with the new bios.. then what to do..??

                       

                      Thanks in advance for any help

                      • 8. Re: Intel Dx58SO Bios issues
                        Domain

                        Is this the same board from your post back on March 11th? http://communities.intel.com/message/86891

                         

                        There have been more then a few people claim that board will not startup after some of the later BIOS revisions... I have seen this behavior myself, but in all cases either putting the board into configuration mode, or unpluging / pulling the battery to clear the CMOS has resolved the problem (I let the board boot first without battery installed).  In one case I also had to disconnect all of the SATA drives to get the board to boot, but it was actually posting video that time (though completely black screen with flashing cursor).

                         

                        Other then that, all I can say is double-check the 2x4 power connector (just below the IOH heatsink) is properly connected.  You might also try a few variations of USB sticks to see if you can get any of them to work in recovery mode... I had some issues with getting recovery mode to work at first, but I never tracked down the exactly problem (perhaps device size or partition size?).  Once I found a working USB device, I just labeled it as such, and kept it around only for recovery use (never did get CD recovery to work, even after 2-3 different drives, and multiple CD's created with various software).

                        • 9. Re: Intel Dx58SO Bios issues
                          msedek

                          Yes it is the same board, at that time I was very upset because I dont know in the US but here in Venezuela, computers and parts cost really A LOT of money, for me that was a 7k USD$ computer and who like to waste that kind of money?, I wanted to return the board to store i bought it, but unfortunately for me, the store got broken, nad Intel wont RMA a board from Venezuela South America lol.. well I ended buying an asus as a I said but i have another intel dx58so also and my "dead board" is still with me and the memory and the cpu, just came up again to see if by this time could be a solution for this..

                           

                          Seems like everything its around the same, dont know if you could read my opening for this post, and noticed all the test i have done so far, but im still with faith, and I know that I probably will make that board to post for me again ( with some help from you all guys).

                           

                          I have around 5 or 6 usb sticks, ill format all of them and try, but theres is not much to do besides to try every usb stick in every usb port and wait over 10 mins for every try..  I will also put the 6 usb  sticks at the same time with the .bio file in them and see what happen..

                           

                           

                          Thanks again for all your replies..

                          • 10. Re: Intel Dx58SO Bios issues
                            msedek

                            Oh and I know.. you will say.. HEY WHY DO STILL HAVE THE CPU AND THE MEMORY???... the asnwer to that its easy... the new vendor, had some combos and it was cheaper to buy the new mother board+new I7 920 cpu+new Corsair 1600 ram than buying only the board... in other words i paid just a few boxes more for the cpu and the memory so i decided it worth it.. and I still have a chance to resurrect somehow the bricked board and have 3 super computers instead of just 2..

                            • 11. Re: Intel Dx58SO Bios issues
                              druizm

                              After updating BIOS to last version (SOX5810J.86A.5600.2013.0729.2250 from 07/29/2013), dmidecode still shows memory speed as 1067 MHz (three modules are 1333 MHz).

                               

                              Besides that problem, I have another question. Now, my PC is configured with 3 memory modules working with triple-channel configutarion. If I insert a fourth module, system (of course) will not run in triple-channel but, is there any way for running in double dual-channel configuration?

                               

                              Thanks.

                              • 12. Re: Intel Dx58SO Bios issues
                                sylvia_intel

                                Druizm, this motherboard supports single, dual and triple memory organization.  http://www.intel.com/support/motherboards/desktop/sb/cs-011965.htm

                                 

                                Quad memory channel are supported only on motherboards with 8 slots of memory.

                                Unfortunately, this motherboard is out of support since June 2013 http://www.intel.com/support/motherboards/desktop/sb/CS-034322.htm . However, could you please provide me the model number of the memory you are using, in order to check why the system is giving you the incorrect memory speed?

                                 

                                Which speed do you get when using only 1 memory stick?

                                • 13. Re: Intel Dx58SO Bios issues
                                  druizm

                                  Hello Sylvia,

                                   

                                  I could send you some files as you said me, but from this forum, I can't send you all files, because total size is 12 MB.

                                   

                                  However, I will explain what I have checked:

                                   

                                  I have checked my system in 5 scenarios, but last has not booted:

                                   

                                  • 1 memory module in Channel A Slot 1
                                  • 2 memory modules in Channel AB Slots 00
                                  • 3 memory modules in Channel ABC Slots 00
                                  • 4 memory modules in Channel AABC Slots 1000
                                  • 1 memory module in Channel A Slot 1  -->  BOOT ERROR

                                   

                                  In all scenarios, dmidecode (run from Scientific Linux 6.4 64bits with kernel 2.6.32-358.6.2.el6.x86_64) shows memory running at 1066 MHz

                                   

                                  If you could give an email address, I would send you all the files and you could review them.

                                   

                                  Thanks.

                                  • 14. Re: Intel Dx58SO Bios issues
                                    druizm

                                    Sylvia, I have another question for you.

                                     

                                    With this motherboard and 3 memory modules (1 of 4 GB and 2 of 2 GB --> total 8 GB), would be possible dual channel? As I can see at Desktop Boards — Single and multi-channel memory modes, there are some configurations that allow that, but DX50SO not have DIMM1, DIMM2, DIMM3 and DIMM1, but has Channel A,B,C with DIMM0 and Channel A with DIMM1, so I "suspect" that with 1 4-GB module and 2 2-GB module, I couldn't have dual channel...

                                     

                                    Help.

                                     

                                    Thanks!!

                                    1 2 Previous Next