1 Reply Latest reply on Jul 20, 2018 12:47 PM by MartyG

    Realsense R200 integrated in Wacom mobile studio 13 callibration error

    alatinyte

      I have already seen one sole post about it, but just wanted to make sure what can I do about it.

      Buying an expensive tablet and not being able to use 3d camera makes me almost cry (because that was one of the features i was so looking forward to)

       

      So I have wacom mobile studio pro 13, and there is integrated realsense r200 camera.

      Before windows 10 update calibration was kind of working but I couldn't manage to get rid of all blue squares and didn't complete the calibration.

      Then with no clue I have updated windows and know I get "DS_INVALID_ARG" error.

      The camera kind of works with Artec Studio 12 scan function but the whole image is very scattered (compared to other people's images on youtube) and program in the log keeps telling:

      Error: SGL: Error filling buffer: CL_INVALID_MEM_OBJECT

      As I've research further in system event log there's an error stating that:

       

      "FW Version Mismatch. Expected Version:1.0.72.6 Actual Version: 1.0.72.10"

       

      during the time when calibration program fails to starts.

       

      So, I have found mr. @MartyG post and link to download older DCM software.

      With uninstalling current drivers and trying to install older ones I've got error in DCM installer stating:

       

      "

        Intel RealSense 3D camera firmware update failed.

                  The installer failed to update the firmware of your Intel

                  RealSense 3D camera.  The camera firmware may be corrupted.

                  Contact your computer manufacturer for recovery instructions.

                  Error code: -3

      "

       

      I was afraid that I have somehow bricked or corrupted firmware with all uninstalls and installs,

      but thank goodness, after reinstalling newest DCM version I was able to get back to the beginning -

      camera kind of working on Artec, but not being able to launch calibrator.

       

      Also,

      interesting notice in system event log that another error pops during the whole calibrator launch process:

       

      The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

      {D63B10C5-BB46-4990-A94F-E40B9D520160}

      and APPID

      {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}

      to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

       

      Tried to run calibrator in administrator mode but no changes.

       

      Any suggestions about how to calibrate the camera or get the calibrator working?

      (or maybe the image I've added in screenshot is the best look possible?)

       

      Will simply copy-pasting David Lu's provided calibration script in cmd will do the trick to get better camera performance?

       

       

      Thank you in advance and I hope this issue will be solved soon. Buying an expensive stuff that is not working (but used to work before update!) is very very frustrating.