3 Replies Latest reply on Jul 31, 2018 5:49 PM by Intel Corporation

    MISSING INTEL HD GRAPHICS CONTROL PANEL and more, help pls

    ReleaseDaWeasel

      Ok so like the title says I have an Alienware 15 r3 with a Nvidia Gtx1060 for dedicated graphics and intel hd graphics 530 for integrated, the problem is I factory reset my laptop around ~2-3 months ago just trying to clean it of all the junk files and things to improve my fps in the games I play. I felt like after the restart it was better, but it was actually the same and probably worse due to new symptoms that were hard to notice unless you were looking for them. So before the reset, I had the intel hd graphics control panel, my computer RECOGNIZED that I had TWO graphics cards. NOW, every game I play, they don't even give me the option to choose my Intel graphics instead of my Nvidia (They had before, and I don't intend to pick the intel one, but it makes me think my computer isn't actually utilizing the intel graphics whatsoever). Now if I right click my desktop, my Intel graphics don't show in the right click menu at all, only Nvidia control panel. I also went to my sys32 folder and tried to open every type of "igfx" or "igfxui" but literally none of them worked. It would show the little loading mouse symbol for a couple secs then it would just go back to my normal pointer. It was showing in the task manager in my processes as "IntelCPHeciSvc.exe" and "IntelCpHDCPSvc.exe" but yet the program would not open in any condition. I even downloaded the DDU uninstaller and booted into safe mode, and used the uninstallers "Clean and reboot (Highly recommended) Option and made sure it was looking for all intel graphics. Once I had done that and restarted normally I went to my device manager found my Display Adapter now under "unknown devices" and it said video controller and I would click properties and at first it would say "no drivers are installed for this device please click the update button to update your driver" , and for about a minute the update button was grayed out and it seemed like the computer wasn't letting me change it. Then the update button would show up and I click it, I updated using the automatic search since that is what the DDU uninstaller recommended (I had previously tried installing manually via an exe file and through the device managers "Let me choose - have disk - zip file" and the exe files would always say you have no devices compatible with this software. I can go on and on and on but basically the only proof I even have that this integrated graphics exists according to my computer is the device manager, because literally every single setting that you could find for intel graphics just using the windows settings search bar is GONE from my computer. No results at all. The reason this is such a big issue is because I feel like my intel graphics is starting to conflict with / trying to override my nvidia graphics bc it feels like a battle between them the way my fps will be fine....drop for 10 secs...fine for 2 mins....drop for 10 secs, and it's because I have no options whatsoever anywhere or a tray icon to do anything for my intel settings. Sorry for the long post this has just been eating away at me for like 2 weeks and I just wanna beat it already, WITHOUT ANOTHER FACTORY RESET. Thanks in advance

       

       

      Most recent status update: I tried downloading windows update troubleshooter in case I was missing updates which I figure I am since the only thing windows wants to do is prevent me from using my already bad drivers for anything. The troubleshooter said "did you know you have pending updates?" So I downloaded the 3 most recent (KB4345421, some Intel - MEDIA update which failed and wouldn't show up ever again after I restarted just now, and I think the intel hd Graphics one,) which was weird considering I had updated it manually to the same driver they claimed to install. This was about 15 minutes ago.

       

      TLDR ; Cant get intel hd graphics control panel back
      Tried uninstalling/reinstalling
      tried Uninstalling/restarting/reinstalling

      tried updating searching auto

      tried executing .exe file from Intel, and tried .exe file from alienware, both say no devices compatible with software

      Tried uninstalling restarting using manual install with .zip file

      tried opening every igfx file in my sys32 folder

      tried uninstalling/turning internet off to prevent windows update/installing manually both from .exe and from "have disk" section  - no luck

       

      Any help would be appreciated.

       

      EDIT: I have opened my laptop a fair amount of times just due to me being ocd about cleaning it and bc I have what I now assume to be a short in a few of my keys *unrelated to current issue* BUT amongst all my fiddling around in there, maybe i nudged the intel card loose? Idk. I can't even recall where it is physically located inside the laptop but I've gone as far as unscrewing everything to gain access to the fans themselves to pull them out and clean the space between them and the vents too. But if I did knock it loose, why would it still show in device manager? Just a thought I had that I figured may be relevent

        • 1. Re: MISSING INTEL HD GRAPHICS CONTROL PANEL and more, help pls
          ReleaseDaWeasel

          Please someone help me with this if you know how crappy intels support staff are you know none of them will ever read this

          • 2. Re: MISSING INTEL HD GRAPHICS CONTROL PANEL and more, help pls
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hello ReleaseDaWeasel,

            I understand that you are having problems with the integrated graphics since it no longer shows after the system factory reset.

            Regarding this, I would like to begin by requesting an Intel ® System Support Utility report. This report can be generated with our tool, which you can download in the link below:

            https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

            After downloaded, please create the report and attach it to this thread. Also, I would like to mention that, since you have a hybrid graphics configuration, there is a sequence in which the graphics drivers must be installed, starting with the ones from Intel ® and then the ones from Nvidia*. This however, is recommended to be done with the graphics drivers from the manufacturer of the system.

            I would like you to try and follow these steps: 

            1 - Download the drivers from Dell's website (Both Intel ® and Nvidia*).  
            2 - Disconnect the computer from the internet.
            3 - Uninstall both the Nvidia and Intel ® display adapters until it shows "Microsoft* Basic Display Adapter".
            4 - Install the drivers previously downloaded, first the Intel ® driver followed by the Nvidia one.
            5 - Reboot the system.
            6 - Check if the integrated graphics show.
            7 - If it shows, you can connect back to the internet. 

            I hope this helps.


            Regards,
            David V

            • 3. Re: MISSING INTEL HD GRAPHICS CONTROL PANEL and more, help pls
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello ReleaseDaWeasel,

              I am following up with your case and see that we have not heard back from you.

              Please provide me with the information requested above. Also, did you try the steps I provided? 

              If you need more assistance do not hesitate to reply.


              Regards,
              David V