3 Replies Latest reply on Jul 23, 2018 1:38 PM by Intel Corporation

    intel wireless 8265 linux: can't connect and work with bluetooth handsets

    DimaGorbenko

      Hi,

       

      I'm using laptop from system76 (galago model) which has Intel Wireless 8265NGW.

      Here is the photo of the device.

      OS: Linux

       

      The problem: I can't connect my bluetooth handset devices (I have two of them) to my laptop: the device may get connected but for a 5 - 10 seconds only, then get's disconnected but the laptop thinks it's connected. Something quite weird goes on there.

       

      If I connect my android smartphone to laptop -- everything goes well and fast and reliable.

      But not handsets !

      These handsets connect to any bluetooth device I have in my home (several tablets, dell 3350 laptop under linux, to smartphone -- I mean they are working !)

       

      I tried different bluetooth managers (NetworkManager, blueman, Gnome-specific, something else) -- all works in a same way.

      I haven't tried windows, I have only Linux on my laptop.

       

      Here are the video I recorder for system76 support team (they didn't help me):

      1: Bluetooth doesn't work on System 76 Galago Pro - YouTube

      2: Trying to connect... - YouTube

       

      Uname -a: Linux galago 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

      lsusb:

      Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
      Bus 001 Device 004: ID 8087:0a2b Intel Corp. 
      Bus 001 Device 003: ID 04f2:b649 Chicony Electronics Co., Ltd 
      Bus 001 Device 006: ID 045e:07a5 Microsoft Corp. Wireless Receiver 1461C
      Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

      attaching dmesg (I may say nothing gets to dmesg when I try to connect to handsets).

       

      Is there is anything else I need to provide ? some info ?

       

      Thank you,

      Dima