4 Replies Latest reply on Jul 29, 2018 6:41 PM by Intel Corporation

    rhel6.9 use the 710 network adapter configure bond0 issue

    wangyue28

      hello,

           configure bond0 use eth0/eth1,ifdown eth1,bond fail,con`t ping

      [root@localhost linux64e]# ll /sys/class/net/

      total 0

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 bond0 -> ../../devices/virtual/net/bond0

      -rw-r--r-- 1 root root 4096 Jul 18 13:56 bonding_masters

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth0 -> ../../devices/pci0000:05/0000:05:00.0/0000:06:00.0/net/eth0

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth1 -> ../../devices/pci0000:05/0000:05:00.0/0000:06:00.1/net/eth1

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth2 -> ../../devices/pci0000:05/0000:05:02.0/0000:08:00.0/0000:09:03.0/0000:0a:00.0/net/eth2

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth3 -> ../../devices/pci0000:05/0000:05:02.0/0000:08:00.0/0000:09:03.0/0000:0a:00.1/net/eth3

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth4 -> ../../devices/pci0000:2e/0000:2e:00.0/0000:2f:00.0/net/eth4

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth5 -> ../../devices/pci0000:2e/0000:2e:00.0/0000:2f:00.1/net/eth5

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth6 -> ../../devices/pci0000:57/0000:57:00.0/0000:58:00.0/net/eth6

      lrwxrwxrwx 1 root root    0 Jul 18 13:56 eth7 -> ../../devices/pci0000:57/0000:57:00.0/0000:58:00.1/net/eth7

      lrwxrwxrwx 1 root root    0 Jul 18 13:55 lo -> ../../devices/virtual/net/lo

      lrwxrwxrwx 1 root root    0 Jul 18 13:58 usb0 -> ../../devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1.6/1-1.6:1.0/net/usb0

       

      [root@localhost linux64e]# lspci -s 06:00.0

      06:00.0 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)

      [root@localhost linux64e]# lspci -s 06:00.1

      06:00.1 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)

       

      dirver version:2.4.6.1

       

      fw version: 6.01 0x80003857 1.1892.0

       

      the bond0 mode=0,in switch configure EthernetChannel

       

       

       

       

        • 1. Re: rhel6.9 use the 710 network adapter configure bond0 issue
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Wangyue28,

          Thank you for posting in Intel Wired Ethernet Communities.  We are currently investigating this issue.  Please check back for updates.  If you have any questions please feel free to contact us.

          Best Regards,  
          Daniel D
          Intel Customer Support
          Agent under contract to Intel

          • 2. Re: rhel6.9 use the 710 network adapter configure bond0 issue
            wangyue28

            hello Daniel,

                 I found that ifdown eth1, the switch still displays the up state to the due interface, which means that the switch did not detect the down of the network port, resulting in the inability to switch to another link.

                

            [root@localhost yum.repos.d]# ethtool --show-priv-flags eth1

            Private flags for eth1:

            MFP: off

            LinkPolling: off

            flow-director-atr: on

            veb-stats: off

            hw-atr-eviction: off

            link-down-on-close: off

            disable-source-pruning: off

            disable-fw-lldp: off

             

            after use this "ethtool --set-priv-flags eth1  link-down-on-close on"  command,ifdown eth1,test bond0 ping is ok.

            I don't understand why the x520 card doesn't need to do this. What's the difference between the 710 and the 520 CARDS

             

                

            • 3. Re: rhel6.9 use the 710 network adapter configure bond0 issue
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello Wangyue28,

              This is an additional feature in the X710 controller. Please find the details in the readme file in the following Link


              Setting the link-down-on-close Private Flag

              -------------------------------------------

              When the link-down-on-close private flag is set to "on", the port's link will go down when the interface is brought down using the ifconfig ethX down command.

              Use ethtool to view and set link-down-on-close, as follows:

              ethtool --show-priv-flags ethX

              ethtool --set-priv-flags ethX link-down-on-close [on|off]



              Please let us know if you have any other questions.

              Best Regards, 
              Daniel D
              Intel Customer Support
              Agent under contract to Intel

              • 4. Re: rhel6.9 use the 710 network adapter configure bond0 issue
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello Wangyue28,

                Hope the explanation provided is beneficial.  If you have any other questions please do not hesitate to ask.

                Best Regards, 
                Daniel D
                Intel Customer Support
                Agent under contract to Intel