6 Replies Latest reply on Jul 31, 2018 2:19 PM by Intel Corporation

    hd4600 hdmi output - Linux = Yay, Windows 7 = Nay

    XantheFIN

      CPU (the main product) = i5-4210m

       

       

      As from title this doesn't work. I think this is now mixed up driver developer forgetting these who has Optimus with fully muxed configurations where ALL output ports are through igpu and not peg (pci-e/.. nVidia or dedicated gpu). As those has been example from hp when hdmi alone goes through another gpu (gep / nvidia). I have switchable but i did modify my bios so that i can disable nvidia fully and linux or windows doesn't see a thing anymore. So  need forget that too in this problem sir/madam intel engineers or did i miss something?

       

       

      So hdmi is at port 7 if that helps any developer out there instead of original 6 or so.

       

      For sayings to "you have hardware problem" Please look at the title **** as at Linux no problemo so it has good drivers.

       

       

      card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]

      -> Physical address is hw:0,7. While the device name, is HDMI

       

       

      And no hdmi audio output so intel has something bad in drivers.

       

       

       

      ...but VGA PORT WORKS.

       

       

      ..and funnily it tries to show that i have TWO VGA ports.

      intelsx.png

       

       

       

       

       

      Plus intel you have extra "s" letter in Finnish registration page writing.

       

       

       

       

      I downloaded 15.28.64bit_test but can't use it as it says i don't have minimum OS.. blah

      Update: I downloaded 15.36.64bit_test now and they installed but no difference. I noticed intel lists them upside down order for some unnatural reasons.

      Download Test Driver - HDMI Display Detection

       

       

      More info for engineers: If i don't have installed intel drivers. i can see two High Definition Audio under "Video and game controller" sections but soonest intel drivers has been installed the other one is gone like a Crack burp* in desert.

      *modified because _f_a_r_t_ is curse word and sensored on intel forums. LOL

       

       

       

       

       

      For intel engineers:

      At windows Registry there IS PROBLEM which resets every each boot and i cant yet myself at least do anything for that.,.

       

       

      HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\VIDEO\ ->

       

       

      \Registry\Machine\System\CurrentControlSet\Control\Video\{AA81242A-3B23-4F38-8AE8-A4FFCF560C0F}\0002

       

      Why its two!? it should be three!

       

       

       

      For everyone experiencing things..

      This is nvidia: if you change it you see it will react to nvidia control panel AFTER igpu reset (basic is 0000 - no attached displays)

      \Registry\Machine\System\CurrentControlSet\Control\Video\{0AC7A935-FC79-4B0B-A616-8C0CA25F1982}\0000

       

       

      COULD it be that hdmi gets lost as Video7 IS NVIDIA???? and not left open for intel hdmi which should be hw address 0.7?

        • 1. Re: hd4600 hdmi output - Linux = Yay, Windows 7 = Nay
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello XantheFIN,
            Thank you for joining this community; it will be more than a pleasure to assist you.
          We understand that you are facing HDMI output issues.
          In order for me to assist you better, please provide me with the .txt file that the System Support Utility will generate. To attach a file, you must click the “Attach” option on the bottom right-hand corner of the response box.
          https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-
          As well, please send please attach a graphic reports as follows on this link:
          https://www.intel.com/content/www/us/en/support/articles/000005848/graphics-drivers.html?_ga=2.245992902.316339874.1531945104-258458104.1514926373
          Please make sure all your monitors are plugged in when running our reports.
          Let us ask, are your monitors working through HDMI to HDMI connections, or are you using any type of adapter/splitter?
          I hope to hear from you soon.
          Regards,
          Diego S.
           

          • 2. Re: hd4600 hdmi output - Linux = Yay, Windows 7 = Nay
            XantheFIN

            Here you go! I had HDMI connected to monitor but as known its no responsive under windows 7. It is same through my splitter and directly to monitor. Thank you answering!

            • 3. Re: hd4600 hdmi output - Linux = Yay, Windows 7 = Nay
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello XantheFIN,
              Thank you for your response.
              In this case, based on the reports that you attached, we noticed that only the built in monitor is being recognized by your Intel ® GPU.
              This is probably because the HDMI connector is directly control by your NVIDIA GeForce* GT 720M.
              Since your machine works through hybrid graphics, the best step right know is to uninstall all the graphic drivers that your system currently has, until the basic Microsoft* display driver is exposed (please make sure that you will do it with no internet access)
              After that, for troubleshooting purposes please install all the OEM drivers provided by your equipment manufacturer, that you can find here (under VGA section):
              https://www.msi.com/Laptop/support/GP60#down-driver&Win7%2064
               
              In order to do it please go ahead and perform this update steps:
              Unzip the file to a designated location or folder.
              Open Device Manager:
              For Windows 10: Right-click Windows Start icon
              Click yes when prompted for permission from User Account Control.
              Expand the Display adapters section.
              Right-click the Intel® and Nvidia* (both) graphics entry and select Update Driver Software.
              Click Browse my computer for driver software.
              Click Let me pick from a list of device drivers on my computer.
              Click Have Disk.
              Click Browse and select the directory where the driver files are located.
              Click OK, and finally click Next.
              Drivers are now being installed.
              Please perform this process with the Intel VGA drivers first.
              Restart your computer.
              And now do it with the NVIDIA* drivers
               
               
              I hope this helps.
              Regards,
              Diego S.
               

              • 4. Re: hd4600 hdmi output - Linux = Yay, Windows 7 = Nay
                XantheFIN

                Hi Diego!

                 

                I appreciate for respond but this is not built by that as in original answer i declared that when i fully disable nvidia through BIOS even so that you can't see it in Windows or Linux even being there (SG to IGFX)..

                I can still pass by hdmi output through this laptop on Linux os. But still not in anyway through windows as hdmi doesn't get detected than only before installing intel drivers (can see third Sound device as giving a hint its there but gets disabled after intel sound driver gets installed) which is a mystery to me. FrameBuffer which has my hdmi screen is intel and not nvidia too. Which i hope shows still more that hdmi is under intel directly in this laptop.

                 

                 

                P.S. I know that there is Optimus hybrid technology in here but this one is not hard wired through nvidia. There is some laptops who has hdmi through nvidia but this is not as i hope my test with BIOS and Linux shows clearly.

                 

                 

                 

                Here is one example in LINUX:

                 

                aplay -l

                **** List of PLAYBACK Hardware Devices ****

                card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]

                  Subdevices: 1/1

                  Subdevice #0: subdevice #0

                card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]

                  Subdevices: 1/1

                  Subdevice #0: subdevice #0

                card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]

                  Subdevices: 1/1

                  Subdevice #0: subdevice #0

                card 1: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]

                  Subdevices: 1/1

                  Subdevice #0: subdevice #0

                • 5. Re: hd4600 hdmi output - Linux = Yay, Windows 7 = Nay
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                   
                  Hello XantheFIN,
                  Thank you for your response.
                  In this case due to the fact that the issue is not present on Linux*, but is still noticeable on Windows*, we suggest you to try to reinstall Windows* again. We have been trying to replicate your issue, but no success has been found.
                  As well, another Option is to contact your OEM in order to get the issue replicated in one of their systems, since can only try with systems that have similar specs as yours (graphic controller and OS).
                   
                  I hope this helps.
                  Regards,
                  Diego S.
                   

                  • 6. Re: hd4600 hdmi output - Linux = Yay, Windows 7 = Nay
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                     
                    Hello XantheFIN,
                    We just wanted to double check if you still need further assistance.
                    Please do not hesitate on contacting us back.
                    Best Regards,
                    Diego S.