2 Replies Latest reply on Aug 2, 2018 10:32 AM by Intel Corporation

    Lidar lite v3 data not being read at high speed

    Ambika_Verma

      Hi

       

      I'm trying to connect lidar lite v3 to the COMPASS port - have tried coneecting through an i2c splitter as well as directly to the compass port with mag0 removed (doesn't seem to be a i2c splitter issue).

       

      I do see the distance sensor in QGC MavLink inspector and see the data change, but the rate of change is extremely slow because of which the drone for example held at 1m the altitude measured is still 0.4m resulting in EKF HGT error.

       

      In mavlink inspector it shows that the data is read at 10Hz but when actually seeing the value, it changes very slowly and gets stuck at the same value for 3-5 seconds.

       

      I tried connecting the lidar lite to Arduino Uno again using I2C but here I can clearly see the data updating at around 400Hz (the default update rate of lidar lite v3).

       

      Is the 10Hz sampling rate at compass port a fixed value? Should I be using telemetry port to get a higher update rate?

       

      Aero version -

      bios - 1.6.2

      Flight controller - 1.8