1 Reply Latest reply on Jul 16, 2018 1:32 PM by MartyG

    Realsense D415 hangs after one use on Linux

    dr_atomic

      Hello,

       

      I'm trying to use D415 with realsense-viewer. I'm on Ubuntu 18.04 (kernel 4.15.0.XX), so I downloaded and built

      development branch librealsense2 SDK using instructions from the Github:

      GitHub - IntelRealSense/librealsense at development

      librealsense/installation.md at development · IntelRealSense/librealsense · GitHub

       

      The issue I have is that the camera run only once: in realsense-viewer I start streaming from the stereo cameras and/or

      RGB camera, then I stop the streaming. When trying to stream again, the system is missing frames, nothing is streamed.

      Only hardware reset or replugging the USB cable helps.

       

      I run some usbmon and found that the USB frames are not sent after the first stream is stopped, nothing is sent on

      the bus. But the device is not completely hanged, because it can be reset using hardware reset option from the Viewer.

      Does someone have any ideas what might be wrong?

      I attached a screencast demonstrating the issue.

       

      Device info:

          Name                          :     Intel RealSense D415

          Serial Number                 :     802212061216

          Firmware Version              :     05.09.11.00

          Recommended Firmware Version  :     05.09.09.02

          Physical Port                 :     /sys/devices/pci0000:00/0000:00:01.3/0000:02:00.0/usb2/2-7/2-7:1.3/video4linux/video5

          Debug Op Code                 :     15

          Advanced Mode                 :     YES

          Product Id                    :     0AD3

          Usb Type Descriptor           :     3.1

       

      Best Regards

      --

      Kamil