5 Replies Latest reply on Jul 17, 2018 2:32 PM by Jonnyz2

    RST Not Recognizing Two Raid 1 Pairs

    Jonnyz2

      Today I noticed a taskbar notification saying that RST was not working.

       

      After trying to open RST, I received a pop up window with an unknown error message.

       

      Based on an online post, I tried to install the most recent version for windows 8.1 64 bit.  It would not install, saying something like "platform not supported."

       

      I then found my existing version number 12.9.0.1001, downloaded the install file from the Intel site, and ran the repair function.

       

      After doing that and rebooting, RST would open but now only showed two independent drives and not the usual symbols for raid pairs. The two drives shown were for one of the pairs, the other two did not show at all.

       

      I then rebooted the computer and checked to see what the bios showed.  It showed four hard drives but not the SSD the OS is loaded on.  I then checked all the connections to all of the drives.

       

      Somehow in that process, I believe I disconnected one of the raid pair drives while it was running.

       

      What I now see on the bios is all four hard drives and the OS SSD; however, when running windows 8.1 I see only one of the two raid 1 pairs I expect to see (perhaps it is not even a raid pair but a single drive) and the other pair and/or associated drives do not show at all.

       

      Using a partition tool to view the drives one pair seems to show as a pair, but now as "un-allocated" and the other two drives show as separate drives (see image).  Again, perhaps it is only showing one drive of the two that should be paired.  I'm not certain.

       

      I've also pasted an image of Device manager side by side with the RST window below.

       

      I need advice on what to do next to make the drives visible again and working as two raid 1 pairs.  While I have fairly recent backups, I really would like to restore the functionality and data accessibility of the existing drives without data loss if possible and without resorted to a restore from the backups.

       

      Thanks!

        • 1. Re: RST Not Recognizing Two Raid 1 Pairs
          Jonnyz2

          Uploading the SSU and System Reports...

          • 2. Re: RST Not Recognizing Two Raid 1 Pairs
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hello Jonnyz2
              Thank you for joining this community.
            In this case we noticed that (based on your system reports) one of your drives is under ACHI mode on your BIOS and not in SATA, which is the mandatory mode in order to run a RAID environment.
            Since we cannot tell you how it went to that mode, or to verify if it was on that mode before your RAID got degraded, we cannot tell you exactly what happened, but probably made your drives to go into a RAID corruption, and that’s the reason why one of your drives shows as “Unallocated”.
            In this case if you make the changes on your BIOS (from AHCI to SATA) your OS will need to be installed again as this will cause data destruction, including your OS.
            I regret to inform you that if you make this change we cannot guarantee that your RAID will be reconstructed, so we strongly encourage you to back up as many data as you can in order to avoid more data loss.
            I hope this helps.
            Regards,
            Diego S.
             

            • 3. Re: RST Not Recognizing Two Raid 1 Pairs
              Jonnyz2

              Hi Diego,

               

              I need to ask a few questions to clarify your comments:

               

              1.  Are you talking about the chip controller mode or an individual disk?  As I read the reports, the controller mode is set to AHCI.  All the disk connections appear to be SATA.  Am I misreading them?

               

              2.  Are you saying that Intel RST is NOT compatible with the Intel Controller Chip set in AHCI mode?  I've found a number of references online which suggest RST should work fine in this mode.  For example...multiple references suggest hot swapping, Native Command Queuing  (NCQ), and  Link Power Management (LPM) are all a result of AHCI capabilities.  Perhaps I'm misreading the content, but some references (Wikipedia) suggest AHCI is a superset of capabilities which encompass the SATA standard.  Please help me better understand this.

               

              3.  I can obviously disconnect one drive from each raid 1 pair for data safety.  What else would you recommend for backup, especially since one drive or one pair currently shows "unallocated?"

               

              Some more information to help with debugging:  

               

              A.  No edits to the BIOS settings have been made for years.   The system has successfully run with the OS on a single SSD as noted.  The two raid 1 pairs (4 drives shown on reports) have also been run the same way for years.

               

              B.  The drive that currently shows "unallocated" did not show that way when this problem first occurred.  It only showed that way after I tried to double check the physical drive connections (wiring).  So, that would indicate that the move to "unallocated" was not bios driven.  Could it be simply be MBR corruption?

               

               

               

               

               

               



               

               


              • 4. Re: RST Not Recognizing Two Raid 1 Pairs
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello Jonnyz2
                 
                 Thank you for your response.
                In this case, I will try to answer your questions in the same order:
                1.  All the drives are working under AHCI mode as the system report shows under “System Storage Info”.
                2. RST does support on AHCI, but if you want to run RAID, SATA mode needs to be change from AHCI to RAID in the BIOS.
                3.  We strongly recommend you to back up your data into an external unit if possible; we do not recommend saving data on the hard drives that we are working on at the moment.
                A. Even if no changes have been done on the past years, a BIOS update could cause the changes on the system.
                B. In this case; yes, it could be a MBR corruption that led the drive from a healthy status to “unallocated”.
                 
                 
                Hope this helps.
                Regards,
                Diego S.
                 

                • 5. Re: RST Not Recognizing Two Raid 1 Pairs
                  Jonnyz2

                  In older computers I used Matrix raid installed and controlled via the bios.  In the computer we are talking about now, I recall that I created and ran the raid arrays via the Windows RST application only (not via matrix raid).  It has been quite a while though so I may not be remembering it correctly.

                   

                  If the raid arrays were created via the RST windows program, is the RAID setting in BIOS still a requirement or can RST function without it (as currently configured)?

                   

                  Thx!