5 Replies Latest reply on Jul 10, 2018 12:05 AM by MartyG

    "PXC_" is undefined

    tommycwh

      I am new to Intel RealSense products and the SDK. With my new camera D415, I am trying to create a new visual studio project on 3d scanning. First I tried to build and compile the samples given when I installed the SDK on my Windows 10, for example the pointcloud project with rs-pointcloud.cpp. The samples are running well with no errors. Then, to take a step further, I tried to build my first project by referencing the documentation: Intel® RealSense™ SDK 2016 R2 Documentation.

       

      I was experimenting on Example 74 shows a typical 3D scanning program using SenseManager (Algorithm Modules> 3D Scan> Coding 3D Scanning). However, it was not working as PXCSenseManager was not found. In the doubt of not linking nor including the required dependecies correctly in my VS project, I copied the lines in Example 74 to the samples provided (in the installation directory, which is working). The same problem arises:

      Meanwhile, most of the other examples given in the documentation seems to be using a lot of identifies with a "PXC-" prefix, but none of these can be used in my project. Upon a quick search on this community and google, I have found the reason is the "pxc_.h" headers are missing in my path. However, I could nowhere find such header files in my installation directory, nor the source codes I downloaded from your github repo GitHub - IntelRealSense/librealsense: Intel® RealSense™ SDK .

       

      Is there anyone who knows how to solve this problem or where to find those headers, or who had also faced similar problems like me?

       

      Thank you