9 Replies Latest reply on Aug 14, 2018 4:49 PM by irieblue

    Cannot build v1.6.2 with yocto

    DanMadill

      I have tried to build both the v1.6.2 build and the latest development build of the Intel Aero Yocto image and in both cases I get the following warnings and error:

      For the v1.6.2 build I tried setting up the repo using the command:

           repo init -u https://github.com/intel-aero/intel-aero-manifest.git -m v1.6.2.xml -b master

      which gives the error above, as well as:

           repo init -u https://github.com/intel-aero/intel-aero-manifest.git -m v1.6.2.xml -b refs/tags/v1.6.2

      which doesn't even find the v1.6.2.xml manifest.

       

      For the development build, I tried:

           repo init -u https://github.com/intel-aero/intel-aero-manifest.git -m default.xml -b master

      which gives the same error as v1.6.2 (master) above.

       

      What is the proper repo initialization to build the v1.6.2 version of the Intel Aero image? Or will I need to work through those errors and resolve them myself? Given a v1.6.2 image has been released I thought it should be possible to build it from the repository. We apply patches to our Intel Aero image, so we cannot use the released image directly. However, the above errors are not due to our patches, which are in a separate layer, but appear to be related to changes in the RealSense support (which I am very interested in).

       

      I also notice that the librealsense v1 API may be dropped. How will this affect support for the R200 camera, which still ships on the Intel Aero? I don't want to lose that support but would like to gain the librealsense v2 support at the same time.

       

      Thank you for your assistance.