5 Replies Latest reply on Sep 9, 2018 4:17 PM by Sneakytiki

    Your support documentation outright lies

    Sneakytiki

      Dear Intel,

       

      Your wireless adapters are essentially inescapable and yet, despite rather reasonable hardware, are utterly useless for any application requiring a stable latency. And the worst part is that it's not even a crippling hardware defect, nor is it some impossible to solve issue tied to core functionality. It literally comes from you disabling a previously available feature, and it's driving me nuts. So I'm really just venting. I don't expect anyone to care, nor do I expect anything to change. You have had years to listen to the community and make the simple change. But no. You're Intel, and you're big and mighty, and you just can't be bothered.
      What am I talking about? I'm talking about your wireless card's insistence on roaming for a stronger wireless access point, no matter what 'Roaming Aggressiveness' setting you select. Mind you, this completely contradicts your own documentation, which states that it "doesn't roam" except in cases of "significant link quality degradation". (Wi-Fi Roaming Aggressiveness ) Well apparently -32dBm is considered 'significant link quality degradation', because it still bloody roams every 10 minutes on the dot. And god forbid I move into the next room with -40dBm. That's extra significant degradation, so roaming every minute is appropriate. And it's not like it's a minor disruption. It's 2-3 seconds of effectively dropped packets to the router, as the latency spikes from 1ms to 120+.
      But you know what the real icing on the cake is for me? YOU TOOK AWAY THE ABILITY TO ACTUALLY TURN IT OFF!!! See, you used to be able to do a regedit and actually disable roaming. See, I've had the unique displeasure of having to deal with your 3160, 7260, 7265, 8260 and now, the 9260. And you have actually made the problem worse. The ScanWhenAssociated setting used to actually exist in the registry. You just went in, set it to 0, and off you went to the races with excellent connection quality. Then with driver updates and some irritated users on your forums, you quietly removed the registry value. Luckily, you could still manually add it. Bam! Like magic, the seemingly worthless dumpster fire of a wireless adapter went from being worse than a USB dongle adapter, to an actually reasonable and usable device. And so it was, all the way up through driver version 17.15.05. Then came driver version 18, and you just had to disable it didn't you? Just couldn't stand your devices actually behaving the way users wanted them to, and the way your documentation claims they do. Nooooo, that's just not the way of important modern companies. You needed to take a perfectly working 7260 and turn it back into a worthless trash heap. Luckily, I had a back-up of the good old driver, and happily restored my card to working condition. But fast-forward a couple of years, the newer generations of cards don't run on the older drivers, and you still haven't re-enabled the ability to turn off the stupid roaming.
      And so, here I am, ranting. Why? Because I felt like it, and because I wanted to be sure you knew exactly why I will never recommend your adapters to anyone and strongly advise they go with a solution from Broadcom, D-Link, or even Realtek any time they can.

       

       

      Have a pleasant whatever-time-of-day-it-is. Call me when you re-enable the ability to turn off roaming.

        • 1. Re: Your support documentation outright lies
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Sneakytiki,

          We apologize for the delay in response and would like to let you know that we understand your concern; we appreciate your feedback as it provides us with the perception you have of our products and allows us to improve them.

          As you mentioned before, the feature to disable background scanning via registry is no longer available, and we can't confirm if it is possible to bring it back for current systems. The Scan When Associated setting that was available with older driver versions only changed the way the WiFi adapter would trigger a scan for other candidate Access Points, based on the signal strength of the currently connected Access Point. It is important to note that Roaming is a different feature and it isn't possible to disable it with Intel® Wireless Adapters.

          We would like to inform that we forwarded your comments to the proper resources so it can be considered for the future. Also, we are using your feedback to clarify our documentation about this topic.

          Regards,
          Jonathan B.

          • 2. Re: Your support documentation outright lies
            Sneakytiki

            I do genuinely appreciate knowing that you pay attention to your community forum. Again, I never expected anything to change, but do you by chance have any insight as why the ability to disable background scanning was removed int he first place?
            You are of course correct in pointing out that roaming and background scanning are different behaviors, and it's the scanning that I'm concerned with.

            • 3. Re: Your support documentation outright lies
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello Sneakytiki,

              The Scanwhenassociated option was changed some time ago with the release of new Wireless Adapters and Windows* versions. We have provided your feedback to the proper channels so it can be evaluated. If you would like to check the functionality of your Wireless adapter, we advise you to Contact Support and work with one of our support agents.

              Regards,
              Jonathan B.

              • 4. Re: Your support documentation outright lies
                Trilby

                Try setting "ScanDisableOnLowTraffic" to 1 in the same place you would previously have set "ScanWhenAssociated " to 0.

                • 5. Re: Your support documentation outright lies
                  Sneakytiki

                  Thanks so much Trillby!

                   

                  Sorry for the late response, got busy with work. But you're absolutely right. i happened upon this post ( Re: Traffic lag issue on Intel Dual Band Wireless-AC 8260 and registry changes ) discussing this same issue. Turns out there are now four different registry settings you can add:

                  "ScanDisableOnLowTraffic"=dword:0000001F

                  "ScanDisableOnMediumTraffic"=dword:0000001F

                  "ScanDisableOnHighOrMulticast"=dword:0000001F

                  "ScanDisableOnLowLatencyOrQos"=dword:0000001F

                   

                  With these applied, problems are gone
                  Thanks very much for your suggestion!