4 Replies Latest reply on Jul 4, 2018 11:45 AM by Intel Corporation

    i7 8750h clock error???

    saxybabe

      Hi guys, I bought a gaming laptop couple weeks ago and I think I have a problem with it.

      my laptop's processor is i7 8750h which has the base clock 2.2ghz and max turbo is 3.9 for all cores and 4.1ghz for single core.

      But mine only goes to 2.7ghz for max clock. I checked with intel XTU and CPUID HWMonitor, so I'm pretty sure i'm right.

      But if i change my power mode to max performance then it goes up to 3.9ghz.

      Then why my cpu doesn't go up from 2.7ghz in balanced mode??????

      I don't want to set my laptop in performance mode because of noise and heat.

       

      Conclusion: I can't get up to 3.9ghz on balance mode. (2.7ghz is max), But on performance mode 3.9 is able to reach

        • 1. Re: i7 8750h clock error???
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello saxybabe,
            Thank you for joining this Community.
          In this case, you can disregard the readings from Intel® Extreme Tuning (Intel® XTU). This tool can be used by any device but is specially designed for desktop systems. Since you own a laptop device, we don't really know where the readings are coming from, especially, that most of the BIOS setting are coming from system manufacturer and most of the time, it's pre-defined.
          Regarding the Base, Idle and Maximum Clock frequency, these values will increase/decrease dynamically depending on the amount of resources that a task needs in order to be performed.
          More resources in this cases, means more or higher base clock values.
          However if you want to increase the Base clock frequency from your Balanced System mode, you can try the following:
          -Press the windows key on your keyboard and on the search bar type in “power options” so you can select the control panel app with that name.
          -Next to Balanced (recommended profile) you will see the “Change plan settings” option, please click on it.
          -Click on change advanced power settings.
          -On the dropdown bar, look for Processor power management on click on it.
          -Make sure that the maximum processor state is set up to 100%
          The minimum processor state is by default 5%, however, to see better results, you can go ahead and increase that value.
          -Reboot your machine.

          I hope this helps, please monitor the results and let us know the outcome.

           

          Regards,
          Diego S.

          • 2. Re: i7 8750h clock error???
            saxybabe

            Hi thanks for the reply. But, I already set my max processor option to 100.

            • 3. Re: i7 8750h clock error???
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello saxybabe
                Thank you for your response, we really appreciate it.
              In this case as you can see, the power plans of your OS are limiting the processor values which under the right settings (performance mode) reaches the max clock base.
              So in this case your hardware (which is working properly) is totally controlled by your software.
              While on balance mode, 2.7ghz is the maximum value, even if the maximum processor state is set up to 100%.
              This limitation in this case is caused by the OS, or by a limitation added by your system manufacturer.
              We strongly encourage you to contact your OEM system manufacturer, so they can replicate the issue in one of their machines and provide you with further assistance on this matter.
               I hope this helps.
              Regards,
              Diego S.
               

              • 4. Re: i7 8750h clock error???
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello saxybabe,
                We just wanted to double check if you still need further assistance.
                Please do not hesitate on contacting us back.
                Best Regards,
                Diego S.