7 Replies Latest reply on Jun 25, 2018 4:42 PM by N.Scott.Pearson

    BIOS recovery doesn't work

    pichardo

      Hi

       

      I bought an Intel motherboard DH67BL and processor and build up a workstation so there is no manufacturer support. Everything was ok for some years, until I ran the driver update utility that comes with the motherboard CD. I selected all updates in the checkboxes and after it finished I saw that some of them failed (I cannot remember which ones), and after a machine reboot nothing appeared, no BIOS screen, no beeps, and of course it doesn't boot. The PC has the leds on, the CPU fan and the HD are running, but seems that the BIOS is broken.

       

      So, I followed the steps here to do a BIOS recovery using a CD. CD is not bootable as the instructions doesn't say so, I only burned the BL0160.BIO file into it, I remove the jumper. I downloaded one version before the latest, just in case the last one has problems.

      Recovery BIOS Update Instructions for Intel® Desktop Boards

       

      I also tried these using a bootable USB as explained here. The USB is correct as I was able to boot it in a different laptop for testing purposes and see the IFLASH2.EXE and BL0160.BIO are there.

      iFlash BIOS Update Instructions for Intel® Desktop Boards

       

      I still see nothing in the desktop PC. I have a graphics card, so I tried to see if there is any output in the HDMI  and VGA ports in the graphics card, and also in the HDMI port in the motherboard. Nothing. I also cleared de CMOS by removing the battery for a while.  I removed the RAM module to see if there is any beep but there isn't.

       

      Nothing works, I still see nothing.

       

      Thanks for your support.

        • 1. Re: BIOS recovery doesn't work
          N.Scott.Pearson

          Have you tried clearing CMOS? Disconnect A/C power and remove the CR2032 battery from the board for 15 minutes. Restore it and see if it will then POST.

           

          Best method to do BIOS Recovery is with a USB flash stick containing only the .BIO file. Note the following:

           

          1. Use a USB 2.0 flash stick. Do not use USB 3.0 flash sticks.
          2. On another Windows PC, reformat USB flash stick, using FAT32 file system, with Quick option disabled. Do not use Linux- or MACOS-based PC.
          3. Place only the .BIO file onto this USB flash stick.
          4. With PC powered off, insert this USB flash stick into one of the black USB 2.0 ports on the rear panel of the board. Do not use USB 3.0 ports. Do not use front panel USB ports.
          5. Remove the yellow BIOS configuration jumper from the board.
          6. Power on system.
          7. System should automatically perform the BIOS recovery. A progress display should be seen during the process. If you do not see a display, let system sit for 15 minutes before powering off (sometimes, BIOS Recovery will proceed without display; if you power off in the middle of this process, your board will be bricked permanently).
          8. When process is completed (you will be told), power off system.
          9. Restore yellow BIOS Configuration jumper to pins 1-2 of the header.
          10. Remove USB flash stick.
          11. Power on system.
          12. Use F2 key to enter BIOS Setup. Verify all parameters are correct. Best bet is to use F9 key to reset all parameters to their defaults and then change only those that are absolutely necessary to boot.

           

          Hope this helps,

          ...S

          • 2. Re: BIOS recovery doesn't work
            pichardo

            I tried first removing the CMOS battery for 20 minutes, nothing occurs.

             

            Then I followed the steps you provided, I made sure the usb stick is 2.0, using a rear 2.0 port, I'm  formatting it from Windows with the quick option disbled and I the jumper is not in the motherboard. I'm using the right jumper as it is labeled as BIOS CFG. It seems to me that the recovery process never starts, beacause nothing is displayed on the screen, I don't hear any sound, and after 25 minutes, the PC is still on. So I do a hard power off and after I power it on, it is in the exact same state. I removed the graphics card and re-tried the recovery process, but the result is the same.

             

            When I use a non-bootable CD burned with the BIO file I hear that the CD drive is trying to read it for a few times, then it stops. So I don't know if there is an working ISO image you could provide.

             

            Does the BIO file name matter?  BL0160.BIO

            • 3. Re: BIOS recovery doesn't work
              N.Scott.Pearson

              No, the name doesn't matter. All that matters is that it is the only .BIO file and is in the root folder of the flash disk.

               

              I have seen situations where, if the board has issues with the installed DIMMs, wherein the BIOS Recovery operation will not complete. What happens is the BIOS ends up taking multiple attempts to successfully initialize the memory and, in the process, forgets about (loses the context for) the BIOS Recovery operation.

               

              So, tell me more about the DIMMs that you are using in this system. Please provide full manufacturer's part numbers, not a (usually useless) description.

               

              One thing you can try, while waiting for my analysis of the memory, is reattempting the BIOS Recovery with only a single DIMM installed. Try using the Channel A Slot 0 connector first. If that doesn't work, try the Channel B Slot 0 connector. If that doesn't work, start again using the other DIMM.

               

              Hope this helps,

              ...S

              • 4. Re: BIOS recovery doesn't work
                pichardo

                I only have one DIMM inserted in the slot labeled as DIMM2 which is the on the rightmost side. I will try it in DIMM1 (there is no 0 in the slots, they are labeled 1-4)

                 

                I see these information in the label on DIMM:

                 

                AKMK1661212

                 

                KINGSTON KVR

                99U5471-020.AOOLF

                0000005818811

                X9LEQ-Q9XM1P-RW1BF

                 

                KVR1333D3N9/4G

                1.5V

                • 5. Re: BIOS recovery doesn't work
                  N.Scott.Pearson

                  The slots I am actually referring to are the two BLUE slots. DIMM1 (Channel A DIMM 1) and DIMM2 (Channel B DIMM 1). Sorry, I should have looked at the TPS instead of guessing.

                   

                  I don't see anything wrong (compatibility-wise) with the DIMMs. Going back and re-reading, you say that you get no beeps at all when you power on the board with no memory DIMMs installed? This is with processor still installed? If so, this is a very bad sign. It tells me that the BIOS isn't getting very far into POST. The BIOS may be bricked completely at this point.

                   

                  Do you remember what BIOS you had installed before you started this whole process? It may have been so old that the BIOS update included by the tool was incompatible with it...

                   

                  I am not sure what else to suggest...

                   

                  Sorry,

                  ...S

                  • 6. Re: BIOS recovery doesn't work
                    pichardo

                    The processor is still installed, and yes, if I remove the DIMM, it does not do any beep, and behaves as always.

                     

                    Changing the DIMM to a the slot 1 does not work either.

                     

                    I do not remember the BIOS version, but I think it should be very old before I did the update.

                    • 7. Re: BIOS recovery doesn't work
                      N.Scott.Pearson

                      Hhmmm, that's what I was afraid of. These boards were updated with BIOS (and Management Engine Firmware) releases that made it possible to use 3rd generation Core processors (as well as 2nd generation Core processors). The transition between the two types of BIO had to be carefully managed; you couldn't just jump forward all at once. Unfortunately, by enabling BIOS update from with the IDSA tool, it made this attempt to do this jump. I am sorry to say that there is probably nothing that you can do to recover from this

                      ...S