3 Replies Latest reply on Jun 20, 2018 5:00 PM by N.Scott.Pearson

    NUC7PJYH a bootable device has not been dectected

    bitrdrop

      Hi,

       

      I can't get my NUC to boot off a USB or DVD. I'm able to see both media in BIOS, though I'm not able to see it in the boot options when I press F10. I've tried to boot with Secure Boot on and off, and tried to boot from BIOS by clicking on the DVD/USB in the Boot Order tab. Both Windows 10 and Ubuntu 18.04 have been attempted.

       

      Any advice would be appreciated. I've never had this problem with NUC before. Maybe I'm not preparing the media correctly? I used dd for the USB drives, and k3b for DVDs with the "Burn Image" option.

        • 1. Re: NUC7PJYH a bootable device has not been dectected
          N.Scott.Pearson

          First of all, I recommend that you use Rufus to prepare your USB stick. Make sure you choose GPT partitioning so you can install under UEFI.

           

          Second, if you wish, you can always enable Legacy and install under that.

           

          Third, many folks have talked about needing the nomodeset parameter in order to get Linux running.

           

          Hope this helps,

          ...S

          • 2. Re: NUC7PJYH a bootable device has not been dectected
            bitrdrop

            Hi Scott,

             

            Thanks for the concise, clear directions.

             

            I used Rufus to prepare the USB, used GPT for the partitions, but still couldn't boot, either from Visual BIOS or the boot menu (F10).

             

            It appears I can't use Legacy boot on this machine. I tried turning off Secure Boot, but still, I don't see any options for Legacy boot.

             

            visualBIOS_noLegacyOption.jpg

             

            I'm not getting the point where setting nomodeset would be possible. The USB doesn't appear in the boot option list when I hit F10.

            • 3. Re: NUC7PJYH a bootable device has not been dectected
              N.Scott.Pearson

              Yea, I forgot that they disabled Legacy in this NUC's BIOS. Sorry for that confusion.

               

              In the picture you have provided, the Memorex Swivel is displayed as it should be. Are you saying that, when you open the F10 menu, this entry is not present? If it is present, what happens when you select it and press <enter>?

               

              I just took a Windows 10 installation (ISO) image and loaded it onto a USB flash stick using Rufus and GPT partitioning. When I press F10 and select the entry for this flash stick (note it's a USB 2.0 flash stick, however), it starts the Windows installer running without issue. I have NUC7CJYS, which is essentially the same system that you have (just Celeron SOC instead of Pentium SOC and it has a 32GB eMMC SSD soldered to board) and it is running the same BIOS. The only changes I have made to BIOS configuration (from defaults) is I disabled Secure Boot and I disabled NUMLOCK.

               

              So, the major difference is that I used a USB 2.0 flash stick and you used a USB 3.0 flash stick. Do you have a USB 2.0 flash stick that you can try?

              ...S