6 Replies Latest reply on Jun 11, 2018 3:33 PM by acedelmar

    Micro SD Card fails to be recognized

    acedelmar

      Hi!  I'm a total newb, so if there's anything unclear, please let me know.

       

      I bought an Insignia tablet from Best Buy for my wife.  Insignia - 11.6" - Tablet - 32GB - With Keyboard - Black   I recently had to reload it with Windows 10 32-Bit.  Everything now works except the SD Card Reader.

       

      If I put in an 8 GB or small Micro SD Card, it finds it.  Anything above 8 GB, it can't find.  I loaded Xubuntu on a LiveUSB and booted it and Xubuntu can see the reader, see any card including a 128 GB card that I had in another device, interact with it, load files, copy files, etc.  Based on that, it's NOT the actual hardware, it has to be a software/driver issue.  So, I did some research in the Device Manager:

       

      SD Host Adapters

      Intel SD Host Controller (3)

      Driver Version 10.0.17134.1 dated 6/21/2006 by Microsoft

      Hardware IDs of ACPI\VEN_8086&DEV_0F14&REV_0001 or *80860F14

       

      Storage Controllers

      1.  Microsoft Storage Spaces Controller

           Driver Version 10.0.17134.1 dated 6/21/2006 by Microsoft

           Hardware ID of Root\Spaceport

       

      2.  SD Storage Class Controller (Built-In SD Card for OS)

           Hardware ID of SD\VID_45&OID_0000&PID_DF4032&REV_0.1

       

      3.  SD Storage Class Controller (External 32 GB SD Card)

           Hardware ID of SD\VID_03&OID_5344&PID_SU32G&REV_8.0

       

      I looked at the SD Storage Class Controllers and they have Driver Version 10.0.17134.1 dated 6/21/2006 by Microsoft.  To test my theory of a driver error, I found Driver Version 6.3.9600.16384 dated 6/21/2006 by Microsoft and installed it and the reader now finds ANY Micro SD card I insert.  It just can't use them...  They show up in the hardware list, the computer attempts to format them, but nothing.  Now, I'm not sure what to do.

       

      I did run the Intel Driver and Support Assistant, but no luck.  I also installed Driver Easy and ran all of the updates that it found.  Still nothing...

       

      By the way, before anyone says anything, yes, I did run the Microsoft Troubleshooters, I ran Microsoft updates, I did an sfc / scannow, etc.  Please do NOT waste my time by suggesting these.  Again, the card reader works just fine in Xubuntu, so clearly this is a software problem, not a hardware problem!  (Sorry, but that seems to be the only suggestions some people have.  *sigh*)

       

      I see a lot of websites with a lot of posts on this topic, but no one offering any real solutions.  Any ideas of things I can try?  (Or, do you know where I can get the Storage Class Controllers version 9.x?)  Thanks in advance for your help!

        • 1. Re: Micro SD Card fails to be recognized
          Al Hill

          You should NEVER have installed driver easy.

          The intel Driver and Support Assistant is intended for Intel products.

           

          Because of driver easy, we have no idea about the state of your drivers.  You have stumbled around, trying various updates, and have likely made the problem worse.

           

          Have you updated the bios?

          Have you contacted Insignia?  That should be your first step, especially regarding the bios.

           

          Doc

          • 2. Re: Micro SD Card fails to be recognized
            acedelmar

            Doc,

             

            At what point did I do it wrong, in your humble opinion?

             

            Windows 10 drivers? Tried it. Didn't work.

             

            Intel Driver Utility? Tried it. Didn't work.

             

            Windows Update. Tried it. No change.

             

            Insignia? They don't have drivers and don't support their own tablets! Tried it.  Didn't work.

             

            Update BIOS? Can't find an update. Again, Insignia doesn't even provide drivers. Tried it. Didn't work.

             

            Loaded Xubuntu LiveUSB to check the hardware? Tried it. Proved it's a driver issue.

             

            Searched the web? Tried it. No help.

             

            Then, after two weeks of no answers, I installed Driver Easy.  Tried it. No help.

             

            Hmm... Let' see, Doc. I tried ALL of your solutions first and...amazingly enough!...they didn't work!

             

            Now you jump on this site to tell me I did it wrong because I installed Driver Easy after everything else failed?

             

            If you have something useful to say, please feel free. Otherwise, please let someone with some ideas contribute. Thanks!

            • 3. Re: Micro SD Card fails to be recognized
              N.Scott.Pearson

              Barry,

               

              Doc is simply pointing out that Driver Easy is not very reputable and you should avoid it (unless you really like having that malware on your system).

               

              The SD readers are all third-party devices and have nothing to do with Intel. That said, you should be able to find the site of the reader's manufacturer and get the latest driver they offer there. You should be able to find information about this reader by looking at its entry in Device Manager.

               

              Hope this helps,

              ...S

              • 4. Re: Micro SD Card fails to be recognized
                Al Hill

                In my humble opinion, you made the problem.  You purchased a discontinued device that has virtually no support, and you thought you had the expertise to fix it yourself by grasping at straws.

                 

                And, you have not proven it is a driver issue.

                 

                So, return the device for a refund, and make an intelligent decision for your next purchase.

                 

                Doc

                • 5. Re: Micro SD Card fails to be recognized
                  acedelmar

                  Wow Al,

                   

                  You are just a bunch of helpful...stuff...aren't you?

                   

                  I bought a NEW tablet from Best Buy.  When I bought it, I assumed that the company - Insignia - would support it.  Also, at the time, it was NOT discontinued.  Silly me for NOT checking when something would be discontinued by Best Buy!  (Can you please share how to do that out of your vast fund of obviously useful information?)

                   

                  By the way, do you ever bother to fact-check first or do you prefer to present yourself as a...well...public forum and all that.  I AM a certified technician, I AM a Linux beta-tester, and I HAVE done tech support for companies, so you're right, Doc...what would I know about anything?  I've just been working in Linux for the past 10 years and I guess I assumed that Windows actually would work.  Silly me...  (I AM a newb to Windows 10, since Linux doesn't need drivers or, if it does, you just install them and they work!)  I also noticed that you glossed over the fact that I did EVERYTHING you would have done - except installing a driver search program - and that NONE of what you would have done would have mattered!  (Yay!  So you were wrong!)

                   

                  By the way, you may consider Driver Easy malware, but strangely enough it's recommended on the Microsoft forum by a Microsoft Tech.  (In case you weren't sure, Microsoft - not you - invented Windows 10!)  It was also recommended by CNet and was flagged as a non-virus by Avast, so it seemed reasonable to assume that if Microsoft recommended someone to use it, it's probably NOT malware, no matter what you, in your infinite wisdom, may think!

                   

                  I can't return the device.  Not sure if you can read, Doc, but I DID mention that I had to reload it.  Funny, never have to reload Linux but Windows 10, 14 months down the road, and it glitches bad enough to need to be reloaded.  (By the way, I know you don't bother to read anything I post, but I DID try using the Windows Restore function and that crashed!)

                   

                  Oh, and by the way, since it DOES clearly work - I can access, edit, format, etc. in Linux - how did I fail to show that it's a driver issue?  Also, since I can put it in my phone, my tablet and my laptop and it's recognized and I can access, edit, format, etc. - how did I fail to show that it's a driver issue?  Also - and you didn't ask, but I figured I would share - I stuck it in a Windows 10 64-bit laptop and it's recognized and I can access, edit, format, etc. - how did I fail to show that it's a driver issue?  The disk clearly works!  On the Insignia under Linux it clearly works!  On the Insignia under Windows 10, it clearly doesn't work!  In your own opinion, can you please explain to me what else it might be?  Especially when it is at least RECOGNIZED when I substitute an older driver?  (I did put a different version on and it's in the process of formatting.  I'm not holding out a ton of hope at this time, but you never know...)

                   

                  So, if you want to stop being a troll and wasting my time - oh, and being a self-righteous...public forum - then please stop commenting.  You OBVIOUSLY cannot contribute anything intelligent to this conversation and your sanctimonious comments are utter crap.

                   

                  If this is the help I can expect on the Intel forums, I'll be canceling my account.  I was hoping for real experts with real knowledge that could address real situations...like the Linux forums.  Not trolls who cannot provide any insight but still feel the need to make comments.

                   

                  *sigh*  Maybe I'll see if Linux can run on it since Intel doesn't support it and Windows 10 can't figure it out!

                  • 6. Re: Micro SD Card fails to be recognized
                    acedelmar

                    Hey Scott,

                     

                    Thank you for your comment.  I did some digging and it may be a Realtek device.  Not an exact match, but close enough.  I installed one of their drivers and the card is, at least, recognized.  Will try and see if this works.  Thanks for the helpful suggestion!