11 Replies Latest reply on Aug 26, 2010 2:56 PM by cssd_run

    Win 7 wont boot after irst 9.6.0.1014 update

    borbs

      Hi!

       

      I recently bought a X25-M 80GB drive and installed win 7 x64 on it. I had Raid mode set in the BIOS during install, as i wich to add a raid array later for storage.

       

      All went well untill i updated the storage driver to 9.6.0.1014 and now the system only boots if i set BIOS to IDE mode. If i use RAID or ACHI mode the pc just hangs with a blak screen when booting into windows!

       

      I benched ssd performance with as-ssd-bench and in IDE mode the performance is a lot worse than in RAID mode (almost half the result). Dont know if this is due to driver 9.6 malfuction compared to driver 8.6 wich comes originally with win 7.

       

      I reinstalled the OS, creatting a restore point before installing 9.6 driver and the same happened! Only boots in IDE mode, so i restored the system to 8.6 driver.

       

      My doubt is about TRIM... Will it work with BIOS in RAID mode and 8.6 driver?? Is Intel SSD optmizer the same as TRIM??

       

      Thanks in advance!!

        • 1. Re: Win 7 wont boot after irst 9.6.0.1014 update
          Ozz

          Hmm, interesting problem.

           

          Can you elaborate on you system details. CPU, motherobard (bios revision etc.)?

          • 2. Re: Win 7 wont boot after irst 9.6.0.1014 update
            borbs

            Sorry forgot about that

             

            Gigabyte GA-P35C-DS3R (rev 1.1) ICH9R - Latest BIOS F12

            C2D E6600

            4GB RAM GSKILL PI series PC8000

             

             

            Just found out that it actually boots with driver 9.6 in RAID mode but it takes like 10 mins to boot into Windows. It just sits in the windows loading screen without reading the hdd and about 10 mins later it starts to read he hdd and then boots! I benched the drive with driver 9.6 and results are as good or better than with 8.6 so i think the problem lies in windows loading the driver.(or maybe the BIOS??)


            10 mins to boot is obviously an intolerable situation for me so im going back to driver 8.6, so my doubt remains. Will i be able to use trim with with BIOS in RAID mode and 8.6 driver?? Is Intel SSD optmizer the same  as TRIM??

             

            Any sugestions to solve my 9.6 driver problem?

            • 3. Re: Win 7 wont boot after irst 9.6.0.1014 update
              borbs

              Just had a BSOD and i'm pretty sure it was related to the 9.6 driver. I opened intel toolbox and it kept reading for a while and then the BSOD!

               

              Here are the crash reports:

               

              http://rapidshare.com/files/377350358/BSOD_Files.rar.html

              • 4. Re: Win 7 wont boot after irst 9.6.0.1014 update
                Ozz

                Which port is the SSD connected to?

                 

                If it is not already, try it in SATAII_0 (top-right)

                 

                P35C-DS3R.png

                 

                Not sure about whether the msahci supports trim when the system is configured under RAID mode, but there's a standalone drive. I would put my money that it is.

                 

                Essentially, yes, SSD optimiser is the manual actuation of TRIM for when the OS or storage drivers don't support TRIM.

                • 5. Re: Win 7 wont boot after irst 9.6.0.1014 update
                  borbs

                  Driver 9.6 states that it adds TRIM support for drives in RAID and ACHI mode so i supose that with driver 8.6 i wont be using TRIM.


                  My drive is connected to port 1 (SATAII 1). I'll try connecting it to port 0 and see if that helps.

                  • 6. Re: Win 7 wont boot after irst 9.6.0.1014 update
                    Ozz

                    My bad, i just remembered from someone else's post, where to paraphrase, Microsoft used Intel Matrix storage manger (8.6) for their RAID driver. So no, no TRIM is supported there.

                     

                    Your setup should be able to use the RST driver though. I wouldn't give up on it just yet, but yes, you could use the 8.6 driver and just use Toolbox for manual TRIM.

                    • 7. Re: Win 7 wont boot after irst 9.6.0.1014 update
                      borbs

                      Well i found a workaround. I connected all my other drivers to the onboard sata controllers (JMicron i think) and now only my SSD is conected to the ICH9R and seems to be working fine with 9.6 ddriver for now!

                       

                      Hope the problem gets fixed in a future release because the board has only 2 jmicron slots and i cant connect more HDDs as a wich in the future!

                       

                      Any intel developers reading this?

                       

                      Thanks for youre help Ozz

                      • 8. Re: Win 7 wont boot after irst 9.6.0.1014 update
                        borbs

                        Well the workaround doesnt work that well. I rebooted and then it doesnt boot again. I have to boot into security mode and then reboot again and then it boots fine!! Very strange stuf.............

                        • 9. Re: Win 7 wont boot after irst 9.6.0.1014 update
                          PubERB

                          Well. I had exactly the same problem when I tried update the Microsot AHCI driver with the new rst 9.6 in my Windows 7 Pro x64. Hang at every try booting in the Windows Logo screen. I have a HP 2530p (last firmware and SATA AHCI mode enabled) with a new 18X-M 160Gb hdd updated at last firmware. At this moment, I'm using MS default driver, because with Intel is impossible.

                           

                          I did a backup of my overall system, to try to do it with a new Windows installation using F6 drivers alternative, but I had the same result.

                           

                          Reading this thread, I'm starting to think that the problem would be related with ICH9 chipset (ICH9M-E in my case).

                           

                          For now, Intel rst is not for me. I hope this problem will be solved in a new release.

                          • 10. Re: Win 7 wont boot after irst 9.6.0.1014 update
                            IrishTopspin

                            This is bizarre. I'm having exactly the same problem on my ASUS P5Q PRO TURBO with Windows 7 Ultimate 64 Bit and can't seem to find any kind of workaround. Have you guys found anything?

                            • 11. Re: Win 7 wont boot after irst 9.6.0.1014 update
                              cssd_run

                              Hello,

                               

                                   I'm not clear if this is an SSD issue or an RST 9.6 issue.  This seems to be more of an RST issue, as what I'm reading seems to indicate the SSD works fine with older version of storage driver.  For RST issues, there is another community forum that you should look for answers:

                               

                              http://communities.intel.com/community/tech/graphics

                               

                              Or if you can't find help there, then please contact Intel Customer Support for more direction.

                               

                              http://www.intel.com/support/feedback.htm

                               

                              If you can isolate that it is the SSD that is the problem, then please let us know.

                               

                              Thanks,

                              Brady (Intel SSD tech)