6 Replies Latest reply on May 22, 2018 1:23 PM by Zuperman

    Problem with RealSense Camera SR300 with Win 10

    Zuperman

      A problem has occured on my laptop, where the RealSense Camera SR300 suddenly stopped working under Windows 10.

      First time a problem with the camera appeared, was immediately after Windows updated itself to 1803. Then ther was an error message related to an issue with Trusted Platform Module (TPM) and hence the camera's security function .

      I uninstalled the 1803-update and blocked it from being reinstalled, and the camera started working as it did before. But only for a few days,

       

      Now, the camera has stopped working again. I have followed the step explained here , but the procedure was unsuccesful (no error message). Please see attached files as per instructions.

       

      What can I do to make the camera work again?

        • 1. Re: Problem with RealSense Camera SR300 with Win 10
          MartyG

          If you roll back Windows then it will tend to automatically reinstall the latest version after a time and undo the fix.  I recommend googling for 'windows 10 disable automatic updates' to turn off auto update so you can manually choose which auto downloaded updates get installed.

          • 3. Re: Problem with RealSense Camera SR300 with Win 10
            StevenSpringlab

            Hello Zuperman,

             

            Having had the same problem as in Unknown in rs2_create_device Error, I'll repeat the solution here as well to allow people to find it faster (already added it in the topic MartyG linked):

            The problem appears to be that the Windows 10 April update has changed access permissions for devices such as the camera and microphone, restricting all by default to none.

             

            Go to Privacy Settings. Select the tab "Camera" and turn on "Allow apps to access your camera".

            None of the apps below need to be given permission, however now you should be able to find and access your Realsense camera again.

             

            Kind regards,

            Steven

              

            • 4. Re: Problem with RealSense Camera SR300 with Win 10
              Zuperman

              It seems to me like Microsoft more or less has eliminated the possibility to avoid the problems caused by the 1803-update.

              The first time I rolled back to the previous version of Windows, the camera worked again for a short periode. But Windows started downloading the 1803-update immediately after the rollback was complete, and the problem reappeared... To make a long story short, I eventually manged to complete a rollback and I was able to prevent the 1803-update (used a Microsoft tool). However, the camera stopped working again after a short time. I have no idea what caused that, but I assume it was an automatically installed patch from Microsoft.

              • 5. Re: Problem with RealSense Camera SR300 with Win 10
                MartyG

                Microsoft has been quite forceful in recent years about applying Windows 10 upgrades when new versions roll out.  So the onus is on the user to set up their own precautionary measures such as needing to manually approve the installation of auto-downloaded updates.

                 

                The theory is that auto-installing updates keeps users safer and gives them a better user experience by delivering security updates and bug fixes faster.  Of course, often it doesn't work out that way in the real world in practice when hardware conflicts arise. 

                • 6. Re: Problem with RealSense Camera SR300 with Win 10
                  Zuperman

                  After various searches, I finally fond a post by typhoonkilo that actually worked (his description is inserted below) Thanks a lot!, mate!

                   

                   

                  So here are the steps that finally got my SR300 working again for me on an Acer laptop.

                  1. Remove all traces of the SR300 in Device Manager by uninstalling any device with SR300 in its name. In my case there were entries for the SR300 in: Cameras, Imaging devices, and Universal Serial Bus devices.

                  2. Restart the laptop.

                  3. Checked device manager again, and no entries for the SR300, good. For some reason Plug and Play didn't try to detect the camera again when Windows started after the restart.

                  4. Ran the camera driver for my laptop downloaded from Acer's website. Result: The driver installation completed fully! No errors!

                  5. Tested SR300, and it's working again.

                   

                  The driver I download from Acer was:

                       Date:2016/05/10

                   

                       Version:14.18.10.486

                   

                       Vendor:Intel

                   

                  Now I don't know if a future Microsoft update is going to kill the SR300 again, but at least it's working for now and I don't have to waste any more of my valuable time on it.

                   

                  The only issue I guess, is that I'm using older firmware software, but at least it's working.

                   

                  Please Intel and Microsoft, fix this problem!!!!