2 Replies Latest reply on May 10, 2018 3:08 PM by Interwebz

    [Solved] Intel(R) HD Graphics 630, 6-bit color, Windows 10 1803

    Interwebz

      Hi guys,

       

      I am wondering if anyone could point me in the right direction regarding a weird issue that I got with my graphics settings.

       

      Details:

      - Computer: Dell OptiPlex 7050 MFF, i7-7700

      - Monitor: Dell U3415W, 3440x1440, mDP

      - Windows 10 1803

      - Intel driver: 2018-04-25, 24.20.100.6025

       

      Issue:

      I am experiencing poor color depth. Pictures and web sites with gradient color transitions looks very choppy, as if the dolor depth is less than Windows 10's default 32-bit mode. I have verified that this actually seems to be the case according to Windows advanced display settings which reports "Bit depth" as being "6-bit".

       

      Troubleshooting:

      I have connected a Dell Precision 5520, i7-7820HQ (Intel HD 630) to the same monitor, installed with Windows 10 1803, using a driver from 2017. This machine is seemingly reproducing correct color depth. Windows advanced display settings reports "Bit depth" as being "8-bit" and color gradients have a much smoother transition.

       

      Update: I rolled back the driver version to "Microsoft Basic Display Adapter, 2006-06-21, 10.0.17134.1" which did the trick. Colors are much better and the bit depth is now 8-bit however, this version does not seem to support sound via DisplayPort which is required for the built-in monitor speakers to work.

       

      Workaround:

      I ended up installing the same driver version that was Installed on the 5520 and that worked (2017-04-21, 21.20.16.4664). It is definitely a driver issue.

       

      Question(s):

      - Are there any known issues with the latest driver?

      - Do anyone else have similar issues using Intel HD 630 graphics card?

      - Will available RAM make a difference since it is shared memory?

      - Could this be a specific issue to OptiPlex machines and its BIOS firmware (the machine is on the latest firmware)?

      - Any other ideas of how to try to solve this annoying problem?

        • 1. Re: Intel(R) HD Graphics 630, 6-bit color, Windows 10 1803
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Interwebz,
          Thank you for contacting us.
          Before starting, please uninstall manually all the graphic drivers (OEM and Intel®) from device manager. Once that you delete them and the basic display driver is exposed, please reboot the computer and check again device manager to make sure that you got rid of them. Please do it while you have no internet access.
          Since you own OEM Motherboard, the first thing to do will be updating the OEM customized drivers for your machine, found here:
          http://www.dell.com/support/home/us/en/04/product-support/product/optiplex-7050-desktop/drivers
          You will need to look for the Intel HD Graphics 510 / 530 / 630 Driver released back in 27 Apr 2018, located as the second option from the bottom up.
          If that does not give you positive results, please uninstall them again following the same exact process and then go ahead and perform a manual installation of the drivers by following the instructions on this video:
          https://www.youtube.com/watch?v=S1KzoQDjMMY
          The content on the above site is not controlled by Intel. This information is offered for your convenience and should not be viewed as an endorsement by Intel for the merchants or services offered there.
          Here you will find the latest drivers for your unit for you to re-install them:
          https://downloadcenter.intel.com/download/27680/Graphics-Intel-Graphics-Driver-for-Windows-10?product=98909.

          I hope to hear from you soon, please let us know the outcome
          Best Regards,
          Diego S.
           

          • 2. Re: Intel(R) HD Graphics 630, 6-bit color, Windows 10 1803
            Interwebz

            Hi,

             

            None of the OEM drivers or the latest Intel driver for that matter works for me. I have just verified it. They all give the same result. The display ends up showing 6-bit and poor color reproduction. I even downloaded the latest A07 driver CAB from here which contains an older driver from 2017. This does not work either.

             

            What works is Microsofts default driver but it does not provide audio via DisplayPort. I have now reverted back to Dell's Precision 5520 OEM driver version 21.20.16.4664. This works as intended all though the driver is a bit old.

             

            My issue is resolved with this workaround but obviously it would be nice to have an update driver from this year. Nevertheless, I will mark this as resolved now.