7 Replies Latest reply on Apr 24, 2018 4:08 PM by N.Scott.Pearson

    NUC7i7BNH won't boot properly after adding 2.5HDD drive

    Mashake

      Hi,

       

       

      My NUC7i7BNH won't boot properly whenever I add a 2.5 HDD on it, it was always stuck in the Intel NUC boot screen, removing the 2.5 HDD had no issues in booting.

       

      Things I tried...

      1. Reset the BIOS to default

      2. Installed the latest BIOS Update

      3. Tested the 2.5 HDD on my another NUC model NUC5i7RYH and it was working fine with it.

      4. Tested both the 2.5 HDD sata and power wires from both NUC7i7BNH and NUC5i7RYH to NUC7i7BNH and they didn't work.

       

      P.S:

      I never changed anything in the BIOS settings

      I bought this NUC this April of 2018

      Crucial Memory 16GB (8GBx2) DDR4

      Samsung 960 EVO Series 250GB M.2 SSD

      Licensed Windows 10 64-bit

        • 1. Re: NUC7i7BNH won't boot properly after adding 2.5HDD drive
          N.Scott.Pearson

          Are you also using (and booting from) an internal SSD? If so, you may need to go into BIOS Setup (the Visual BIOS program) and ensure that the SSD is appearing ahead of the HDD in the Boot Order.

           

          Hope this helps,

          ...S

          • 2. Re: NUC7i7BNH won't boot properly after adding 2.5HDD drive
            Mashake

            Thanks for the reply...

             

            Yes, I also tried that, the problem is my NUC was stuck in Intel NUC Boot Screen (the screen with F2, F7 message) and pressing the F2 to open bios won't work.

             

            I also find it weird that my NUC model name inside the BIOS is NUC7i7BNB instead of NUC7i7BNH. My NUC box says I have NUC7i7BNH.

            And also i searched online and find out that NUC7i7BNB only supports 1 internal drive, that causes the 2.5 HDD issue?

             

            How can I fix this?, seems like I have the wrong BIOS installed or wrong motherboard.

             

            TEMP.png

            • 3. Re: NUC7i7BNH won't boot properly after adding 2.5HDD drive
              N.Scott.Pearson

              No, no, no.

               

              First of all, NUC7i7BNB is the identifier for the board. It is normal to see this.

               

              Second, if you have NUC7i7BNH, then you can have one or two drives. The first can be a M.2 SATA SSD or (better) a M.2 NVMe SSD. The second can be a 2.5" SATA SSD/SSHD/HDD.

               

              You want to be hitting the F2 key almost immediately after powering on. Keep pressing it, over and over, until it is accepted.

               

              If it continues to hang, power off and then power back on -- but, this time, hold the power button down for three full seconds or until the power LED turns amber (whichever comes first), before releasing. After a few moments, a menu, the Power Button Menu, should appear onscreen. Pressing F2 then will take you into BIOS Setup (Visual BIOS).

               

              Hope this helps,

              ...S

              • 4. Re: NUC7i7BNH won't boot properly after adding 2.5HDD drive
                Mashake

                I tried both, it was really stuck on the Intel NUC boot screen, waiting for like 5min on the stuck screen will automatic reboot and a message will appear that something went wrong with BIOS and a Y/N question will pop up, Y for opening the Setup and N for rebooting with previous settings... screen was stuck too, pressing Y or N won't work.

                 

                From my screen shot of BIOS, it shows that the BIOS version was from Feb 22, it won't allow me to install the newest one which was released last April 13, I tried the Windows BIOS Update and the F7 one, neither worked.

                 

                I might use an external hard drive for now.

                • 5. Re: NUC7i7BNH won't boot properly after adding 2.5HDD drive
                  N.Scott.Pearson

                  That message you received makes me suspect that you have bad or marginal memory in your NUC. If you have bad or marginal memory in your NUC, the EBU, iFlash and F7 BIOS Update methods will fail to update the BIOS. This happens because the BIOS update process includes a reboot and, during this reboot, the NUC is having problems initializing memory and having it run cleanly. When it will not run cleanly, the NUC will hang. After some amount of time, the Recovery Timer will reawaken the system and the BIOS will attempt to recover by initializing the memory at lower settings. If there are no lower settings, it stops and you see the Error message. If there are lower settings and it is able to continue, the BIOS update will still fail. The recovery process causes the BIOS to lose track of the pending BIOS update (because the update was sitting in memory and the memory was wiped) and this it appears to have been aborted.

                   

                  Bottom line, as I said, I believe that you have bad or marginal memory. Try this with different memory and see if the problem is alleviated. Borrow this memory if you can (or have the test performed in a repair shop), so you aren't incurring a cost in this process, since yes, it is possible that the issue is in the NUC hardware itself and not in the memory.

                   

                  Hope this helps,

                  ...S

                  • 6. Re: NUC7i7BNH won't boot properly after adding 2.5HDD drive
                    Mashake

                    Do you think I have the wrong memory?, I am using the

                    Crucial 16GB Kit (8GBx2) DDR4 2400 MT/s (PC4-19200) DR x8 Unbuffered SODIMM 260-Pin Memory - CT2K8G4SFD824A

                    • Speeds start at 2133 MT/s and faster data rates are expected to be available as DDR4 technology matures
                    • Increase bandwidth by up to 30%
                    • Reduce power consumption by up to 40% and extend battery life. NON-ECC
                    • Faster burst access speeds for improved sequential data throughput
                    • Dual Ranked, x8 based, Unbuffered SODIMM

                     

                    but the NUC7i7BNH Spec should have the following:

                    • 7th Generation Intel Core i7-7567U
                    • Intel Iris Plus Graphics 650
                    • M.2 22x42/80 (key M) slot for SATA3 or Pie X4 Gen3 NV Me or AHCI SSD
                    • 2.5" SSD/HDD bay
                    • Dual channel DDR4-2133 SODIMMs, 32GB maximum

                     

                    I remember that I successfully updated the BIOS once, that was from the day I installed Windows 10 but now It is not working and having the issue as shown from screenshots below:

                    i1.png

                    i2.png

                    • 7. Re: NUC7i7BNH won't boot properly after adding 2.5HDD drive
                      N.Scott.Pearson

                      I am saying that I believe that this memory is only marginally being supported. Marginally supported memory, over time, can become unsupported memory. This is because, as components age, they will generate more noise and this can eventually cause failures. My suggestion is to test with some true 2133MHz memory and see if this alleviates the problem.

                      ...S