4 Replies Latest reply on Apr 15, 2018 3:09 PM by rhbecker

    Skull Canyon NUC6i7KYK seems completely dead after power interruption

    rhbecker

      Hi,

       

      I've been running my Skull Canyon NUC6i7KYK without incident since December 2016.

       

      Today, a friend inadvertently shut off the surge protector it was plugged into and ever since it won't power on at all.

       

      Over the course of the day, I've read several posts, trying to find someone with the exact same experience. I've read several where a nuc won't boot, but a fan turns on, or a light blinks. I have none of that. I have no sign of life, whatsoever.

       

      In reading these other posts, I've tried several things that get mentioned. For example, from suggestions in this thread, I tried removing all added components (RAM, SSD HD, usb dongle for keyboard and mouse), waited at least 30 minutes, and then tried holding the power button down for 3 seconds. I also tried unplugging the CMOS battery found on the underside of the motherboard, waiting 15 minutes before booting. I tried each of these suggestions with 2 separate power adapters. There's just nothing - no sounds, no lights.

       

      At this point, I think I'm screwed, but I'm holding out some slim hope that someone has an idea of what else might help.

       

      Surely a power interruption isn't enough to destroy a $600 nuc?

       

      In case it's relevant ...

      • Windows 10
      • Crucial MX300 M.2 2280 275GB SATA III TLC Internal Solid State Drive (SSD) CT275MX300SSD4
      • G.SKILL Ripjaws Series 8GB 260-Pin DDR4 SO-DIMM DDR4 2133 (PC4 17000) Laptop Memory Model F4-2133C15S-8GRS