6 Replies Latest reply on Apr 12, 2018 1:03 AM by lw1948

    NUC7i5DNKE cannot boot from EVO 960

    Tom_W

      I am using a Intel NUC7i5DNKE and the installed M.2 Samsung 960 EVO is not available as a bootable device in Uefi-Bios.

        • 1. Re: NUC7i5DNKE cannot boot from EVO 960
          lw1948

          1. Please check that the drive is properly sitting in M2 slot and fastened wilt its screw.  You can remove it and insert again.

          2. In Bios settings: Advanced -> Devices->PCI->M2.Slot shall be enabled (checkbox).

           

          I'll start from settings Bios to default settings:

          1. Enter Bios setting by pressing F2 during boot process.
          2. Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let the NUC fully reboot.
          3. You can enter again to Bios setting to change the necessary settings.

           

          Leon

           

          • 2. Re: NUC7i5DNKE cannot boot from EVO 960
            N.Scott.Pearson

            I haven't verified this one way or the other, but there was a posting the other day that indicated that both UEFI and Legacy boot needed to be enabled for this to work (for the NVMe drive to be detected properly). Obviously, Legacy boot shouldn't need to be enabled but this user claimed that the latest BIOS has an issue that requires this setting.

             

            Hope this helps,

            ...S

            1 of 1 people found this helpful
            • 3. Re: NUC7i5DNKE cannot boot from EVO 960
              Tom_W

              Thanks N.Scott.Pearson - it´s weird, but this was the right thing to do. NUC-box boots now from M.2.

              • 4. Re: NUC7i5DNKE cannot boot from EVO 960
                lw1948

                Hell Tom,

                It is really very weird to me too. I can't understand your and Scott's claim that Legacy boot must be enabled in order to boot from M.2 NVMe drive. I've even tested it in my NUC6i5SYH (with Samsung SM951 NVMe PCIe M.2 256GB installed drive as booting drive). So, after disabled the legacy boot, my NUC is booting without any problem (only with UEFI boot enabled). By the way - if you where acting according to may advice (i.e. setting Bios to default), it will also enabled the Legacy Boot.

                 

                I'm writing this post not because I want to argue with you, but only because I want to be sure that your founding are not misleading for other users. So, can you please, in situation that your NUC is booting, disable (just for test), legacy boot in bios and veryfy that your computer can't boot?

                 

                Thank You

                Leon

                 

                • 5. Re: NUC7i5DNKE cannot boot from EVO 960
                  N.Scott.Pearson

                  Leon,

                   

                  I am not saying that this is normal. There is a bug in the DN BIOS, plain and simple. A user discovered that enabling Legacy boot seems to overcome this bug. It is a workaround; nothing else.

                   

                  ...S

                  • 6. Re: NUC7i5DNKE cannot boot from EVO 960
                    lw1948

                    Hello Tom,

                    Did you try to boot your NUC with legacy boot disabled? Can you confirm that the NUC doesn't boot?

                    Leon