3 Replies Latest reply on Apr 10, 2018 1:12 PM by Coline

    Intel Aero - Mission transfer fails with QGroundControl

    Coline

      Hello,

       

      I was trying to get the Intel Aero to do a follow waypoint mission created with QGroundControl. The UAV was set-up following 02 Initial Setup · intel-aero/meta-intel-aero Wiki · GitHub , so the main computer is still running yocto. I selected px4 as the firmware for the flight controller. I am running QGroundControl version 3.3.1 on an Android phone, and I am connecting to the drone using the drone wifi access point. The error I get when I try to upload is "Mission transfer failed Error: Vehicle did not request all items from ground station MISSION_REQUEST", and the QGround control console output is "Critical: Operation timeout". I tried maybe 10-15 times and did a reboot of the drone and closed and reopened QGroundControl. Other than that I haven't had any connection problem (calibration and telemetry worked fine) and flew for about ten minutes in position mode before trying to upload waypoints. Has anyone else run into that issue? Or on the contrary got it working (maybe with a different setup)? I would appreciate any pointers to what might be going wrong and on where to look for more information.

       

      Thanks for your help,