2 Replies Latest reply on Apr 3, 2018 3:30 PM by Intel Corporation

    Intel Rapid Storage Technology removed my D drive- Reversing?

    Peachti

      Hi All

      Intel Rapid Storage Technology removed my D drive and turned it into this useless 'recovery volume'

      Now my internal HDD and everything I had in it is completely gone, I can't see it from the file explorer nor the Disk Management application. It's just not there and I've lost access to it entirely.

      I Did this accidentally as i was being annoyed by the IRST icon popping up often so i just pressed ok ok ok then when i realised it was too late to stop the process :-(

       

      I own a Acer Predator G9 593 which is running windows 10 with an i7-6700HQ- 256GB SSD, 2TB SATA hard drive with 16GB RAM

       

      I tried looking under Acer community page but this has not solved my problem - https://community.acer.com/en/discussion/519160/g9-593-72dz-intel-rapid-storage-technology-removed-my-d-drive/p1

       

      Im desperate to find a solution as i have important data that was stored in there.

       

      Thanks for reading this post and taking time to help a layman like me.