7 Replies Latest reply on Apr 2, 2018 5:33 PM by Intel Corporation

    ny NUC7i3BNH is not working correctly with my tv

    muncjack

      Hello,

       

       

      I got a my self a nuc to use as a media box, I had a problem with ny tv a toshiba. when I connect the tv to the hdmi port I get no picture.

       

      After doing some searching. I found other people had the same problem and one of the solution was to connect the TV via HDMI to USB-C. which work but a bit disappointing because sound and cec does not work.

       

      So I did notice something, I am using ubuntu and when I run the xrandr tool the result is a bit strange when I try and connect the TV to the HDMI port xrandr give this:

      Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192

      DP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 708mm x 398mm

         1920x1080     50.00*+  60.00    59.94    30.00    25.00    24.00    29.97    23.98 

         1920x1080i    60.00    50.00    59.94 

         1280x1024     75.02    60.02 

         1360x768      59.95 

         1280x720      60.00    50.00    59.94 

         1024x768      75.03    70.07    60.00 

         800x600       72.19    75.00    60.32 

         720x576       50.00 

         720x480       60.00    59.94 

         640x480       75.00    72.81    60.00    59.94 

      DP-2 disconnected (normal left inverted right x axis y axis)

      HDMI-1 disconnected (normal left inverted right x axis y axis)

      as you can see the the nuc thinks the TV is connected to DP-1 and not HDMI.

       

      on the laptop which has the a graphics chip from the same family it look kile this:

      Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767

      DP1 disconnected (normal left inverted right x axis y axis)

      DP2 disconnected (normal left inverted right x axis y axis)

      DP3 disconnected (normal left inverted right x axis y axis)

      HDMI1 disconnected (normal left inverted right x axis y axis)

      HDMI2 disconnected (normal left inverted right x axis y axis)

      HDMI3 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 708mm x 398mm

         1920x1080     50.00*+  60.00    59.94    30.00    25.00    24.00    29.97    23.98

         1920x1080i    60.00    50.00    59.94

         1280x1024     75.02    60.02

         1360x768      59.80

         1280x720      60.00    50.00    59.94

         1024x768      75.08    70.07    60.00

         800x600       72.19    75.00    60.32

         720x576       50.00

         720x576i      50.00

         720x480       60.00    59.94

         720x480i      60.00    59.94

         640x480       75.00    72.81    60.00    59.94

      VGA1 disconnected (normal left inverted right x axis y axis)

       

      The resolution settings are correct it looks like the wron output is in use!

       

      regards,

      Peder.