8 Replies Latest reply on Apr 20, 2018 2:57 AM by 1Martin

    NUC7CJYH Linux/HDMI issues

    ka-nuc

      I'm toying with my new NUC7CJYH with Linux (idea is to make replacement Kodi box out of it) and I have serious troubles trying to connect it to my TV. Things work OK when I connect it to my desktop DVI monitor via HDMI-DVI adapter - I can boot from Lubuntu LiveCD, install Linux and Kodi and video works fine. But when I connect it to my old tried TV box (50" Samsung regular full HD 1080 display) via HDMI thing immediately break. Here is what I see:

      • Splash screen shows up normally (showing "Intel NUC")
      • I can get into BIOS pressing F2 and it works fine too
      • Going into Linux boot I can see GRUB in text mode
      • When Linux switches to graphics mode TV does not show anything, in fact TV just says "No Signal" as if NUC does not send anything to HDMI.
      • This happens both with LiveCD on USB flash (latest Ubuntu 17.10) and with Ubuntu installed on SATA SSD.
      • I tried to play with BIOS settings changing every possible option, nothing helps
      • I also tried to change Linux video driver in X11 between intel/modesetting, does not help either
      • Even if TV does not show any picture I know that Linux boots and Kodi start OK, I can connect to the box with VNC and it shows expected picture, Kodi says it's configured for 1920x1080 display, just as expected.
      • From VNC I tried to change Kodi screen resolution, and that sometimes makes NUC to show picture on a TV, but it is not very consistent (works more frequently on lower resolution, but almost never for 1080p).
      • I tried it also on my other TV, 1080p LG, and it has the same problem.

      I'm not sure what else to try, but to me it make my new NUC unusable (even before I get into audio over HDMI step which I expect to be a problem).

       

      Does anyone see anything similar to my experience, or did you manage to make it work?