3 Replies Latest reply on Mar 19, 2018 9:32 AM by N.Scott.Pearson

    STK1AW32SC EMI/ESD crashes USB subsystem

    bulletim3

      Hello

       

      I have several Intel Compute Sticks STK1AW32SC (H93326-103 and H93326-104). Running the latest BIOS and x86 Ubuntu server Xenial 16.04.4. I'm using the compute sticks to build a network device that has multiple wifi cards (always in monitor mode) connected through a 4 port hub to the USB 3.0 port. I use the onboard wifi to connect to a local network and the system just does its job, works for months on end, no issues whatsoever.

       

      However, when I disconnect the onboard wifi and add a 3G USB modem to the mix (connected to the USB 2.0 port) I start experiencing USB issues. Every now and then I see messages like "[15775.183824] usb 1-2-port1: disabled by hub (EMI?), re-enabling..." in the kernel log. This can result in one of two scenarios:

      1. The disconnected USB device recovers with no issues and its business as usual
      2. The USB subsystem crashes, the disconnected USB device(s) "fail to enumerate" making USB ports completely unusable

       

      When scenario two occurs, even a system restart does not seem to resolve the issue and human intervention is required to physically unplug and replug (so that the internal circuits discharge?). After which the system boots and starts working normally again until it experiences one of the above two scenarios again.

       

      Troubleshooting done so far:

      • Have tried using different USB cables, hubs, wifi cards, compute sticks and 3 different brands of 3G cards. This means that all hardware is most probably working as designed.
      • Plugged all wifi cards and the 3G modem on a powered USB hub. This setup seems stable, but requires more testing to confirm if this actually works. However, this makes the setup bulky and requires more power sockets and components and so is not ideal at all. (This test may suggest that the powered USB HUB provides Vcc isolation? And could suggest that the ESD transient is simply travelling up the Vcc line???)
      • Have shuffled around the various components in the box to ensure that the devices were not just interfering with each other.
      • I know that USB 3.0 devices can create certain amount of EMR, but none of my USB devices are USB 3.0.
      • All the USB extension cables are shielded and are no longer than 6cm (~2.5 inches long)
      • The EMI issue happens randomly and I have no way of reproducing it on demand, which also makes troubleshooting very hard.

       

      Questions:

      • What exactly is happening here? I need to understand what is going on here before I can try and resolve this issue. If EMI is creating interference, what sort of interference is it creating? Are they just random transients causing issues over the Vcc rail or perhaps even the data lines?
      • Which device is causing the issue here? I'm inclined to say the 3G modem but I've tried 3 different brands so far which makes me wonder if the real issue here is the low EMI tolerances in the Intel Compute Stick?
      • I found a USB 3.0 EMI filter (https://www.allaboutcircuits.com/news/when-you-need-a-little-emc-help-a-new-usb-3.0-emi-stick-from-wurth/) but hesitent to try it until I can understand what the issue really is. What are your thoughts on using something like this on the USB 3.0 port?
      • What else can I try to resolve this issue?

       

      Sorry about the long post, I wanted to be very thorough. Thank you for reading and your help in solving this issue!

        • 1. Re: STK1AW32SC EMI/ESD crashes USB subsystem
          Al Hill

          I know it is not the answer you want to hear, but your OS is not supported on the STK1AW32SC:

          Supported Operating Systems for Intel® Compute Sticks

           

          Only Windows 10 is supported.

           

          Doc

          • 2. Re: STK1AW32SC EMI/ESD crashes USB subsystem
            bulletim3

            Oh interesting, thank you for pointing that out. I'm wondering how accurate that page is though? The latest BIOS (0038) on these compute sticks lets you select Android as an operating system to install on the device and Android is not even mentioned on that page.

             

            I'm also curious if an official response from Intel would be similar? Because if so, then this is important information for any business looking to invest in most of Intel compute stick range (and possibly other Intel products) for open source projects.

             

            Anyways, I was simply hoping to draw upon the experience and expertise of this community to troubleshoot a problem that seems like a hardware issue. Appreciate your time

            • 3. Re: STK1AW32SC EMI/ESD crashes USB subsystem
              N.Scott.Pearson

              Let me say it a different way: While it is true that the boot of other O/Ss is supported, Intel Customer Support will only provide support for issues related to Windows.

               

              If you want to see an issue addressed, you essentially have to demonstrate that the issue also occurs with Windows or you debug it to the point where it can be shown that the BIOS is responsible.

               

              ...S