4 Replies Latest reply on Mar 18, 2018 7:58 AM by blueribb1

    D53427RKE BIOS update fails


      I have two almost identical Intel NUC's. One is a DC53427HYE and the other is a D53427RKE. I run Libreelec (Kodi) on both and I am starting to experience problems with waking from Suspend and intermittent black screens. I decided to update the BIOS on both machines. They both had an older version installed (0042). I successfully updated the DC53427HYE without any issues to BIOS version 0049 (latest). The D53427RKE starts to run the BIOS update and stops on "Management something error" and then reboots to Libreelec. I tried the IFLASH and F7 methods and also tried different USB drives, but they all fail with the same error. I should take a quick photo to capture the exact message but I thought I'd post this first to see if there was something I could try.

        • 1. Re: D53427RKE BIOS update fails

          What you need to do is attempt to reinstall the latest available BIOS, but this time use the Jumper-based BIOS Recovery method. This process is documented here: Intel NUC BIOS Recovery Update Instructions. Here re some recommended extra steps you should perform:


          1. It is better to use a USB 2.0 flash disk than it is a USB 3.0 flash disk.
          2. Regardless, you should reformat your USB flash disk first. Do this on a Windows-based PC (not Linux and not MACOS). Do a full reformat; disable the Quick option and use the FAT32 file system.
          3. Place only the .BIO file for the BIOS on the flash disk.
          4. Follow the instructions for doing the jumper-based BIOS Recovery process.


          Just to be sure, it is worth following this process on both NUCs.


          Hope this helps,


          • 2. Re: D53427RKE BIOS update fails

            Thanks. I'll give that a try tomorrow. In the meantime I formatted an older USB 2.0 Flash Drive in my Windows 10 Desktop and installed just the .BIO file and tried updating using the F7 method again. This time I took a quick snapshot. Some of the text is outside the TV boarder, but most can be read. See the attached image below:

            • 3. Re: D53427RKE BIOS update fails

              It worked !


              I removed the bottom cover and spotted the yellow jumper. Removed it and inserted the USB drive. Powered on and sat back to watch it update. Took quite a while (~5 minutes) but all went well. I powered down, replaced the jumper and reset the BIOS (default) and made some individual changes before exiting and trying the system. It will be a week or so until I'm sure the issues I had are gone.


              I really appreciate the help.


              Thanks again,


              • 4. Re: D53427RKE BIOS update fails

                After a week my problems were still present. I did manage to fix both the intermittant black screen and intermittant start from suspend. The problem turned out to be the placement of the external USB IR (infrared) sensor I was using. When placed directly under my LCD TV, these problems happened. When I moved the IR sensor away from the TV a few inches, both problems seem to be gone. Again, it will take a week or so to be sure. I googled IR interference and found this solution.