2 Replies Latest reply on Mar 14, 2018 12:45 AM by Intel Corporation Branched to a new discussion.

    e1000e: GE NIC Link is Down/Up

    firmware

      Hi.

      I am having problems with 82574L

       

      Hardware :

      03:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection

      04:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection

      05:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection

      06:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection

       

      System:

      Centos 7.3   kernel´╝Ü3.10.0-514.el7.x86_64

       

       

      Output from message

      Feb 26 20:50:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Down

      Feb 26 20:50:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

      Feb 26 22:10:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Down

      Feb 26 22:10:04 localhost kernel: e1000e: slot0_GE4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

      Feb 26 22:40:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Down

      Feb 26 22:40:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

      Feb 26 23:20:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Down

      Feb 26 23:20:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

      Feb 26 23:30:02 localhost kernel: e1000e: slot0_GE2 NIC Link is Down

      Feb 26 23:30:02 localhost kernel: e1000e: slot0_GE2 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

      Feb 27 01:10:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Down

      Feb 27 01:10:04 localhost kernel: e1000e: slot0_GE4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

      Feb 27 03:10:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Down

      Feb 27 03:10:02 localhost kernel: e1000e: slot0_GE4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

       

       

      modinfo

      filename:       /lib/modules/3.10.0-514.el7.x86_64/updates/drivers/net/ethernet/intel/e1000e/e1000e.ko

      version:        3.3.6-NAPI

      license:        GPL

      description:    Intel(R) PRO/1000 Network Driver

      author:         Intel Corporation, <linux.nics@intel.com>

      rhelversion:    7.3

      srcversion:     6453212B70344504D53DE09

      alias:          pci:v00008086d0000105Esv*sd*bc*sc*i*

      depends:        ptp

      vermagic:       3.10.0-514.el7.x86_64 SMP mod_unload modversions

      parm:           copybreak:Maximum size of packet that is copied to a new buffer on receive (uint)

      parm:           TxIntDelay:Transmit Interrupt Delay (array of int)

      parm:           TxAbsIntDelay:Transmit Absolute Interrupt Delay (array of int)

      parm:           RxIntDelay:Receive Interrupt Delay (array of int)

      parm:           RxAbsIntDelay:Receive Absolute Interrupt Delay (array of int)

      parm:           InterruptThrottleRate:Interrupt Throttling Rate (array of int)

      parm:           IntMode:Interrupt Mode (array of int)

      parm:           SmartPowerDownEnable:Enable PHY smart power down (array of int)

      parm:           KumeranLockLoss:Enable Kumeran lock loss workaround (array of int)

      parm:           CrcStripping:Enable CRC Stripping, disable if your BMC needs the CRC (array of int)

      parm:           EEE:Enable/disable on parts that support the feature (array of int)

      parm:           Node:[ROUTING] Node to allocate memory on, default -1 (array of int)

      parm:           debug:Debug level (0=none,...,16=all) (int)

       

      [root@localhost ~]# ethtool -k slot0_GE4

      Features for slot0_GE4:

      rx-checksumming: on

      tx-checksumming: on

      tx-checksum-ipv4: off [fixed]

      tx-checksum-ip-generic: on

      tx-checksum-ipv6: off [fixed]

      tx-checksum-fcoe-crc: off [fixed]

      tx-checksum-sctp: off [fixed]

      scatter-gather: on

      tx-scatter-gather: on

      tx-scatter-gather-fraglist: off [fixed]

      tcp-segmentation-offload: on

      tx-tcp-segmentation: on

      tx-tcp-ecn-segmentation: off [fixed]

      tx-tcp6-segmentation: on

      udp-fragmentation-offload: off [fixed]

      generic-segmentation-offload: on

      generic-receive-offload: on

      large-receive-offload: off [fixed]

      rx-vlan-offload: on

      tx-vlan-offload: on

      ntuple-filters: off [fixed]

      receive-hashing: on

      highdma: on [fixed]

      rx-vlan-filter: on [fixed]

      vlan-challenged: off [fixed]

      tx-lockless: off [fixed]

      netns-local: off [fixed]

      tx-gso-robust: off [fixed]

      tx-fcoe-segmentation: off [fixed]

      tx-gre-segmentation: off [fixed]

      tx-ipip-segmentation: off [fixed]

      tx-sit-segmentation: off [fixed]

      tx-udp_tnl-segmentation: off [fixed]

      tx-mpls-segmentation: off [fixed]

      fcoe-mtu: off [fixed]

      tx-nocache-copy: off

      loopback: off [fixed]

      rx-fcs: off

      rx-all: off

      tx-vlan-stag-hw-insert: off [fixed]

      rx-vlan-stag-hw-parse: off [fixed]

      rx-vlan-stag-filter: off [fixed]

      busy-poll: off [fixed]

      tx-sctp-segmentation: off [fixed]

      l2-fwd-offload: off [fixed]

      hw-tc-offload: off [fixed]

      [root@localhost ~]#