10 Replies Latest reply on Mar 1, 2018 5:41 PM by Wibble

    NUC6i7KYK boots to EFI Shell only



      I have recently run into a problem with my Skull Canyon and it booting.

      For a couple of days, it would pause for a long time on the Intel logo after power on and before displaying the text inviting to press F2 for BIOS.

      I entered the BIOS and turned off all other boot device options except for the two SSD drives internal to the computer (linked in a single RAID drive for the Windows partition). I turned off legacy boot support and tried to make sure the system would only look at the drive with the Windows partition.

      Well, now it only boots to the EFI shell.

      - It does not display the Intel logo, it does not invite me to press F2 for BIOS, it does not respond to any keypresses.

      - It merely puts up the text for the EFI shell and seems to have two devices mapped (which must be the two SSD drives). It then asks me to press escape to avoid entering the shell as it counts down, but does not respond to keypresses. At the shell prompt the system is similarly inert. All I can do is turn it off.


      I have tried pressing the power key for three seconds when turning it on, but that does not change the behaviour. Pressing the power key for thirty seconds makes the system completely unresponsive until I disconnect the power supply.

      I have tried moving the BIOS jumper on the motherboard from BIOS to SEC, but that makes no difference.

      I cannot disassemble the computer further (I had heard there may be a BIOS battery on the other side of the board); the heatsink to the processor seems to be stuck on something.

      It does not matter what is connected to my computer or what I disconnect (I have a wireless keyboard and mouse; a Razer Stargazer camera; XBox controller dongle; Thunderbolt 3 hub with Blu-Ray drive, 3.5" floppy drive and two firewire drives). It does not matter into which port I connect the keyboard and mouse dongle.


      My system had all the updates from the Intel updater and Microsoft applied to it as of Feb 17, 2018.


      I have seen similar threads for other Intel products in this community but no answer other than that Intel have managed to reproduce the issue.

      Can anyone help me recover my computer?

        • 1. Re: NUC6i7KYK boots to EFI Shell only

          I should note that this is a fresh thread on this topic as one that I read for a NUCi5 mentioned creating fresh threads for similar behaviour on different hardware. I have not found another question for a NUC6i7KYK with this problem, which makes me nervous...

          • 2. Re: NUC6i7KYK boots to EFI Shell only

            Did you try setting your BIOS to default settings? Since you don't see the usual menu with F2, try to enter to the Power Button Menu:

            Press and hold the Power Button for about 3 seconds. You should release the Power Button soon as the power led changes color from blue to amber. NUC will reboot into Power Button Menu. When you will see the Power Button Menu, press F2 to enter BIOS. Now, press F9 (followed by "Y") to set default settings. Finally press F10 (confirm by pressing "Y"), to save the settings and exit BIOS.




            • 3. Re: NUC6i7KYK boots to EFI Shell only

              Hello Leon,

              As described in my question, I have tried the three-second press of the power button, but it does not take me to any BIOS settings. I have not noticed any colour differences with the power button (that at least was new information to me).

              However, just to be completely clear, I shall try it once more and pay special attention to the button illumination.

              • 4. Re: NUC6i7KYK boots to EFI Shell only

                I have examined the power button for colour changes. It remains black until I release it, It never shows any other colour than Blue or White (it shows white when powered on, I know I could set it to blue when the NUC was working properly). I do not know which product has an amber colour, but I don't think it is the NUC6i7KYK.

                • 5. Re: NUC6i7KYK boots to EFI Shell only

                  My instruction are correct. See paragraph 3.7.4 (sub paragraph 3. on page 53) of your NUC Technical Product Specification: https://www.intel.com/content/dam/support/us/en/documents/boardsandkits/NUC6i7KYK_TechProdSpec.pdf  . In addition if you will connect a headphone or amplified speaker to the front 3.5 mm audio receptacle, the system will emit three beeps in a moment you may release the power button in order to boot into Power Button Menu.


                  An other alternative to get F2  is from Configuration Menu:

                  1. Disconnect the power adapter and remove the bottom cover from your NUC.
                  2. Remove the yellow security jumper (see Product Technical Spec, para., page 39: ) and close the bottom cover.
                  3. Reconnect the power adapter and power ON the NUC. Wait 30 sec - 2min, you will see the Configuration Menu

                     4. Press F2  to enter BIOS. Press F9 (followed by "Y") to set BIOS defaults. Press F10 folowed by "Y" to save the settings and exit BIOS.

                     5. Switch the power OFF, remove the power adapter and replace the Security Jumper.





                  • 6. Re: NUC6i7KYK boots to EFI Shell only

                    Thank you Leon,

                    That sounds suspiciously similar to what I have tried, but much more specific.

                    Let me try it out and let you know.

                    • 7. Re: NUC6i7KYK boots to EFI Shell only

                      Hello Leon.

                      I have tried your suggestion regarding the beeps.

                      Firstly, they are not beeps but alarming squeals that, when I first heard them frightened me so much I let go of the power button. Intel really must try harder to make their hardware emit less alarming sounds.

                      Anyway, I was able to approximate your described behaviour, but it still won't boot to anything other than EFI shell.


                      From it being unplugged, I connect the power supply and hold the power button for a few seconds (up to 15 seconds). The computer does nothing. When I release the power button it boots to the EFI shell as I had previously described.

                      If I tap the power button to turn it off then it will only boot to the EFI shell no matter what button press I do to turn it back on.

                      However, I did find that if I hold the power button for 5-6 seconds when powering off from the EFI shell then I can release and then immediately hold the power button for long enough (a few seconds) such that the power light comes on white and the harsh squeals are heard. However, I shall hear anything from between one and three squeals and then the computer turns itself off. It never progresses any further. If I immediately release and press the power button after it has turned itself off then it will repeat the behaviour, but if I release the power button and don't press it for a few seconds then I have to let it boot to the EFI shell and then hold the power button for 5-6 seconds while it turns off to get it back to squealing before turning off.

                      It will always turn itself off during or immediately after the three squeals.


                      Regarding the boot jumper. I assume that removing the jumper is the same as transferring it to the "SEC" pair of pins. This only boots to the EFI shell just as with the jumper in the BIOS position, as I first described.

                      • 8. Re: NUC6i7KYK boots to EFI Shell only

                        Hello Wibble

                        Sorry to hear that your computer is still stuck in EFI Shell and you are not be able to get the Power Button Menu. However you are wrong about the Security Jumper positions. Actually there are three jumper positions:


                        - NORMAL (between pins 1-2) , for normal operation


                        - LOCKDOWN (between pins 2-3), All POST Hotkeys are suppressed (prompts are not displayed and keys are not accepted. For example, F2 for Setup, F10 for the Boot Menu). Power Button Menu is not available . I hope that Security Jumper in your NUC is not connected between pins 2-3, because if yes, this will explain why you don't have Power Button Menu.


                        - CONFIGURATION (without jumper). In this third position after power On, BIOS Recovery Update process (BIOS Recovery Update Instructions for Intel® NUC ) starts automatically if a KY0051.bio file is found on USB stick Download BIOS Update [KYSKLi70.86A] .  However if there is no any USB stick with valid bios file, NUC will boot into Configuration Menu (similar to one on the attached image).


                        For complete description of Security Jumper position, please refer to table 14 on page 40 in the Product Technical Specification I've given you in my post.


                        So, my suggestion is now:

                        1. Recover BIOS using Security Jumper Removed method. BIOS Recovery Update Instructions for Intel® NUC

                        2. Reboot the computer (with the Security Jumper removed and without USB with Bios file) in order to reach the Configuration Menu.

                        3. Enter Bios by pressing F2 and restore bios defaults (as explained in my previous post).


                        Finally, if you will not be able to perform the above steps or if this will not solve your problem, in my opinion you shall disconnect the CMOS battery for 10 minutes (after removing the board from the casing).



                        • 9. Re: NUC6i7KYK boots to EFI Shell only


                          I shall try this.

                          • 10. Re: NUC6i7KYK boots to EFI Shell only

                            Hello Leon,

                            Thank you for your help. You have identified the answer and it has helped me establish the underlying cause for my computer's behaviour.

                            Removing the jumper allowed the computer to boot into a safe version of the BIOS where I was able to make changes that allowed my system to boot.

                            After that was fixed, I was still stuck with a computer that booted far too slowly.

                            I have since discovered that my USB3.0 Blu-Ray drive is knackered for some reason and was holding up the boot while it looked for optical drives.

                            By disabling that option I now have a computer that boots properly and quickly.