8 Replies Latest reply on Feb 21, 2018 1:52 PM by Ronald_Intel

    Another 4k@60hz issue

    blistovmhz

      I notice a trend here, in that every other post is about 4k not working at 60hz on the 620/630 chips

       

      I'm in the same boat. Bought an Asus UX430 (8th gen, UHD630). It only has USB-C/TB/eDP output. Connected to my 4k display (LG 49UJ6300) but only lists 30hz and under.
      For reference, my nearly 6 year old ROG laptop connected to the same display via hdmi has no issue getting 4k@60hz with 12ms input lag. I've tested with several other Nvidia GPU's and they all work as well.

       

      So I figured maybe Asus somehow borked their setup, so I talked to Razer about the Blade 14 (2017) and they were absolutely positive that their USB-C/TB port would support 2x 4k displays at 60hz each, when connected via a USB-C/TB > HDMI2.0 dongle. So I bought one. Guess what. Also doesn't work.

       

      I've tested both in Windows and Linux with the last 5 most recent drivers from Intel. Same results every time. The Blade has a discrete 1060 as well, so I connected it to the same TV. Works fine at 60hz.

       


      There are two common denominators I've seen in every single post regarding the 620/630 and 4k @60hz, and that is the chip itself, and the use of the USB-C/TB/eDP > HDMI2.0. I know there are a ton of bad adapters out there, but mine has been tested and proven to work by multiple people. I did find a few threads from a few months back, which suggested several people had got 60hz working (through the USB-C/TB port) by "upgrading" to the then most recent Beta driver. That was driver I believe was Beta_15.40.26.64.4474. They ALL said that when they updated to the most recent stable drivers, their 4k dropped back down to 30hz.

       

      Any idea's? I've only got a few days left to return these laptops. They're useless to me without 60hz. Can't even mouse properly at that speed.

       

      *EDIT* Just added another test to the list. Realized my Asus UX430 also has a miniHDMI2.0 port so I tried that, again to the same display. Same result. 4k@30hz.
      Also just for giggles, I tested all three setups successfully at 1440p@60hz and 1080p@120hz.

       

      So to be clear, my HDMI cable isn't the issue as it works in 4k@60hz from any nvidia GPU dating back to the early 7xx series.

        • 1. Re: Another 4k@60hz issue
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello blistovmhz 

          Thank you for joining the community.

          To investigate further the situation could you provide us with the Intel® System Support Utility for Windows* report for both of the PCs when they are connected to the external display. Please attach the report to the thread

          https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

          What is the model of both of the PCs?

          Can you provide us with the video connection configuration that you are using? (Type of cables, model of adapters)

          This information will help us to investigate your situation  

          Regards,
          Leonardo C.
           

          • 2. Re: Another 4k@60hz issue
            blistovmhz

            I "CAN" do this, but as I've returned the Razer Blade (for multiple reasons), all I have left now is the Asus UX430 on which I am currently running Linux, so I'd have to install windows first. I really don't want to do that at this point, unless someone from Intel can actually confirm that the USB-C/TB should support 4k@60hz (ie: I keep hearing that it should, but I haven't seen on any of the very numerous forum posts about this issue, that anyone has ever seen it work).

             

            Can someone on your end actually test this before I wipe out another installation just to install windows to test something I've already spent 3 full days on?
            EG:, can someone try to reproduce the issue with a similar setup?

             

            Asus UX430 connected to an LG 49UJ6300 TV via HDMI2.0 port. (All Nvidia GPU's are able to connect to the TV at 4k@60hz via TMDS (single). Full color  range, YCbCr420 color space, 8bpc.
            UX430 has been tested to the same display using the same HDMI2.0 cable via two methods.

            1. UX430 microHDMI2 port > microHDMI2 adapter > HDMI2.0 > TV.
            2. UX430 USB-C > USB-C to HDMI2.0 hub > HDMI2.0 > TV.

             

            The USB-C hub currently being tested is listed here: Amazon.com: ZYNUN USB C to HDMI Adapter for Nintendo Switch,Samsung Note 8,Galaxy S8/S8 Plus(Dex Mode),2017/2016 Macbook…

             

            I have also tested 3 other USB hubs, all confirmed to be connecting to 4K sets @ 60hz.

             

            I thought at first that the USB-C hubs were all just junk, but I've found several people who have posted videos confirming 4K@60hz operation with the same hubs. The built in microHDMI port also doesn't do the trick.
            I notice that nearly every post here for the past several months has been from people asking why their HD 620/630 won't output 60hz, but haven't seen any resolved.

             


            As I said, I CAN install windows if absolutely required, but I'd much prefer that someone at Intel verify correct operation on their end so I know the issue must be something on my end.

             

            Oh, I will suggest that perhaps the issue is that the Intel drivers are not allowing a YCbCr420 colour space, which for nearly every 4k TV, would be mandatory for 60hz operation.

             

            Attached log output for:
            * xrandr output from both an nvidia (working 4k@60hz connected via HDMI) and the Intel® UHD Graphics 620 connected via USB-C>HDMI2.0 adapater (4k@30hz max).
            * xorg log
            *  620 modelines and setings.

             

            The driver reports an error with the 620 when trying to set a modeline >30hz. Running the latest intel driver.

            • 3. Re: Another 4k@60hz issue
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello blistovmhz   

              Thank you for the information provided
               
              The output of the USB type C/TB will support the same range of the display port 1.2 capable of working at 4k@60Hz according to the specs or the display LG 49UJ6300 the resolution can go up to 3840 x 2160 4K UHD 2160p, can you provide us with the version Micro HDMI output? And the version of the HDMI® input of the display? That information as not able to be confirmed in the model specs found on the following link
               
              http://www.lg.com/us/tvs/lg-49UJ6300-4k-uhd-tv
               
              On the set up that you are using in both cases I see that you are using adapters, in this case, please bear in mind that Intel® does not recommend the use of any kind of adapters. This is because we cannot test all of them, so we cannot guarantee that these are going to work, we are would like to verify I you can try to use connections peer to peer for example micoHDMI® to HDMI® (no adapters in between)?
               
              Does the built-in display is giving you the resolution on 4K@60hz?  
               
              Regards
              Leonardo C.
               

              • 4. Re: Another 4k@60hz issue
                Toons

                I know you're discounting the adaptors but that was the only way I could get mine to work and has been stable through all updates

                 

                I went for one of the newer active Mini Display port Active adaptors to female HDMI and it worked a treat

                 

                At first I had to reduce the protocol to 4.2.0 but now it's happy with the enhanced 4.2.2

                 

                I can display 4k UHD @60 Hz

                 

                It was driving me up the wall
                The one I bought that worked was an ALOGIC,  PART code  - MDP-HD4KAC

                • 5. Re: Another 4k@60hz issue
                  blistovmhz

                  Well just looking at the intel chipset specs, it says the microHDMI will only be 1.4, so the only possible way to use 4k@60hz then would be though the USB-C/Thunderbolt correct?

                  The LG 49UJ6300 definitely supports 4k@60hz with 4:2:0, as that's what i"m running it at right now with my Nvidia 780.

                  The Asus laptop only has 1080 internal display.

                   

                  The reason I'm asking Intel to test the TB output, is that I haven't been able to find anyone who can confirm that it will output 4k@60hz, and other than Intels marketing and spec sheets, I haven't heard any Intel reps confirm this output.

                   

                  Given the specs state specifically that it only has HDMI1.4 on the chip, TB would be the only possible way to get 4k@60hz, so I assume that must be what Intel is referring to in the docs.

                  • 6. Re: Another 4k@60hz issue
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hello blistovmhz     

                    Thank you for your response
                     
                    For the Intel® 8th generation processors the resolution, in general, is 4096x2304 and might run at 60Hz. The refresh rate that you may get out from the laptop or PC depends on the type of display interface (HDMI, DVI, DP) used by the OEM manufacturer. Since we are talking in this case of USB type C/ TB as mentioned previously that is equivalent in bandwidth to Display Port (DP) 1.2 it can reach a maximum bandwidth of 17.28 Gbit/s. Therefore the maximum resolution for your device/adapter will be 3840x2160@75Hz meaning a bandwidth of 15.79 Gbit/s.
                     
                    This link can help you to find the processor information
                     
                    https://ark.intel.com/products/series/122593/8th-Generation-Intel-Core-i7-Processors
                     
                    For your convenience, I have found this link for ASUS* support
                     
                    https://www.asus.com/support/
                     
                    Regards
                    Leonardo C.
                     

                    • 7. Re: Another 4k@60hz issue
                      blistovmhz

                      I am aware of the specs. I  have posted them in this thread a few times. I've also contacted Asus support and they say it must be an Intel driver issue.
                      Given there has been discussion on this very forum, about an older "beta" driver working correctly but the newer stable drivers exhibiting the same symptoms I'm seeing, I strongly suspect there is a driver issue.

                       

                      Again, I'm asking Intel to test USB-C/TB>HDMI2.0 output on a 4k TV that supports 4:2:0. I suspect the Intel driver doesn't attempt 4:2:0, or it determines that HDMI is on the other end of the adapter and just gives up rather than attempting 60hz.
                      There is no technical reason why my setup should not work. Hell, I have HDMI 1.4 from my Nvidia GPU working correctly, so a USB-C/TB to HDMI2.0 interface should easily be able to support this bandwidth.

                       

                      I've also asked if someone could explain why setting the 3840x2160@60hz modeline manually results in the intel driver throwing an error stating "insufficient bandwidth". This is clearly incorrect as you just confirmed the worst case scenario here would be equivalent to DP1.2, yet I am asking the driver for less bandwidth than that and being told 60hz is going to exceed the available bandwidth.

                      • 8. Re: Another 4k@60hz issue
                        Ronald_Intel

                        Hi blistovmhz,

                         

                        While Intel cannot recommend or endorse specific 3rd party adapters/dongles, I was able to successfully get 4K@60hz with this USB Type-C to HDMI 2.0 adapter.

                        As for Thunderbolt 3, I was also able to use this Thunderbolt 3 Dual-4K Docking Station and also get 4K@60hz.

                        My test system consisted on an Intel® NUC Kit NUC7i3BNH (Intel® Core™ i3-7100U Processor with Intel® HD Graphics 620) connecting it to an LG-OLED55E6P via HDMI 2.0

                         

                        Perhaps I can help you dig further... can you share the make and model of the adapters and dongles you have used so far?

                         

                        Best Regards,

                        Ronald M.

                         

                        P.S. Sorry I found this post right after I replied to you here 4k resolution issue intel hd 630 graphics  so I basically did copy+paste of my reply here.