11 Replies Latest reply on Mar 13, 2018 7:35 PM by UffeBerra

    Nuc6i7kyk sound issues


      I have tremendous issues getting the sound working properly on my NUC6i7KYK (Skull Canyon). I am running sound over HDMI to my Denon AVR1910.


      I have three different operating systems on my computer and each of them showcase different types of issues. I am really at the end of my rope with this quite expensive but seemingly faulty computer. 


      * LibreElec - Mostly works, but occasionally cuts out.

      *  Ubuntu 17.10 - Usually works from start after setting up the sound on every reboot. Typically dies after watching for a while. At times only stereo sound works.

      * Windows 10 - Start netflix, everything works. PAuse movie, play again - no sound. Change sound configuration (switching between 5.1 and 7.1) and restart movie and I have sound again.  It is not specific to netflix, but merely an example of how I typically run into the issue.


      I feel like I have tried everything. As a last resort I re-installed windows and all drivers from scratch. No dice.


      Does anyone else have this problem and more importantly were you able to resolve it.


      Any and all help is appreciated.



        • 1. Re: Nuc6i7kyk sound issues
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello, UffeBerra.

          Thank you very much for taking the time to reach the Intel® Communities Team.

          I understand you are facing some sound issues with your NUC6i7KYK. I will be more than glad to assist you further.

          In this case, can you please update the BIOS? In order to achieve so, download the latest BIOS version by clicking here and, for you to complete the update please use the following guide: http://https://www.intel.com/content/www/us/en/support/articles/000005532/mini-pcs.html

          Furthermore, please confirm for me where the AVR is connected to, the model of the device in use and the cable used.

          Antony S.

          • 2. Re: Nuc6i7kyk sound issues

            Hi Antony,


            Thanks for responding. I have installed the latest BIOS. I attached the Intel® Driver & Support Assistant report to this post.


            My receiver is a Denon AVR1910. I connect to the receiver via the HDMI port on the NUC, using a generic HDMI cable. (My Video output from the receiver goes to a projector, if that makes any difference.)

            I have tried a couple of different cables without any success.


            In addition to my previous post, I should mention that I have no sound issues using my bluray player with the same receiver. My old computer never displayed any of these issues using the same receiver.




            • 3. Re: Nuc6i7kyk sound issues
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello, UffeBerra.

              Thank you very much for your reply and the information provided.

              In this case, for me to provide you with more accurate information, I will escalate this case to a different level of support. This might take some time nevertheless, once I have an update I will definitely let you know.

              Antony S.

              • 4. Re: Nuc6i7kyk sound issues

                Thanks Antony, I would appreciate your continued support.



                • 5. Re: Nuc6i7kyk sound issues

                  Hi Patrick,


                  I checked your system configuration report and I see that the system is fully updated, the only thing I was not able to confirm is if your AVR is HDMI 2.0 ready.

                  If your AVR is HDMI 2.0 enabled, I would recommend that you run the following firmware update: https://downloadcenter.intel.com/download/26061/-HDMI-2-0-Firmware-Update-Tool-for-Intel-NUC-Kit-NUC6i7KYK?product=89187

                  After reading the issue description it sounds like it might be a handshake issue when the connection is interrupted and it needs to negotiate again. If the connection is dropped even for a fraction of a second the receiver has to renegotiate the handshake. Receivers usually take more time to do this than a regular TV.

                  Can you try a straight connection to the TV and see if the issue persist? The TV has to do the same negotiation but it may not be as noticeable as when you use the AVR.



                  Ronny G

                  • 6. Re: Nuc6i7kyk sound issues

                    Hi Ronny,


                    That sounds like a plausible explanation, albeit not a satisfying one. It works without issues playing content from my blueray player and it worked on my old computer running Ubuntu. 


                    Myreceiver is not HDMI 2.0 ready. It's a fairly old receiver (Denon AVR-1910).


                    I am using a projector for video output. The projector doesn't have any speakers so I tested the computer on my old TV. I didn't experience any sound issues in Windows 10 during my short test. In Ubuntu I couldn't get surround sound working (presumably just a configuration issue that could be resolved with some research).


                    Thanks for your continued support.



                    • 7. Re: Nuc6i7kyk sound issues

                      Any suggestions on what to do next? Buy a new receiver / new computer?

                      • 8. Re: Nuc6i7kyk sound issues

                        Well, that's the optimal answer. An alternative is to use the RealTek audio solution. With the KY NUC, you can deliver 5.1 audio over an optical connection to your receiver.


                        Hope this helps,


                        • 9. Re: Nuc6i7kyk sound issues

                          Thanks for your input Scott. I don't think my receiver supports audio delivery over optical whilst delivering image over HDMI for the same input. I played around with an optical cable and couldn't get it working. I furthermore tried to run sound and video via display port (dp to hdmi converter), but I had no luck with that either. At this point I am assuming that I either have a hardware problem in the NUC or that the drivers are sub par.


                          I just ordered a new raspberry pi as I am sure none of these issues will exist with that hardware (I used to run the original pi on the very same receiver without any issues). I will then make the NUC a work only computer as it doesn't seem capable of handling home entertainment duties.



                          • 10. Re: Nuc6i7kyk sound issues

                            Even though you don't have an HDMI 2.0 receiver did you try the firmware patch?


                            Also, someone suggested on another forum to try a mDP to HDMI or TB3 to HDMI dongle.

                            • 11. Re: Nuc6i7kyk sound issues

                              I have not run the HDMI 2.0 firmware update as the description for the update clearly states:

                              An HDMI 2.0 device must be connected when you run this Firmware update, or the following error is displayed: "OUI mismatch!" and/or "Product ID error! Please check your firmware".


                              I tried mDP to HDMI, the issues remain exactly the same.