7 Replies Latest reply on Mar 5, 2018 3:56 AM by Intel Corporation

    Connecting to QGC with ubuntu

    Jeffrey95

      I'm following the instructions here: 90 (References) OS user Installation · intel-aero/meta-intel-aero Wiki · GitHub to attempt to connect by drone (running ubuntu) to QGC on my laptop:

       

      Get your laptop IP and run on Aero:

      • sudo mkdir /etc/mavlink-router/config.d
      • create this file: sudo gedit /etc/mavlink-router/config.d/qgc.conf and fill it with:
      [UdpEndpoint wifi] 
      Mode = Normal
      Address = <my laptop's IP>
      • launch QGroundControl on your laptop. It should receive automatically the telemetry feed from the drone.

       

      Both my drone and laptop are connected to the same wifi network and the qgc.conf file contains the proper IP address of my laptop. However, QGC on my laptop is not connecting to the drone. Any advice for diagnosing this problem?

        • 1. Re: Connecting to QGC with ubuntu
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi, Jeffrey95

          Thank you for contacting Intel Customer Support. 
          What is the output of the get_aero_version.py command?
          Also, can you try to disable the firewall on your computer?  It might be blocking the connection between QGC and the Aero Drone.

          Regards,
          Alexandra

          • 2. Re: Connecting to QGC with ubuntu
            Jeffrey95

            BIOS_VERSION = Aero-01.00.13

            OS_VERSION = Ubuntu 16.04.3 LTS"

            AIRMAP_VERSION = unkown

            FPGA_VERSION = 0xc2

            AeroFC firmware version = unknown

             

            There's no firewall on my computer. I had no problems running QGC when I was running yocto on the drone. This problem only occurred when I switched to ubuntu.

             

            I've updated the FC firmware with the wiki instructions (although it took many attempts to do this successfully):

             

            cd /etc/aerofc/px4/

            sudo aerofc-update.sh nuttx-aerofc-v1-default.px4

             

            However, even after flashing the PX4 firmware, "sudo aero-get-version.py" still shows an unknown AeroFC firmware version.

             

            I can confirm that I'm booted with the proper ubuntu version: when I run "uname -a" I get "Linux my-drone 4.4.76-aero-1.2 #1 ... "

            • 3. Re: Connecting to QGC with ubuntu
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi, Jeffrey95

              Could you please check if the mavlink service is running?:
              sudo systemctl status mavlink-router
               
              Also, could you try restarting the service and provide us the status output:
              sudo systemctl restart mavlink-router
              sudo systemctl status mavlink-router

              Regards,
              Alexandra

              • 4. Re: Connecting to QGC with ubuntu
                Yograj

                Hi Alexandra,

                In my case when I run:-

                sudo systemctl status mavlink-router

                 

                mavlink-router.service - MAVLink Router

                   Loaded: loaded (/lib/systemd/system/mavlink-router.service; enabled; vendor preset: enabled)

                   Active: inactive (dead) (Result: exit-code) since 火 2018-02-20 16:44:11 JST; 1min 40s ago

                  Process: 1080 ExecStartPre=/bin/bash -c echo 4 > /sys/class/tty/ttyS1/rx_trig_bytes (code=exited, status=1/FAILURE)

                 

                2月 20 16:44:11 smartdrone systemd[1]: Starting MAVLink Router...

                2月 20 16:44:11 smartdrone bash[1080]: /bin/bash: /sys/class/tty/ttyS1/rx_trig_bytes: Permission denied

                2月 20 16:44:11 smartdrone systemd[1]: mavlink-router.service: Control process exited, code=exited status=1

                2月 20 16:44:11 smartdrone systemd[1]: Failed to start MAVLink Router.

                2月 20 16:44:11 smartdrone systemd[1]: mavlink-router.service: Unit entered failed state.

                2月 20 16:44:11 smartdrone systemd[1]: mavlink-router.service: Failed with result 'exit-code'.

                2月 20 16:44:11 smartdrone systemd[1]: mavlink-router.service: Service hold-off time over, scheduling restart.

                2月 20 16:44:11 smartdrone systemd[1]: Stopped MAVLink Router.

                2月 20 16:44:11 smartdrone systemd[1]: mavlink-router.service: Start request repeated too quickly.

                2月 20 16:44:11 smartdrone systemd[1]: Failed to start MAVLink Router.

                 

                 

                and When I run 

                sudo systemctl restart mavlink-router

                 

                Job for mavlink-router.service failed because the control process exited with error code. See "systemctl status mavlink-router.service" and "journalctl -xe" for details.

                 

                • 5. Re: Connecting to QGC with ubuntu
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi Yograj,

                  Please make sure you are booting into the correct kernel. Could you share the output of command uname -a?
                  it should be Linux frelon 4.4.76-aero-1.2 #1 SMP PREEMPT Mon Nov 6 19:42:57 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

                  Regards,
                  Alexandra

                  • 6. Re: Connecting to QGC with ubuntu
                    Yograj

                    Hi Alexandra,

                    Sorry for late reply. Here is the output of:-

                       

                        command uname -a

                         Linux smartdrone 4.476-aero1.2 #1 SMP PREEMPT Thu Dec 21 09:55:38 UTC 2017 x86_64 x86_64 86_64 GNU/Linux

                    • 7. Re: Connecting to QGC with ubuntu
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Hello Yograj,

                      Thank you for your reply.

                      I would suggest you re-install the "aero-sytem" package using the instructions on our wiki: https://github.com/intel-aero/meta-intel-aero/wiki/90-(References)-OS-user-Installation or re-install Ubuntu.
                      There seems to be an issue with the mavlink-router configuration and should be working after the fresh install.

                      Hope this helps.

                      Regards,
                      Octavian