5 Replies Latest reply on Apr 12, 2010 7:52 AM by longplaypg

    DP45SG SATA copy reboots

    longplaypg

      When i copy a large amount of files (ex 1 TB of WTV recorded shows or 500 GB of MP3 and photos) to another drive the system will sometimes reboot.

      I have disabled the SMART in the BIOS and that didn't seem to improve anything.

      I was using the default Windows 7 64bit enterprise drivers for AHCI SATA.

      I installed the Intel Rapid Storage Technology Driver 9.6.0.1014 and things speed up a bit, but it did NOT fully fix the reboot issues when copying.

       

      DP45SG

      Core 2 Quad Q9550

      Patriot Viper 4GB Kit PVS34G1333ELK (2x2gb) DDR3 1333

      Antec TP-650

      Windows 7 64bit Enterprise

        • 1. Re: DP45SG SATA copy reboots
          allan_intel

          Did you enable Write back Cache?

           

          if you installed Rapid Storage Technology this option should be under Manage tab

          • 2. Re: DP45SG SATA copy reboots
            longplaypg

            Glad to see the forums are back up, but sad to say I might have a larger underlying problem. I can not currently confirm if write back cache is enabled or not at this time. My system has degraded even further at this time.

            Currently the following is happening...

            Power on computer.

            Intel BIOS graphics display and codes cycle.

            Press F2 to visit BIOS page and all I get is some pink blocks and lines... Definetly not the normal bios screen i am used to.

            Reboot the computer and let it pass the BIOS splash and it can boot off my windows 7 install DVD. It can not finish installing windows without problems copying files. I have picked a different hd than my original one so as to not loose any of my current configuration and files.

            Reboot the computer and let it try to boot off the old original hd but it wants to always chkdsk... it mostly hangs during the 10 second countdown. If i try to skip it by pressing any key it will hang.

            Anyways I will have more time after work tonight. I do NOT have any extra parts laying around. I plan to stop by a store tonight and see if i can pick up a new power supply in case this is my weak link.

            If the power supply does not help for at least entering the BIOS then its time to take this box down and start diagnosing hardware.

            • 3. Re: DP45SG SATA copy reboots
              longplaypg

              Well i must say i am digusted with my DP45SG...

              I installed a new 1000W with 5 power rails that is overkill for the power requirments.

              I have been unsucesful in using my AHCI SATA installation. I do know for a fact the default windows write back cache were enabled. When using the AHCI driver or the Rapid Storage Technology Driver interface i can see the write back cache for windows is enabled.
              Device manager, properties of the hd, policies tab, Write Caching policy, Enable write caching on the device is definetly on and was on by default

              Since i can not complete even a chkdsk or control random reboots with the AHCI SATA drivers I booted into safe mode and removed them.

              I still did not have a stable system.

              I did a FRESH install to a 2nd hard drive with bios defaults loaded. THis forced a IDE SATA instead of the AHCI i prefer to use.

              System installed and ran what seemed fine, but it was not fine. more on that issue later.

              Well at least windows loaded and ran. I tried to flash the bios again with v0125 to fix the pink screen issues when trying to change the bios. This of course did not work.

              I loaded the bios file to a USB memory stick and sat the computer to recovery mode. I turned on the PC but no graphics came up. I didn't try to diagnose it and left the computer go for 20 minutes. It never did shut down. I tried moving the video cable around on the video card but never got a signal. I turned off the computer and sat it back normal bios.

              I turned on the computer and pressed F2, but i could finally read the dang bios screen. Ok so that problem was fixed. I reloaded defaults and saved them. I entered the bios screen on next reboot and confirmed my settings for SATA were not ACHI and on the IDE mode. I booted up the OS and told it chkdsk my c: drive on next boot. This drive was formated and installed using the IDE SATA driver. It completed its chkdsk and things looked fine. Inside windows i asked it to chkdsk my other driver that was formated and used under AHCI mode previously. I asked it to even check bad blocks. I walked away to do something else know it would take a while. I heard the computer reboot. Sure enough windows was saying the system had rebooted. There was no power flucuation and it clearly was behaving like the SATA AHCI now.

              I started reading about DDR3 1333 ram and problems with the DP45SG with Q9950 installed. The really sad part is my memory can pass over 24hrs straight extended memory testing with auto settings. I am NOT trying to overclock anything at all.

              • 4. Re: DP45SG SATA copy reboots
                longplaypg

                Well I was getting ready to run a different test. Tried to enter the bios using F2 and that crappy corrupted pink screen is back. I am currently recovering the bios to see if i can successfully get a clean f2 bios screen again. If i do i think i wil downgrade back to 0121 since i dont remember that problem every happening with that bios. Then i will try underclocking my ram to see if i can get a stable system. Actually i pretty tired of wasting all my free time diagnosing this boards problems.

                Maybe someone will have some words of ecouragement, because all the posts i have been reading are nothing but failures.

                • 5. Re: DP45SG SATA copy reboots
                  longplaypg

                  I checked under the manage button and this is what I find on my SATA port 0 connection.

                   

                  IRST1.jpg

                  This shows that "Disk data cache: Enabled" and might be the write back cache you are quering about.

                  Sadly after doing some tests with 2 different ram kits I believe this board is having issues running DDR3 1333 ram as many other users have complained about.

                  PVS34G133ELK Patriot 4GB kit DDR3 1333 PC 10666

                  If i force the above ram to manual timings, 1066 instead of 1333, and save the bios settings I can then copy files so far without errors.

                  KVR1333D3N9K2/4G Kingston 4GB kit DDR3 1333 PC3 10600

                  This ram seems to do better at auto detecting, but i still noticed some issues. I also forced this ram to 1066 instead of 1333 and those issues seemed to go away.