8 Replies Latest reply on Feb 21, 2018 10:05 AM by Intel Corporation

    7700HQ - Why is it preforming so far below standard?

    Josepharduino

      The laptop is a Dell Inspiron 15 7657 (win 10) - with an Intel i7-7700HQ.

       

      The CPU seems to sit at a constant 0.78GHz (according to taskmanager) while opening programs, browsing the web, and just daily use. The mouse occasionally lags and programs occasionally take long to respond.

      The only time I do see the clock speed vary and even hit 3.5GHz is when I am watching a video on VLC or Windows Video player on fullscreen. When I watch a video on windowed mode the processor sits at 0.78GHz.

      The CPU stays at 0.78GHz even while gaming... it just throttles the whole system ...

       

      Here is a Benchmark: http://www.userbenchmark.com/UserRun/7314617

       

      I have also attached an image of HWMonitors readings (on idle). And another reading from in-game (only played for 3 minutes or so . . ).

       

      In advanced power settings I have set the laptop to be able to use as much power as it needs.

       

      Would be very very appreciative of any comments that could help .

        • 1. Re: 7700HQ - Why is it preforming so far below standard?
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Josepharduino,

          I understand that you believe the unit is performing badly compared to how it should be performing. 

          Regarding this I can see that you ran tests with different third-party benchmark software, however we only recommend to run the testing with Intel® software. You can get our Intel ® Processor Diagnostic Tool in the following link: 

           https://downloadcenter.intel.com/download/19792/Intel-Processor-Diagnostic-Tool

          After downloading this software, please run the test and post the results here so we can check the information.


          Regards,
          David V

          • 2. Re: 7700HQ - Why is it preforming so far below standard?
            Josepharduino

            Oh yeah. I forgot to attach that.. IDPT Test results are attached. I watched the clock speed on task manager for the duration of the test and it went up during/after the "CPUfreq" test then it went back to 0.78GHz after a few seconds...

             

            Just today I left the laptop on while I went out for about an hour and when I came back I opened task manager and saw the clock speed was varying and above 1GHz - pretty much as soon as I did anything it dropped back to 0.78GHz and lag.

            • 3. Re: 7700HQ - Why is it preforming so far below standard?
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello Josepharduino

              Thank you for your response,

              I can see that the processor shows the frequency that it is supposed to show in the Intel ® Processor Diagnostic Tool. If you are having problems still, what I could recommend you to do is to check your power settings and make sure to keep them in "High Performance". You can refer to the screenshot attached for more information.

              Something else that could be tried is to disable Intel ® Turbo Boost and/or Intel ® Speed Step from the BIOS of the computer. This is because Turbo Boost, boosts or lower the frequency according to the system needs but if it is deactivated and in high performance then the processor's frequency should be high. 


              Regards,
              David V

              • 4. Re: 7700HQ - Why is it preforming so far below standard?
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello Josepharduino,

                My apologies, I did not attached the screenshot in the previous post. Please refer to the following screenshot showing the power options.


                Regards,
                David V

                • 5. Re: 7700HQ - Why is it preforming so far below standard?
                  Josepharduino

                  Yes, I noted that. I had task manager running alongside the IPDT and saw the clock speed go up when the "CPUFreq" test module ran. After that it hovered around 1.5GHz then dipped back down to 0.78GHz and stayed at that no matter what I opened or ran.

                  Seems like it doesn't know when to speed up or slow down (?) and only speeds up in certain situations or for certain applications.

                   

                  Advancedpower options.PNG

                  I disabled Intel Turbo Boost from the BIOS. Task manager says the clock speed is still 0.78GHz... Programs and the mousepointer still lag.

                  • 6. Re: 7700HQ - Why is it preforming so far below standard?
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hello Josepharduino,

                    Thank you for your response,

                    I can see that you have set up the power settings, however, Is the problem happening with both the power adapter connected and disconnected or only when it is disconnected? Remember that the processor's performance may be reduced for the lack of power supply connected.

                    Since the Intel ® Processor Diagnostic Tool shows that it runs at the actual frequency then it shows that there is no problem. If you could provide us with a video of the "Lag" and the frequency being low we would be able to better find what the problem can be. 


                    Regards,
                    David V

                    • 7. Re: 7700HQ - Why is it preforming so far below standard?
                      Josepharduino

                      The problem is pretty much constant - 0.78GHz from start up to shutdown. Sometimes I see the clock speed at above 1GHz - only in certain conditions though - such as after watching a video on full screen. Also I left the laptop on for an hour without touching it and when I came back the clock speed was varying.

                       

                      I'm guessing that it possibly isn't problem with the processor but with dells hardware. I've read a heap of forums and most say that disconnecting then reconnecting the battery solves the issue (which I have tried) or replacing the motherboard. Also a few suggest using Throttle Stop which I have tried .. but hasn't worked.

                       

                      I know you can't trust the 'third-party' programs such as task manager and HWmonitor ... but you should be able to trust the recording. Minimizing and expanding programs, right-clicking, moving programs around on the screen, opening up programs, opening up file explorer especially and playing videos (always gets a trash frame-rate at the start- gradually gets better) all lagged in the video attached. (in case it wasn't noticeable). Can even see the mouse jump across the screen as I move it and the programs leaving short trails as I move them around. By the way, I re-watched the recording to make sure the recording software didn't add lag and stuff to the video when it was being processed. Everything you see in the video is what I saw during the recording. Also lag isn't usually 'as' bad as it is seen in the video - the screen recording application lowered the performance a bit.

                       

                      I have pretty much kept the laptop tethered to the charger since I got it about a month ago.

                       

                      The problem could be the gpu too I guess - the intel 630 ... task manager shows that it gets quite high in usage.. Still the cpu is performing terribly.

                      • 8. Re: 7700HQ - Why is it preforming so far below standard?
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hello Josepharduino,

                        Thank you for your response,

                        I was reviewing the troubleshooting done so far and it seems to point at a hardware problem. I am unable to determine exactly which component could be causing this issue so it is highly recommendable for you to get in contact with the OEM in this case Dell.

                        They should be able to check which component is giving you the problem and even if it was the processor which being completely honest does not seem to be the problem, they will replace it. 


                        Regards,
                        David V