7 Replies Latest reply on Feb 21, 2018 5:16 AM by Intel Corporation

    Re enable Optane Memory when can't access O/S (Windows 10 Pro)

    DaveSanderson

      In addition to previous discussion 'System won't restart after disabling Optane Memory

       

      Is there a way to re-enable Optane Memory when you can't access the Operating System (Windows 10 Pro) or the computer won't load Windows at boot?

       

      Thanks

       

      Dave

        • 1. Re: Re enable Optane Memory when can't access O/S (Windows 10 Pro)
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Dave,

           

          You can enable the Intel® Optane™ memory from your BIOS but this “enable” means that you set the Intel® Optane™ memory ready to be full enabled from the RST application in Windows*, so that it can be concatenated with the SATA drive.

           

          According to your description, you want to concatenate the module again with your HDD. If so, then it can only be done through the RST application (or the Intel® Memory™ application) which means you need to boot to Windows*.

           

          What is uncommon is how your system is not booting properly after disabling the Intel® Optane™ memory from the RST application. It looks similar to what this user described in this thread: Clone HDD+Optane to HDD+Optane

           

          What we can try to do is what that user did. He disabled the Intel® Optane™ memory from BIOS. Unfortunately, after doing this, the user lost his data as the partitions disappeared somehow. That’s not supposed to happen, however as this method has not been tested nor validated I’m not sure what the system response would be after doing this, so if you agree we can try it. Hopefully, the system will boot again and the Intel® Optane™ memory would be full disabled so that you can enable it again as you did the first time you setup the module.

           

          As we probably have different motherboards, I will describe the steps to disable the Intel® Optane™ memory from BIOS for the motherboard ASUS* Z270-P which is the one I have access to. You would have to look for these settings in your BIOS menu as these steps may not match 100% for your system:

           

          1. Go to the BIOS.
          2. Enter into the Advanced Mode. I do this by pressing F7.
          3. Go to a tab named as Advanced.
          4. Look for the option Intel® Rapid Storage Technology and enter into it.
          5. You should see your Intel® Optane™ memory. It may be displayed along with the text “PCIe xxx or Intel MEMPEK1W0. Enter into this option.
          6. Look for the option Disk Actions. There should be an option to reset the module. In my system it’s named as “Reset to non-Optane”. This option will reset the module and allow you to detect it as when you used it the first time.
          7. Save the changes and restart the system. Hopefully, Windows* will boot again without the Intel® Optane™ memory enabled.

           

          On the other hand, if you have access to the command prompt as you mentioned here: System wont restart after disabling Optane Memory , we may try to reset the Intel® Optane™ memory from there. Please follow this process first in case you have access to the command prompt:

          1. Run the command prompt as Administrator.
          2. Type diskpart and press Enter.
          3. Type list disk to display a list of your connected storage devices. You should be able to see the Intel® Optane™ memory. Please note the disk number.
          4. Type select Disk X and press Enter. Make sure to use the disk number from previous step instead of the X character.
          5. Type clean all and press Enter. Diskpart will proceed to low-level format the Intel® Optane™ memory. This process may take several minutes. There is no visual progress of this process so don’t close the command prompt yet. You will see the cursor blinking, wait until the cursor changes to close the command prompt.
          6. Restart the computer.

           

          Please keep in mind that these 2 methods are not for this particular issue, but it may help your system to boot again. These methods are usually followed when Windows* was reinstalled but the Intel® Optane™ memory wasn’t disabled beforehand. However, if we remove completely the link to the Intel® Optane™ memory, the system may boot normally (assuming that the issue is somehow related to the Intel® Optane™ memory).

           

          Let me know what the result is after following these steps. I’ll be waiting for your response.

           

          If you have any doubts, please feel free to ask.

           

          Have a nice day.

           

          Regards,
          Diego V.

          • 2. Re: Re enable Optane Memory when can't access O/S (Windows 10 Pro)
            DaveSanderson
            1. Go to the BIOS.
            2. Enter into the Advanced Mode. I do this by pressing F7.
            3. Go to a tab named as Advanced.
            4. Look for the option Intel® Rapid Storage Technology and enter into it.
            5. You should see your Intel® Optane™ memory. It may be displayed along with the text “PCIe xxx or Intel MEMPEK1W0. Enter into this option.
            6. Look for the option Disk Actions. There should be an option to reset the module. In my system it’s named as “Reset to non-Optane”. This option will reset the module and allow you to detect it as when you used it the first time.

            Hi Diego,

            Thanks for your reply.

            I followed your instructions up to step 5.

            On my Intel NUC7i7BNB Motherboard, under 'Devices', 'Add-In Config', I found IRST to configure. I selected the 'Configure' button, I got the IRST Screen.  Which indicated IRST version - 15.7.0.3054 RID Driver.

            Then it displayed -

            'Non-RAID Physical Disks:

            • SATA 0.0 HGST.... 1.3TB;
            • PCIe 1.0 Intel.... 27.2GB. 

             

            I selected the one named PCIe... Intel MEMPEK...

            I got the Physical Disk Info screen.  But there was NO 'Disk Actions', only a list of disk info:

            • Port:
            • Model Number:
            • Serial Number:
            • Size:
            • Status:
            • Controller Type:
            • Controller Interface:

            Non of these had a function that could be changed.  So I exited this screen back to IRST screen. Which I exited back to the Intel Visual BIOS, and looked at your second option:

            On the other hand, if you have access to the command prompt as you mentioned here: System wont restart after disabling Optane Memory , we may try to reset the Intel® Optane™ memory from there. Please follow this process first in case you have access to the command prompt:

            1. Run the command prompt as Administrator.
            2. Type diskpart and press Enter.
            3. Type list disk to display a list of your connected storage devices. You should be able to see the Intel® Optane™ memory. Please note the disk number.
            4. Type select Disk X and press Enter. Make sure to use the disk number from previous step instead of the X character.
            5. Type clean all and press Enter. Diskpart will proceed to low-level format the Intel® Optane™ memory. This process may take several minutes. There is no visual progress of this process so don’t close the command prompt yet. You will see the cursor blinking, wait until the cursor changes to close the command prompt.
            6. Restart the computer.

             

            I followed the above instructions to step 3 - two disks were listed:

            • Disk 0 - Online -1397 GB: - 1397 GB:  (This I presume is the Optane Memory Disk)
            • Disk 1 - Online - 14 GB - 0B:  {This I presume is a 16GB thumbdrive I have which is a Windows Media Installer disk.

            Step 4 instructs to select Disk 0 to clean.  This I presume will delete everything on the Optane Memory disk and my SATA disk.

            But, where possible, I don't want to lose all the info on the SATA disk - unless there is no choice.  So I have left my system at this point, until I hear further from you.

             

            Many thanks for your help so far.

             

            Dave.

            • 3. Re: Re enable Optane Memory when can't access O/S (Windows 10 Pro)
              DaveSanderson

              Incidentally, I performed the 'clean all' function to the Disk 1 drive that was listed in the 'Disk List' function, which was a 16Gb Thumb drive I was using as a boot drive, and was loaded with the 'Create Windows 10 Installation Media' Download Tool and with Windows 10 Pro program.

              Anyway, not only did the 'Clean All' clean all the data off the drive, the drive is now not recognized by Windows File Manager at all.  So I'm presuming if I 'Clean All' the Optane Memory drive, Disk 0, the same will happen and all data will be vamoooshed, and possibly not recognised by my system!!!!????????

               

              That is for your information and possibly something to take into account when preparing further instructions.  Then again, it may have no bearing on my problem above!?

               

              Regards,

               

              David

              • 4. Re: Re enable Optane Memory when can't access O/S (Windows 10 Pro)
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi David,

                 

                I did a quick test to show you how the Intel® Optane™ memory should look like when running Diskpart utility in the command prompt.  If the Intel® Optane™ memory is indeed disabled, you should see your SATA drive apart from the Intel® Optane™ memory as shown below.

                 

                Capture1.JPG

                On the other hand, if your Intel® Optane™ memory is enabled and therefore, concatenated with your SATA drive, you will see only one disk which is the SATA drive. The Intel® Optane™ memory won’t be visible because it’s currently concatenated with the SATA drive as one single drive, as shown in the image below.

                 

                Capture2.JPG

                According to your description, this is your case which means that the Intel® Optane™ memory wasn’t disabled properly when you previously ran the RST application in order to attempt to disable the module.
                As your SATA drive is still concatenated with the Intel® Optane™ memory, please do not run the Diskpart utility as I described in my previous post because you would be erasing the SATA drive data. I suggested that method because I thought the Intel® Optane™ memory was already disabled, but apparently it’s not.

                 

                Could you please check and confirm if you can find an option in your BIOS that says “Reset to non-Optane”? This option should be under Devices>Add-In Config where you went previously, not necessarily under the Intel® Optane™ memory entry itself, but in the menu in the Add-In Config section. This option will deconcatenate the Intel® Optane™ memory from your SATA drive.

                 


                Regarding to your thumb drive that was formatted when you ran the Diskpart utility.

                 

                It’s not recognized by Windows* probably because the drive has to be initialized first. In order to so, please open the Disk Management utility in Windows*. You can open it by clicking the Windows* key and the x key at the same time. Select Disk Management from the menu that will appear.

                 

                Capture3.JPG

                 

                Once you are in the Disk Management utility, you will see all drives connected and recognized. Your thumb drive should appear as a non-initialized device as in the image below. In order to initialize it, please right-click on it and select the initialize option as shown below.

                 

                Capture4.jpg


                Then, select the partition style. You can select MBR. Then click OK.

                 

                Capture5.jpg

                Now the drive is initialized but without any partition. In order to create a partition, double-click again on the disk and select New Simple Volume. Navigate through the wizard menu that will appear. There is no need to change anything so simply click Next until the end.

                 

                Capture6.jpg

                Finally, your drive should have a new partition and it should be recognized by Windows*.

                 

                Capture7.jpg

                 

                I hope this helps you. Please let me know if you can find the option “Reset to non-Optane” in your BIOS in order to deconcatenate the module.

                 

                I’ll be waiting for your response.

                Have a nice day.

                Regards,
                Diego V.

                • 5. Re: Re enable Optane Memory when can't access O/S (Windows 10 Pro)
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi David,

                   

                  I noticed that you are also working in this thread System wont restart after disabling Optane Memory to back up your files in order to save them and then proceed with a possible Windows* reinstallation.

                   

                  If you prefer, and to avoid confusions between threads, you can continue with the support in that thread as we already found in this one that the issue is because the Intel® Optane™ memory is still concatenated with your drive.

                   

                  Please let me know if this is fine for you so that this thread can be marked as answered.

                   

                  Have a nice day.

                   

                  Regards,
                  Diego V.

                  • 6. Re: Re enable Optane Memory when can't access O/S (Windows 10 Pro)
                    DaveSanderson

                    I noticed that you are also working in this thread System wont restart after disabling Optane Memory to back up your files in order to save them and then proceed with a possible Windows* reinstallation.

                     

                    If you prefer, and to avoid confusions between threads, you can continue with the support in that thread as we already found in this one that the issue is because the Intel® Optane™ memory is still concatenated with your drive.

                     

                    Please let me know if this is fine for you so that this thread can be marked as answered.

                    I think that will be fine, I'm just about to reinstall the OS - I'm 'full' of trying to work it all out - I think that's the best way to go - Mark this thread as being answered - and I'll see you on the other side!!

                     

                    Dave

                    • 7. Re: Re enable Optane Memory when can't access O/S (Windows 10 Pro)
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Hi Dave,

                      I understand. I’m sorry you had to reinstall Windows*, but I hope you can have the system working again after that.

                      If there is something you need help with, please don’t hesitate to open a new thread. We’ll try to help you in any way we can.

                      Have a nice day.

                      Regards,
                      Diego V.