0 Replies Latest reply on Feb 6, 2018 6:03 PM by dpastorm

    No HDMI on Joule 570x

    dpastorm

      Hello,

       

      I got a Intel Joule for Turtlebot 3 and I cannot display hdmi output. The first time I used the board I could connect a hdmi cable to see the bios and the pre-installed os, however, the instructions said to flash bios version 193 and I cannot see the hdmi output anymore. I tried several monitors and several cables that work with other devices, including the original pair of cable of monitor that made it work at the beginning.

      The flashing process didn’t give any errors. I also tried newer bios versions with same negative results.
      I can connect to the board using serial connection. It seems to recognize the display when I execute xrandr -q. If I reboot the board it displays the whole boot sequence. These are the last commands before stopping:

       

      [ 12.378641] Bluetooth: RFCOMM ver 1.11
      [ 12.820056] HDMI HDA Codec ehdaudio0D1: HDMI: failed to get afg sub nodes
      [ 12.827761] HDMI HDA Codec ehdaudio0D1: Failed in parse and map nid with err: -22
      [ 12.836166] HDMI HDA Codec: probe of ehdaudio0D1 failed with error -22

       

      It seems to be some sort of hdmi error. Any idea how to correct the issue?

      I tried to contact intel but they directed me to the newest bios which does not work.


      Thanks,

      Daniel