8 Replies Latest reply on Feb 8, 2018 11:20 AM by Intel Corporation

    Corrupted Partition Map: No longer boots: What do?

    grayfox

      I was about to flash and reinstall Ubuntu on my Euclid via thumb drive with the image already loaded and ready to go when I had an issue with one of the partitions on the thumb drive. I decided to wipe the partitions on the thumb drive, format it, and try to load the Ubuntu image again, except it turns out I was doing all this to the Euclid's partition table instead of the thumb drive.

       

      For anyone finding this doing a Google search in the future: The Euclid does NOT use sda for its internal storage. If you see something using sda, that's whatever storage you've plugged into it. Or at least, it was on mine, and AFAIK I didn't do anything to cause that. Continuing on...

       

      So I completely mucked up my Euclid's partition table, it won't boot, and I can't even get into BIOS to tell it to boot from external storage. When I fire it up, all I get is a static (read: NOT blinking) white underscore on a black background, nothing else. I try to press [F2], [DEL], [F12], all the usual suspects to get into BIOS, press physical buttons on the Euclid itself, nothing.

       

      I thought about physically tearing it down, pulling the internal storage and redoing the partitions by externally mounting that storage on another device, like my PC, but after watching the YouTube teardown video of the Euclid, it looks like the internal storage is soldered onto the board, so I wouldn't be able to do anything with that, anyway. So what are my options, here?

       

      Thanks!

       

      Edit: poor word choice. Clarification added.

        • 1. Re: Corrupted Partition Map: No longer boots: What do?
          MartyG

          The function key to access Euclid's BIOS is F5.  Can you try this first please and see if anything happens?  Thanks!

          • 2. Re: Corrupted Partition Map: No longer boots: What do?
            grayfox

            Yes, I just tried spamming F5 during boot, and no change. I was pretty sure that at some point before making my original post, I resorted to spamming every function key just to make sure it wasn't an odd one like F5, but I did it just now just to make sure. Still nothing :/

            • 3. Re: Corrupted Partition Map: No longer boots: What do?
              MartyG

              When trying to reinstall the OS on Euclid with an external storage stick, the ideal setup is to plug a USB hub device directly into the Euclid and then plug mouse and keyboard into the hub, as described by the diagram below.  The display should be connected to the HDMI port.

               

               

              If you are short of USB ports on the Euclid and do not have a hub, you could try connecting only the keyboard to it and booting up and pressing F5 to enter the Euclid BIOS.  You could then use keyboard controls to set the BIOS options instead of a mouse (e.g move through the options with the arrow keys).

               

              When the BIOS change to boot from USB stick has been done, you could try shutting the Euclid down, unplugging the keyboard and putting the boot stick in, then turning the Euclid back on.  When the Euclid has booted into Ubuntu, see if you can unplug the stick and put the keyboard back in to control the interface.  It's a bit of a juggle with these different devices, so you can see why they recommend using a USB hub with Euclid in the diagram!

               

              If the keyboard still does not respond ... are you using a wireless keyboard with a dongle that plugs into the USB port? I have never had success in entering the BIOS at boot-up with these and so always use a wired keyboard for such repairs.

              • 4. Re: Corrupted Partition Map: No longer boots: What do?
                grayfox

                Yep, that's exactly what I've done. I've already wiped and re-installed the Ubuntu image several times in the past, and that's exactly how I've done it every time. USB hub with 4 ports, wired KB&M on the first two ports, and a thumb drive with the Ubuntu image preloaded on the third port. I would boot into BIOS to change the boot order to boot my thumb drive before anything else, run the wipe and re-installation, then continue with my ROS work. This time though, I can't even get to BIOS. Within a second of the monitor getting signal, it goes straight to the black screen with a non-blinking underscore in the upper-left corner. No response from KB&M input, no response from buttons, nothing. I don't know if you're an Intel dev, or have access to any of their tools, but you can easily reproduce this by just deleting all the partitions on the Euclid while it's running (obviously not the EXT4 partition though, you literally can't do that while it's running), and reboot it. You'll undoubtedly see what I see.

                • 5. Re: Corrupted Partition Map: No longer boots: What do?
                  MartyG

                  I do not have a Euclid unfortunately, so I cannot run tests myself.

                   

                  In the second half of 2017 there was an issue with some Euclids where they would stop booting when they were connected to the power plate adapter.  I know that the Euclid team were investigating the problem to try to find out more about it and come up with a solution.  I haven't heard any more about their progress since then though.

                   

                  Re: Euclid will not power up.

                   

                  The information in the above link may give you a couple more options to try in order to eliminate the possibility of a power issue.

                  • 6. Re: Corrupted Partition Map: No longer boots: What do?
                    grayfox

                    Interesting. I'll give that a shot. I've been researching along the lines of "I deleted the EFI partition linux -windows," and I feel like I'm pulling on the right thread, but still unsure of how I could do this. I have a feeling that the Euclid doesn't have an actual BIOS, but instead uses EFI, and the EFI partition was undoubtedly one of the partitions that got wiped when I mistook the internal storage for my thumbdrive. If that's the case, is there a way I could grab an original image of the EFI partition, put it on some form of storage (like maybe an SD card?) and maybe I'll get lucky and it'll at least get me as far as the EFI config menu, where I can set my thumb drive with Ubuntu to boot, and then get a clean install? I'm an experienced C++ dev, and no stranger to Linux, but this is pretty well outside of anything I've had to do for any machine I've worked on, simply because if I screw up my machine's storage that badly, I can always pull the drive, mount it on another machine externally, and just wipe it and start from scratch. I've never so thoroughly broken a machine that I can't even get into BIOS :/

                    • 7. Re: Corrupted Partition Map: No longer boots: What do?
                      MartyG

                      A complete 2 GB Euclid restoration image that restores it to factory-default conditions can be downloaded from a link on the page linked to below.  Is this the one you have been using?

                       

                      Re: Restore Euclid / download software

                      • 8. Re: Corrupted Partition Map: No longer boots: What do?
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hello Grayfox,

                        If Marty's recommendation does not work, then, unfortunately, your Euclid is bricked and cannot be recovered. You can return it to Intel for a refund if this is the case.

                        Regards,
                        Jesus
                        Intel Customer Support