5 Replies Latest reply on Feb 2, 2018 3:55 PM by Intel Corporation

    MSI MOBO and Intel Optane Install

    Gunbunny

      So I recently went and got a 16GB Intel Optane memory chip. I've gone and installed it into my M.2 1 slot, enable the "M.2/Optane" Genie, I've installed both Intel RST 15.9 and then uninstalled and installed Intel Optane Memory at least 3x each. Windows 10 WHQL is enabled, as is M.2 remapping, as well as making the BIOS UEFI boot only. Also updated the firmware on my MSI board to the latest and greatest (1.2). I've gone and run diskpart using the "Clean" command to clean it and all to no avail. I'm able to see it in the Disk Manager as well as in RST as a PCIe drive. However the "Intel Optane" tab does not appear. I've looked for a "Disable CSM" but apparently that isn't a thing in MSI boards from what I've read, you want to enable Windows WHQL which is already done. What gets weird is when I run Intel Optane SW is that I can click through everything and hit "Enable". After that it goes to a fancy looking loading screen in which it assembles some cube. Let it sit there for a couple of hours (no initializing screen appears like in the install vid) and it will ask you to reboot as it's completed "Disabling" the Optane memory you just told it to enable..... Upon reboot if you go and run the Optane SW again the "Enable" button is still there. Please help. See attached picture for BIOS settings.

        • 1. Re: MSI MOBO and Intel Optane Install
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Gunbunny,

          Thank you for contacting our support community. We understand your situation regarding the  Intel® Optane™ Memory. 

          In order to better understand your situation, could you please confirm the following information: 

          *Please download and run the Intel® System Support Utility. Run the scan selecting "Everything." Save this report and upload.
          *Please attach the Optane™ logs located here: C:\Users\[your user name]\Intel\Logs
          *Could you please let us know the brand and model of your motherboard. 

          We look forward to hearing back from you.

          Regards,
          Junior M.

           

          • 3. Re: MSI MOBO and Intel Optane Install
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi Gunbunny,

            Thanks for the information provided. 

            Based on that, we found that your BIOS is set to legacy mode. Optane(TM) only supports the UEFI BIOS mode. In order to change the configuration, we recommend you to follow the next steps: 

             1- Backup all files on your system.

            2- Convert partition table from MBR to GPT with MBR2GPT.exe in order to allow the system to boot after the BIOS change: 

            A- Open Command Prompt with administrator privileges

            B- Issue the following command: mbr2gpt.exe /convert /allowfullOS

            3-Shut down and boot into your BIOS

            4- Press F7 to go to the advanced mode. 

            5- Go to Settings\Boot\ Boot configuration and check the following option: Boot Mode Select = UEFI

            6- Go to Settings\Advanvced\ Windows Os Configuration and make sure that the option that says Windows 8.1/10 WHQL Support is enabled. 

            7- Please go to settings\SATA Configuration and check the following options:

            -SATA Mode: "RAID/Optane™ Mode"
            -M.2 Genie: "Enabled"
            -M.2_1 - RST PCIe Storage Remapping: "Enabled"  
            -M.2_2 - RST PCIe Storage Remapping: "Enabled"  

            8- Press F10 to save changes and restart the system. 

            After that, you are supposed to be able to enable Optane(TM). In case you run into any issues, we recommend you to disconnect the other drives and only keep the Optane(TM) + the SATA boot drive. 

            Please let us know the outcome of your situation. 

            Regards.
            Junior M. 

            • 4. Re: MSI MOBO and Intel Optane Install
              Gunbunny

              Okay so here is what happened. :

              I went and tried to do MBR2GPT.exe using the switches you recommended and got the following error: Disk layout validation failed for disk 0.No matter how I tried it that's what came out. GPT was already assigned to the drive instead of MBR so I decided to move on.

               

              After confirming that all settings in the BIOS matched your recommendation I was still in the same place. SIDE NOTE: One thing I found interesting that was in the BIOS as well as in the MSINFO32 it stated UEFI boot but in your SSU log it stated "legacy".   like recommended I went and removed all other drives but the Optane Memory and the Boot Disk. Ran the Optane SW but had an error. Uninstalled it and installed RST, now had an Optane Memory Tab. Enabled Optane memory and reboot. BSOD stating it couldn't find boot device. Ran multiple Windows OS Troubleshooting utilities came up empty. Went into BIOS and it would appear that RST Software switched my BIOS storage setting from RAID to ACHI. Switched it back and all was happy. Shutdown the machine and re-connected the other RAIDS. Machine wouldn't boot and would come back to a screen that said something like F1-Run Setup, F2 - Default Values. Ran setup but no matter what kept coming back to that screen. Unplugged the other RAIDS and it would boot back to Windows just fine w/ Optane running. The only way I could get it to boot back into Windows was to go into by BIOS RST settings and delete my arrays. Boot to Windows and re-create the arrays while in the OS. Loosing data on my RAID 1 (not a big deal) but for some reason I couldn't create my RAID 0 now in RST. Eventually ended up leaving it torn down transferring data off to another drive, establishing mirror w/ Windows OS (Disk Manager). Then transferring the data back to the new OS controlled RAID. Now everything appears to finally be happy and quite the journey was had.... Happy with the caching thus far, but maybe I should have just done SSD? Thanks for the assist guys.

              • 5. Re: MSI MOBO and Intel Optane Install
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi Gunbunny,

                Thanks for the reply. 

                We are glad to hear that your situation has been resolved. 

                In order to answer your question, you can use the drive you prefer. If you use an NVMe* SSD you will not need the Optane(TM) because the performance benefit will be none to zero due to the technology. However, if you use a SATA Boot drive the performance benefit will be really high and it may reach similar speeds as an NVMe* SSD with the Optane(TM) benefit. 

                Please let us know if there is something else we can assist you with.

                Regards,
                Junior M.