4 Replies Latest reply on Feb 12, 2018 10:56 PM by Intel Corporation

    Flashing Intel X540-T2 with firmware

    RandomUser55

      Hi,

       

      I recently bought a (second hand) Intel X540-T2 network adapter for my DIY-NAS (my workstation already has one).

       

      Unfortunately, it seems to have problems booting on my ASUS Maximus 6 Gene board (Post code 55). I've narrowed down the problem to Dell's memory mapping of the firmware. It is a known problem with Dell X540-T2's and the Intel Z87/Z97 chipset when using 4 DIMMs. It can be fixed by removing on DIMM from the board, after which the board POSTs and boots without any problems. The Dell X540 does boots without any issues on the H110 and Z370 chipsets, even with all four DIMM slots populated.

       

      The card I intended to use for my workstation is a passive one (Intel OEM) and this one boots just fine of my ASUS M6G board. Considering both NICs have an identical board (aside from the fan header on the Dell one), I suspect that the Dell card will still work when I flash it with the unmodified Intel firmware, correct? This should solve the EFI memory mapping problem that I encounter on my NAS.

       

      Is what I'm trying to achieve possible? Or should I just get rid of the Dell X540 and buy a new OEM Intel card? I got the dell really cheap - and genuine X540's often go for over $300 used (not counting the potentially compromised chinese knock-offs)

      I've done a bit of Google-Fu, but couldn't find the native Intel firmware anywhere.

        • 1. Re: Flashing Intel X540-T2 with firmware
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi RandomUser55,

           Thank you for posting in Wired Communities. For Dell OEM network adapter, it is recommended to contact Dell the OEM vendor for firmware update and further support, as modification or alteration done on OEM network adapter is beyond our control. Please contact Dell* if you intend to upgrade the firmware on Dell OEM network card.

            Please do let me know if you have further clarification. Thanks.

          Regards,
          Sharon T

          • 2. Re: Flashing Intel X540-T2 with firmware
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi RandomUser55,

               Please let me know if you still have other inquiries and provide clarification below:

                You mentioned the Dell OEM version X540-T2 had the memory mapping on the firmware. Please help clarify also "The card I intended to use for my workstation is a passive one (Intel OEM) and this one boots just fine of my ASUS M6G board" Are you referring you have another X540-T2 and this is an Intel version? 

                 Please feel free to update me. Thank you.

            Thanks,
            Sharon T
             

            • 3. Re: Flashing Intel X540-T2 with firmware
              RandomUser55

              No, I'm only talking about the Dell X540-T2.

               

              It's firmware conflicts with the memory mapping on Z87 & Z97: when all 4 DIMM slotsare populated, the board refuses to POST - even though the setup works fine without the Dell X540-T2. My M6G remains stuck on POST code 55 ("Memory not installed").

               

              But when I only use 2 memory sticks, the board boots just fine and the card is recognised in the OS.

               

              Either way, it won't matter for me: the second card I bought for about £100 turned out to be a counterfeit - even though the seller guaranteed me it was a genuine card before I bought it. He showed me a invoice from a reseller that listed the serial number on the card, even though that card lacked a YottaMark sticker, wasn't recognised in the Intel warranty database, didn't have an Intel logo on the PCB and didn't have a sticker indicating where and when it was made (like Malaysia 12/2015).

               

              Seller gave me my money back and was very polite: turns out he got ripped off way harder than I did: he paid £350 ex VAT/card for a set of counterfeit cards. Either way, I'm left without a second 10GBase-T card - and one that doesn't work optimally in this system. I'll probably just pick up a set of SFP+ cards for my 10Gb/s connection.

               

              You might want to look into "AlteredImages", the seller of the counterfeits.

              invoice.png

              • 4. Re: Flashing Intel X540-T2 with firmware
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi RandomUser55,
                 
                    Thank you for the update and information. I am sorry to hear what happened but good to know the your point of purchase return the money back.  We will take note of the information you provided. 

                 It is recommended to purchase Intel network adapter from our authorized resellers, you may visit http://locate.intel.com for the list of Intel resellers. 

                    With regards to this Dell OEM NIC, please contact Dell for the firmware as OEM NIC vendor provides the firmware for the OEM card. 

                      Please let me know if further assistance needed. Thanks. 


                Regards,
                Sharon T