4 Replies Latest reply on Feb 1, 2018 2:16 PM by Intel Corporation

    Intel optane no longer detected by BIOs when RST Pcie Storage Remapping is enabled

    WaffleKing

      Several months ago I built a new PC using optane to accelerate my hard drive. It was a massive headache to get it to work, but I finally managed it.

       

      Recently I had to reinstall windows because of software issues. The new windows install works completely fine but when I tried to reinstall the optane software it said my BIOs didn't support optane. I checked my BIOs settings and saw that the SATA mode was somehow switched back to AHCI.

       

      I switched the SATA mode to RST and rebooted, however my system would no longer detect the optane M.2 module (the M.2 slot is listed as empty in BIOs). I found that disabling M2_1 - RST Pcie Storage Remapping allows my BIOs to detect the optane module in my M.2 slot, however as I understand it I need to enable remapping to use optane.

       

      So basically, in RST mode my BIOs will not detect the optane module in my M.2 slot unless RST Pcie Storage Remapping is disabled. optane module also properly shows up in the M.2 slot if the SATA mode is AHCI, but optane will only work when windows is installed with the SATA mode set as RST.

       

      Anyway, I re-installed windows a second time, this time with RST as the SATA mode. However, I can't install optane because it's not detected unless I disable storage remapping, which is required for optane to work.

       

      Bear in mind the motherboard is using the latest version of its BIOs, and optane WAS working properly on it before I reinstalled windows. It's an AsRock z270 ITX/ac board.

       

      Does anyone know what the solution for this problem is? Thank you.