2 Replies Latest reply on Jan 29, 2018 7:55 AM by Intel Corporation

    Intel ssd 540s M.2 freezing randomly (win10)

    agentpayne

      Hi INTEL support team !! I have intel ssd 540s M.2 120Gb wich is causing weird issues and I want you to help me to identify the cause of this.

      My motherboard is Asrcok A320M-DGS with the lastest bios version and the lastest ssd firmaware version.

      The pc is new and I started expericing theese freezing problems  after restarting it the ssd wasn't detected at startup so only way to turn pc was to power off button and on agan .I updated bios and  freezing still occurs but not with this „not found boot device“ after restarting now pc turns normaly without this error and then  I found that I am not using the lastest ssd firmaware so I updated it.Everying works just fine but the problem with freezing still remains and its like hard freeze mouse stop moving and keyboard does't work so only way is to restart pc.So after all theese monts of expericing this issues I think that this is not related to sleep/hibernate prosses because never occurs when pc goes to sleep or hibernate not problem at all .

      The main issues is causing random pc freezes when watcing you tube,playing music or instaling games there is no particular scenario that provokes freezing just happens randomly so its not related to sleep/hibernate issues .

      This occurs once a month or in worst case 2-3 per  month it depends how often pc is used.It is not a big problem but I would like to consult with you intel support team for any tips how to fix this issue.

      For  the final iI would like to ask some question:

      Is windows 10 option turn off hard disk to never affect ssd or only hdd and can it help resloving this issue or its bad ot turnt it off ?

      My motherboard has option called Agressive Sata device sleep set to auto .Can this cause ssd to freeze becasue of the mobo forcing ssd to go devsleep when its not needed ?

      Is devsleep controled by motherboard with this option or ssd itslef cotrols this option I would really like to know ?

      In my opinion this is devsleep issues with this particular ssd and motherboard but I want to hear your opinion thank you in advance intel support team!

        • 1. Re: Intel ssd 540s M.2 freezing randomly (win10)
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi agentpayne,

           

          According to your description, it’s possible that the BIOS doesn’t support the power management features used in this drive. It’s always recommended to update the BIOS to the latest version, but if you have already done it we can try to disable the fast startup option to see if there is a change in the behavior. Please follow these steps:

           

          1. In the Start Menu, search for Power Options and open it.
          2. Click Choose what the power buttons do on the left side of the window.
          3. Click Change settings that are currently unavailable.
          4. Under Shutdown settings, make sure Turn on fast startup is disabled.

           

          I also recommend you to double check if the SSD has the latest firmware. The latest firmware is the 041C, which includes some fixes and enhancements in power management features. Please double check the firmware version using the Intel® Solid State Drive Toolbox which is available in the following site: Download Intel® Solid State Drive Toolbox

           

          Additionally, please get the SMART attributes of your SSD so I can take a look at them, and the report from the Intel® System Support Utility as well. The SMART attributes can be obtained from the Intel® SSD Toolbox which you can download from the above link. The Intel® System Support Utility can be downloaded from this other link: Download Intel® System Support Utility for Windows* . This issue is not common, but these reports will help us to check if there is something unexpected with the SSD.

           

          Regarding to your other questions, check my comments below:

           

          1. You can avoid your drive from going to sleep by doing the following steps which is equivalent to choose the “never” option: 
            • Go to Power Options.
            • Click on Change plan settings next to your current power plan.
            • Click on Change advanced power settings.
            • In Hard disk > Turn off hard disk after, set On battery and Plugged in to zero.
          2. I’m not sure how the option Aggressive SATA Device Sleep affects the system, but it should not cause the freezing issue. Anyhow, I’ll investigate more about this feature to provide you a better response.
          3. The DevSleep feature is a feature of the SATA device which allows it to go into a low power state, therefore the SSD is the one that decides when to go into this low power state. What the motherboard does is to send a signal to wake up the SATA drive. When there are issues related to the DevSleep feature is usually because the motherboard is not sending properly the required signal to wake up the SSD.


          Please send me the reports of the SMART attributes and system information using the tools I mentioned above. In the meantime, I’ll keep investigating about the issue.

           

          I’ve checked some other threads where the users describe similar issues with the same SSD. There is not a resolution though, but you can check them too in case you want to know what other customers tried:

           

           

          I'll be waiting for your response.

           

          Have a nice day.

           

          Regards,
          Diego V.

          • 2. Re: Intel ssd 540s M.2 freezing randomly (win10)
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi agentpayne,

            I wasn’t able to get relevant information about the Aggressive SATA Device Sleep option, but I did find information about the Aggressive Link Power Management which is a power management protocol applied to SATA devices. It seems that this is the protocol used by this setting option, but it doesn’t tell the SSD when to enter into a low power state, so as far as I understood, you can leave the option set to Auto.

            I’d like to know if you have tried my previous suggestions, or if you have faced the issue again so far.

            Regards,
            Diego V.