9 Replies Latest reply on Mar 30, 2010 8:05 AM by gregg

    "Unknown" DX58SO mobo

    godomir

      Hi,

       

      I have a strange problem: I can not install Intel Desktop Control Center onto my DX58SO(Original Win7 Pro x64 OEM). The installer runs, but before the end of installation stop with the following message: "Error 1001: Motherboard detected is not a supported 'Intel(R) Extreme Series' motherboard.

      Another strange thing: when i run Intel Board Id Tool the 'Board Model' section is empty! I updated the BIOS from 4405 to 4598.

       

      Help me please! Thank You!

       

      G

        • 1. Re: "Unknown" DX58SO mobo
          Nico

          update to the latest bios using the recovery method, and use the latest version of IDCC

          • 2. Re: "Unknown" DX58SO mobo
            RJL190365

            Unfortunately, this is not the correct answer. The latest BIOS version has many bugs that earlier BIOS versions did not have. Also, the latest version of IDCC would not run properly or at all on many of the DX58SO-based systems even with the latest BIOS version.

             

            To the OP:

             

            Which processor do you have on your DX58SO? It is possible that you might have a processor which is not supported by either the 4405 or the 4598 BIOS versions. Or, you might have a Xeon processor installed - but IDCC will only run if you have a "consumer" i7 or i7 Extreme Edition processor.

            • 3. Re: "Unknown" DX58SO mobo
              Nico

              and why would it not work at all on the DX58SO?

              • 4. Re: "Unknown" DX58SO mobo
                RJL190365

                Sorry that I should have made it more clear. From what I read the latest release of IDCC has had serious problems, especially if a previous version of IDCC was installed at the time of update. In this case, then the latest release of IDCC would not even load at all. The only way to fix this would be to completely uninstall any previous version of IDCC manually before you start installing the latest version. Letting IDCC setup automatically installing a newer version over the old version will still leave old files which will conflict with the newer version's software.

                • 5. Re: "Unknown" DX58SO mobo
                  godomir

                  I've already updated the latest bios version (5020), but the system didn't boot. I had to recovery the previously latest revision from a bootable cd. I tried a lot of different version of IDCC but the results are 'Error 1001'.

                  • 6. Re: "Unknown" DX58SO mobo
                    godomir

                    I have a Core i7 920 Retail version; Corsair XMS 6Gbyte RAM and Sapphire Radeon HD 4890.

                    • 7. Re: "Unknown" DX58SO mobo
                      gregg

                      5020 works but I had to go back, load optimized defaults, and then flash.

                      Only change, 135 is the new 133.

                       

                      And complete uninstall of the older control center before installing new version.

                       

                      I was using Crucial (still am) but replaced with Ballistix 1600 kit.

                      DX58SO and 920 D0 GTX 260/216 WD VelociRaptor (3) RAID

                      using latest Intel Maxtrix Storage.

                      • 8. Re: "Unknown" DX58SO mobo
                        godomir

                        With 5020 the screen was black. I could not load optimized defaults. I can't install any version of IDCC.  

                        • 9. Re: "Unknown" DX58SO mobo
                          gregg

                          So you are saying no video at all so you can't get early video?

                          Don't suppose you have another video card to play with?

                          I did notice the BIOS screen is different looking, but works.

                           

                          I assume most people are on UPS - great protection, and enough so even if power went by accident, your system would have 5 minutes at least to complete flashing.

                           

                          I had trouble with mouse, not know after flashing, but seems like looking defaults and then BIOS update did the trick, and my DX is from June/July.