6 Replies Latest reply on Jan 21, 2018 9:12 PM by N.Scott.Pearson

    NUC6CAYH can't find SATA/AHCI Drivers

    Jonesy433

      Hi,

       

      Cant seem to find drivers for the SATA AHCI Controller other than the standard Windows drivers. I have windows 10 fully updated and have tried various Intel INF packages etc. Any ideas? I find it strange that I would be stuck with the standard driver and not getting the most out of my SSD.

       

      Can people have a look to see what driver they are running for SATA controller please?

      CheersNew Bitmap Image.bmp

        • 1. Re: NUC6CAYH can't find SATA/AHCI Drivers
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Jonesy433

          Thank you for joining the community

          Looking in for the information you have provided and into the NUC drivers I was able to find a chipset driver 10.1.1.35, you can see the information on the following link.
           

          https://downloadcenter.intel.com/download/26802/NUCs-Intel-Chipset-Device-Software-for-Intel-NUC-Kit-NUC6CAYH-NUC6CAYS

          Have you tried to contact Microsoft I order to verify what features of the SSD are not going to be available with their driver?
           
          Regards,
           
          Leonardo C.
           

          • 2. Re: NUC6CAYH can't find SATA/AHCI Drivers
            N.Scott.Pearson

            Intel does not provide a separate device driver for SATA/AHCI devices; you use the standard SATA/AHCI device driver that is supplied by Microsoft. When you install the Chipset Device software package (as Leonardo has suggested), it does not actually install any device drivers. Instead, what it is doing is installing information (.INF) files that will configure the Microsoft-supplied device driver to work optimally with the Intel SATA controllers.

             

            Provided you have the Intel Chipset Software package installed, any SSD device(s) that you have connected to Intel's SATA controllers will be optimally supported by the Microsoft-supplied device driver. If the SSD device has vendor-specific features that go beyond the "standard" SATA/AHCI capabilities, you would use the vendor-supplied configuration tool and/or a vendor-supplied device driver to manage these features. I would add that this is a rarity. Bottom line, getting a device driver from Intel will not add any additional capabilities nor will it improve performance. If your SSD has additional features, look to the SSD vendor for their management.

             

            While it doesn't have any bearing on the situation with the NUC6CAY NUCs (since it doesn't support this capability), for completeness I will provide some additional information: In other NUC models - especially those that support M.2 NVMe SSDs - it is possible that there is a vendor-specific device driver that you need to optimally support this SSD. I know, for example, that both Samsung and Toshiba/OCZ offer their own device drivers for working with their NVMe SSDs. If you find such device drivers, use them.

             

            Hope this helps,

            ...S

            • 3. Re: NUC6CAYH can't find SATA/AHCI Drivers
              Jonesy433

              Thanks for confirming that there is not an Intel Driver for the SATA controller. I can now at least stop looking. I still feel however that performance of my Intel SSD may be way down due to the "Standard" driver. 4k Random writes are more than half the speed of my other Intel & Samsung SSDs running on Intel Drivers.

              • 4. Re: NUC6CAYH can't find SATA/AHCI Drivers
                N.Scott.Pearson

                Oh, I carefully didn't say that there wasn't another driver from Intel. There is, but you have to install the Intel RST package to get it. I am saying that this driver won't make an appreciable difference in performance. Still, if you want to try and prove me wrong, feel free to try it out.

                 

                ...S

                • 5. Re: NUC6CAYH can't find SATA/AHCI Drivers
                  Jonesy433

                  Intel RST wouldn't install. "Platform not supported"

                  • 6. Re: NUC6CAYH can't find SATA/AHCI Drivers
                    N.Scott.Pearson

                    Oh darn, I didn't catch that we are talking about the AY NUC. This NUC has an Apollo Lake SOC. Intel RST is not supported on this processor; you are stuck with the Microsoft-provided driver. I am wondering if I realized this the first time I responded and thus didn't bring up the RST possibility. Sorry to thrash you the second time.

                    ...S