6 Replies Latest reply on Jan 14, 2018 12:38 AM by mint13

    No HDMI audio after Ubuntu 14.04 pdates

    mint13

      Hi, I hope someone can help me solving an issue with the HDMI audio on my STCK1A8LFC. It was probably unwise, but I updated (not upgraded) the Ubuntu 14.04 OS after a long time of not updating. After all the updates the system boots fine, but the HDMI audio does not work. It worked before the updates.

       

      After booting Ubuntu 14.04, a window appears requesting for authentication to run '/usr/bin/env' as the super user. The "Action" is "org.freedesktop.policykit.exec", with "Vendor" being "The PolicyKit Project". After authentication, the "OEM LTS Installer" gives a warning: "Current LTS enablement stack will not be supported anymore so it needs to upgrade to the latest LTS enablement stack." Then the "OEM LTS Installer" updates Debian packages, upgrades LTS enablement stack, and reports:

       

      Failed!

       

      Check /var/log/oem-lts-stacks-installer.log for details.

       

      So, I checked this log (attached) and these are the crucial lines:

       

      Package 'oem-audio-i915-baytrail-dkms' is not installed, so not removed

      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

      1 not fully installed or removed.

      After this operation, 0 B of additional disk space will be used.

      Setting up oem-hdmi-audio-dkms (0.1) ...

      Removing old oem-hdmi-audio-0.1 DKMS files...

       

      ------------------------------

      Deleting module version: 0.1

      completely from the DKMS tree.

      ------------------------------

      Done.

      Loading new oem-hdmi-audio-0.1 DKMS files...

      First Installation: checking all kernels...

      Building only for 4.4.0-104-generic

      Building for architecture x86_64

      Building initial module for 4.4.0-104-generic

      Error! Bad return status for module build on kernel: 4.4.0-104-generic (x86_64)

      Consult /var/lib/dkms/oem-hdmi-audio/0.1/build/make.log for more information.

      dpkg: error processing package oem-hdmi-audio-dkms (--configure):

      subprocess installed post-installation script returned error exit status 1

      Processing triggers for initramfs-tools (0.103ubuntu4.9) ...

      update-initramfs: Generating /boot/initrd.img-4.4.0-104-generic

      Errors were encountered while processing:

      oem-hdmi-audio-dkms

       

      So, I consulted this "make.log" (attached), and find:

       

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c: In function 'intel_audio_codec_enable':

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c:533:3: error: too few arguments to function 'acomp->audio_ops->pin_eld_notify'

         acomp->audio_ops->pin_eld_notify(acomp->audio_ops->audio_ptr, (int) port);

         ^

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c: In function 'intel_audio_codec_disable':

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c:560:3: error: too few arguments to function 'acomp->audio_ops->pin_eld_notify'

         acomp->audio_ops->pin_eld_notify(acomp->audio_ops->audio_ptr, (int) port);

         ^

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c: At top level:

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c:756:2: warning: initialization from incompatible pointer type [enabled by default]

        .sync_audio_rate = i915_audio_component_sync_audio_rate,

        ^

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c:756:2: warning: (near initialization for 'i915_audio_component_ops.sync_audio_rate') [enabled by default]

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c:757:2: warning: initialization from incompatible pointer type [enabled by default]

        .get_eld = i915_audio_component_get_eld,

        ^

      /var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.c:757:2: warning: (near initialization for 'i915_audio_component_ops.get_eld') [enabled by default]

      make[2]: *** [/var/lib/dkms/oem-hdmi-audio/0.1/build/intel_audio.o] Error 1

      make[1]: *** [_module_/var/lib/dkms/oem-hdmi-audio/0.1/build] Error 2

      make[1]: Leaving directory `/usr/src/linux-headers-4.4.0-104-generic'

      make: *** [all] Error 2

       

      How to solve this?

        • 1. Re: No HDMI audio after Ubuntu 14.04 pdates
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello  mint13
           
          Thank you for contacting Intel Technical Support,
           
          I received your inquiry and I understand that you are having problems HDMI® audio. Please accept our apologies for any inconvenience this may be causing. I will be more than happy looking for a solution.
           
          While doing a search on the problem that you are having I have found that the Intel® Compute Stick STCK1A8LFC is out of interactive support, you can verify this information on the following link:
           
          https://ark.intel.com/products/86613/Intel-Compute-Stick-STCK1A8LFC
           
          In order to assist you in my best effort, we can try to review if the BIOS is up to date, here you can review the list of BIOS that are available
           
          https://downloadcenter.intel.com/search?keyword=STCK1A8LFC
           
          You also may want to review the Ubuntu communities for any driver solution or the following link: https://01.org/
           
          Regards,
           
          Leonardo C

          • 2. Re: No HDMI audio after Ubuntu 14.04 pdates
            mint13

            Hello Leonardo C,

             

            Thank you for your response to my question. Yes, I understand that this stick is not supported anymore and therefore appreciate any assistance.

             

            My description of the problem clearly indicates errors involving an HDMI audio package and the linux kernel, which doubtlessly is the root of the problem of no HDMI audio. The BIOS is fine (audio worked before updating the Ubuntu 14.04 OS).

             

            I am unable to find a solution on the site you linked to. Of course, I tried to find a solution on other (Ubuntu) forums, and I understand that Linux HDMI support for this stick is not standard, and that some kind of patch is required for the kernel. I was hoping to find someone with such specialist knowledge here, on this forum.

             

            Thanks again.

            • 3. Re: No HDMI audio after Ubuntu 14.04 pdates
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello mint13 
               
              We apologize for the inconvenience since you were not able to get a solution on the Ubuntu forum seems that the best way we can proceed to find a solution is with these options:
               

              • Complete OS reinstalled using Operating System Recovery [F8]
              • Complete a clean installation of the OS  using your own copy of the OS (is recommended to use Ubuntu 14.04)
               
              Regards
               
              Leonardo C.
              • 5. Re: No HDMI audio after Ubuntu 14.04 pdates
                linuxium

                If you were using the original Ubuntu 14.04 that came on the STCK1A8LFC then the kernel was v3.16 and HDMI audio was provided by a DKMS package. When you 'updated' it actually 'upgraded' the LTS enablement stack from v3.16 to v4.4 as v3.16 was EOL. However as the DKMS package had a dependency on v3.16 failed when trying to build with the new v4.4 kernel. You can fix all this but it will be simpler to perform a fresh install having first saved any user files.

                 

                First in terms of OS flavour, personally I don't recommend Ubuntu on the STCK1A8LFC as it is too resource hungry for the device's specification. You will find that Lubuntu works much better.

                 

                Second in terms of OS release for HDMI audio to work you will want a release that supports the v4.11 kernel as a minimum as this contains the audio patches but because you have a STCK1A8LFC then you need the v4.12 kernel as a minimum as it contains the RTL8723BS wifi module. So you are looking at Ubuntu 16.04 running the upcoming HWE Stack (hwe-edge).

                 

                Third in terms of OS security following the public release of the Meltdown and Spectre vulnerabilities you need a kernel that includes fixes for Meltdown as a minimum. Unfortunately Canonical hasn't released their fixed kernels yet so you can either install the latest hwe-edge kernel for 16.04 or wait (likely only another 24 hours) for the updated and fixed kernel which, just to add to the confusion, will be the hwe kernel as the v4.10 hwe is being made EOL early so hwe will go to v4.13 early as a consequence.

                 

                Fourth in terms of OS booting and functionality you will need to ensure the BIOS setting for a 64-bit bootloader is selected (for OS select Ubuntu 14.04) if you install an official Ubuntu or Ubunto flavoured ISO and then you will need to add the Bluetooth userspace files for Bluetooth to function correctly.

                 

                I have written a script called 'isorespin.sh' that simplifies some of the above steps by respinning an official ISO and allows it to be updated. For example you can upgrade the kernel and include the necessary Bluetooth files prior to creating a LiveUSB from the respun ISO. For example I'd download and respin the Lubuntu 16.04.3 ISO using the invocation of '-i <path to>lubuntu-16.04.3-desktop-amd64.iso --atom --rolling-release-hwe -s 200MB' for the STCK1A8LFC. Having written the newly created ISO to a USB I'd then boot from the USB, resize the persistence partition to fully use all remaining space on the USB, then copy any user files from the STCK1A8LFC to the USB persistence partition, perform the installation and then copy back the saved user files to the newly created install. You can find more details including the download URL on my blog.

                • 6. Re: No HDMI audio after Ubuntu 14.04 pdates
                  mint13

                  Many thanks for your insightful answer. I will try the method that you suggest.