1 Reply Latest reply on Dec 25, 2017 12:48 PM by Al Hill

    Intel DP35DP does not POST with RX560

    Tuscany

      Hi guys,

       

      I need a bit of support - I have Intel DP35DP motherboard with the latest available BIOS.

      I bought AMD RX560 but unfortunately the PC does not want to POST - the fans are spinning but no beep or sigh of life. I have tested the machine with another card and the machine is working properly. I have also tested the RX560 on another PC and it is working fine.

      Could it be that the MB does not support latest AMD series? I have enabled UEFI Boot in BIOS.

        • 1. Re: Intel DP35DP does not POST with RX560
          Al Hill

          It is more likely that the RX560 is not fully backward compatible with your old motherboard.

           

          The motherboard is PCIe x16 2.0, and your RX560 is PCIe x16 3.0 (and is claiming backward compatibility).

           

          There was no way for the DP35DP to predict the future.

           

          So, contact the manufacturer of the RX560 and ask them why it does not work.  Perhaps they have a firmware update for the card (which I doubt).

           

          Or, find a card that is truly backward compatible.

           

          Or, get a new board.  Even if you do find a card that is backward compatible, you will always be running in a degraded mode.

           

          A nice, new, shiney graphics card deserves a nice new board.

           

          Doc