14 Replies Latest reply on Jan 17, 2018 7:14 AM by Intel Corporation

    Help with error "Error: The firmware update process encountered an error (10/53)."

    Benson.Chan

      I have got a 600P 256GB M.2 SSD, but I could not perform firmware update via Intel® Solid State Drive Toolbox as an error popped up "Error: The firmware update process encountered an error (10/53)." I rebooted my computer and tried again as per the recommendation following the error, it was still not successful.

       

      So, I downloaded SSD Firmware Update Tool with iso format and loaded it into a bootable USB flash memory. After booting my device with the USB and running it automatically, I could only see a black screen with message "Out of Range" on my monitor. I waited for more than half an hour and did not see any pop-up or message for updating successful, so that I rebooted my PC again.

       

      I confirmed my Win10 64bit system is up-to-date and attached Intel Logs as well. May I know what action should I take then? Thanks.