10 Replies Latest reply on Dec 22, 2017 12:29 PM by Espen

    SSD Data Center tool in ESXi not detecting NVMe SSD DC P4500

    virtualtran

      Hi,

       

      I'm setting up an all-flash vSAN 6.6 platform and my capacity tier is Intel DC P4500 SSDPE2KX020T7 NVMe drives with firmware QDV1013D.  vSAN shows warning on controller firmware in health check, it recommends VDV10110.  I installed SSD Data Center Tool version 3.0.9 (tried older versions too) onto ESXi 6.5 U1 to update firmware but it does not work.  Here are the steps per instructions:

       

      esxcli software acceptance set --level=CommunitySupported

      esxcli software acceptance get

      CommunitySupported

       

      esxcli software vib install -v /tmp/intel_ssd_data_center_tool-3.0.9-400.vib

       

      esxcli software vib list | grep intel

      intel_ssd_data_center_tool     3.0.9-400                            Intel   CommunitySupported  2017-12-18

       

      cd /opt/intel/isdct

      ./isdct show -intelssd

      No results

       

      Enable logging:

      ./isdct set -system LogFile = 'log.txt'

       

      ./isdct set -system EnableLog = 'true'

      Set EnableLog successful.

       

      ./isdct show -intelssd

      No results

       

      more log.txt

      21:22:08:164981 [debug] tdk_interface_dll.cpp(259) SendXMLMessage: Entering

      21:22:08:167676 [debug] TDKInterface.cpp(522) scan: Entering

      21:22:08:167697 [debug] DeviceFinder_NVME.cpp(63) scan: Entering

      21:22:08:167709 [debug] DeviceFinder_NVME.cpp(100) scanPhysicalDevices: Entering

      21:22:08:167854 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:167883 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme0

      21:22:08:167950 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:167966 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme1

      21:22:08:168013 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:168027 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme2

      21:22:08:168072 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:168086 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme3

      21:22:08:168129 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:168144 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme4

      21:22:08:168187 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:168202 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme5

      21:22:08:168245 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:168259 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme6

      21:22:08:168303 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:168317 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme7

      21:22:08:168360 [error] Connection_Path.cpp(91) open: vmk_MgmtUserInit error: 19

      21:22:08:168374 [error] DeviceFinder_NVME.cpp(134) scanPhysicalDevices: Failed to connect to device. Ignoring intel-nvme8

       

      Any ideas how I can go about updating the firmware so that vSAN can verify it?  TIA!